summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-09-10 13:08:47 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-09-10 13:08:47 +0000
commita230c073018d24db3c99c55fc629937907a62e88 (patch)
treee2288229f9a42070319db1177d64944d92ce4b33 /x11-drivers/xf86-input-synaptics
parentSparc stable --- Bug #220739 --- seems to work fine. (diff)
downloadgentoo-2-a230c073018d24db3c99c55fc629937907a62e88.tar.gz
gentoo-2-a230c073018d24db3c99c55fc629937907a62e88.tar.bz2
gentoo-2-a230c073018d24db3c99c55fc629937907a62e88.zip
Add explosion avoidance to the driver, upstream patch found by Kamil Kamiński <kamil@mrblur.net>. Closes bug #237074.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5-00131-g5f17cfc-dirty x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-synaptics/files/synaptics-fix-explosion.patch13
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1-r1.ebuild69
3 files changed, 90 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index 67c813908583..36cb4ffea54f 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.8 2008/09/08 11:47:07 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.9 2008/09/10 13:08:46 chainsaw Exp $
+
+*xf86-input-synaptics-0.15.1-r1 (10 Sep 2008)
+
+ 10 Sep 2008; <chainsaw@gentoo.org> +files/synaptics-fix-explosion.patch,
+ +xf86-input-synaptics-0.15.1-r1.ebuild:
+ Add explosion avoidance to the driver, upstream patch found by Kamil
+ Kamiński <kamil@mrblur.net>. Closes bug #237074.
08 Sep 2008; Joseph Jezak <josejx@gentoo.org>
xf86-input-synaptics-0.15.1.ebuild:
diff --git a/x11-drivers/xf86-input-synaptics/files/synaptics-fix-explosion.patch b/x11-drivers/xf86-input-synaptics/files/synaptics-fix-explosion.patch
new file mode 100644
index 000000000000..90d8729d3d51
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/files/synaptics-fix-explosion.patch
@@ -0,0 +1,13 @@
+diff -uNr xf86-input-synaptics-0.15.1.ORIG/src/synaptics.c xf86-input-synaptics-0.15.1/src/synaptics.c
+--- xf86-input-synaptics-0.15.1.ORIG/src/synaptics.c 2008-09-10 13:54:55.000000000 +0100
++++ xf86-input-synaptics-0.15.1/src/synaptics.c 2008-09-10 13:56:19.000000000 +0100
+@@ -176,7 +176,8 @@
+ device = xf86FindOptionValue(local->options, "Device");
+ if (!device) {
+ device = xf86FindOptionValue(local->options, "Path");
+- xf86ReplaceStrOption(local->options, "Device", device);
++ if (device)
++ xf86ReplaceStrOption(local->options, "Device", device);
+ }
+ if (device && strstr(device, "/dev/input/event")) {
+ #ifdef BUILD_EVENTCOMM
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1-r1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1-r1.ebuild
new file mode 100644
index 000000000000..940f19801951
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1-r1.ebuild,v 1.1 2008/09/10 13:08:46 chainsaw Exp $
+
+inherit toolchain-funcs eutils linux-info x-modular
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+LICENSE="MIT"
+IUSE="hal"
+RDEPEND="x11-libs/libXext
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ !x11-drivers/synaptics
+ x11-base/xorg-server
+ x11-proto/inputproto
+ >=sys-apps/sed-4"
+
+evdev-input_check() {
+ # Check kernel config for required event interface support (either
+ # built-in or as a module. Bug #134309.
+
+ ebegin "Checking kernel config for event device support"
+ linux_chkconfig_present INPUT_EVDEV
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "Synaptics driver requires event interface support."
+ ewarn "Please enable the event interface in your kernel config."
+ ewarn "The option can be found at:"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " -*- Generic input layer"
+ ewarn " <*> Event interface"
+ ewarn
+ ewarn "Then rebuild the kernel or install the module."
+ epause 5
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ evdev-input_check
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ # Fix to handle multiple screens through Xinerama properly. Bug #206614.
+ epatch "${FILESDIR}"/synaptics-fix-xinerama.patch
+ # Fix to not explode if no device and/or path are specified. Bug #237074.
+ epatch "${FILESDIR}"/synaptics-fix-explosion.patch
+}
+
+src_install() {
+ DOCS="INSTALL NEWS TODO README"
+ x-modular_src_install
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd "${FILESDIR}"/rc.init syndaemon
+ newconfd "${FILESDIR}"/rc.conf syndaemon
+
+ if use hal ; then
+ # Have HAL assign this driver to supported touchpads.
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ doins "${FILESDIR}"/11-x11-synaptics.fdi
+ fi
+}