summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-01-04 02:35:27 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-01-04 02:35:27 +0000
commit4e5c5990a3e1044fadb70e09855857fda1f0d901 (patch)
tree9bf2fd309286a507491f08cb7904783f127ca3a6 /x11-drivers/xf86-input-wacom
parentVersion bump. (diff)
downloadgentoo-2-4e5c5990a3e1044fadb70e09855857fda1f0d901.tar.gz
gentoo-2-4e5c5990a3e1044fadb70e09855857fda1f0d901.tar.bz2
gentoo-2-4e5c5990a3e1044fadb70e09855857fda1f0d901.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.19.0.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 3292a4e28c63..1e2f656ffd23 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.68 2013/01/01 14:57:57 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.69 2013/01/04 02:35:27 chithanh Exp $
+
+*xf86-input-wacom-0.19.0 (04 Jan 2013)
+
+ 04 Jan 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xf86-input-wacom-0.19.0.ebuild:
+ Version bump.
01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> xf86-input-wacom-0.18.0.ebuild:
Add ~alpha, wrt bug #449220
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.19.0.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.19.0.ebuild
new file mode 100644
index 000000000000..28f3ef88980a
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.19.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.19.0.ebuild,v 1.1 2013/01/04 02:35:27 chithanh Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr
+ x11-libs/libXinerama"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable debug)
+ )
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${ED}"/usr/share/hal
+}
+
+pkg_pretend() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}