summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-13 12:21:56 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-13 12:21:56 +0000
commitb2962038a0fdefb9538220dc20e5ecc6ee5dac9e (patch)
tree68fd9fa880d1aaea175ee9fb50271815bf38bcf4 /x11-drivers/xf86-input-wacom
parentDrop sparc keywords (diff)
downloadgentoo-2-b2962038a0fdefb9538220dc20e5ecc6ee5dac9e.tar.gz
gentoo-2-b2962038a0fdefb9538220dc20e5ecc6ee5dac9e.tar.bz2
gentoo-2-b2962038a0fdefb9538220dc20e5ecc6ee5dac9e.zip
Remove USE="hal" since it's not present in stable X.org server anymore.
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog10
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild58
2 files changed, 66 insertions, 2 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index a21da349b998..598a9bc9ed76 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.29 2010/12/25 20:17:58 fauli Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.30 2011/02/13 12:21:56 ssuominen Exp $
+
+*xf86-input-wacom-0.10.8-r1 (13 Feb 2011)
+
+ 13 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ +xf86-input-wacom-0.10.8-r1.ebuild:
+ Remove USE="hal" since it's not present in stable X.org server anymore.
25 Dec 2010; Christian Faulhammer <fauli@gentoo.org>
xf86-input-wacom-0.10.8.ebuild:
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild
new file mode 100644
index 000000000000..d13f1a2305db
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.8-r1.ebuild,v 1.1 2011/02/13 12:21:56 ssuominen Exp $
+
+EAPI=3
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+HOMEPAGE="http://linuxwacom.sourceforge.net/"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug"
+
+RDEPEND="!x11-drivers/linuxwacom
+ >=x11-base/xorg-server-1.7
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXrandr"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ x11-proto/kbproto
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_install() {
+ xorg-2_src_install
+
+ rm -rf "${D}"/usr/share/hal
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}