summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-05-14 17:42:41 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-05-14 17:42:41 +0000
commit6cf9d49ac55bda3a7864b2246c09ae40dfd5a840 (patch)
tree1541c6445e052923e9b8a2283ed25f2b0b166c6f /x11-drivers/xf86-video-ati
parentadd a patch to build with latest poppler, bug #269544 (diff)
downloadgentoo-2-6cf9d49ac55bda3a7864b2246c09ae40dfd5a840.tar.gz
gentoo-2-6cf9d49ac55bda3a7864b2246c09ae40dfd5a840.tar.bz2
gentoo-2-6cf9d49ac55bda3a7864b2246c09ae40dfd5a840.zip
Restore back some versions of the driver to let users choose. Per bug #264461.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.10.0.ebuild57
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.11.0.ebuild57
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild57
4 files changed, 178 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 57189f3bc831..4969585d162d 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.87 2009/05/14 17:18:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.88 2009/05/14 17:42:41 scarabeus Exp $
+
+ 14 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
+ +xf86-video-ati-6.9.0.ebuild, +xf86-video-ati-6.10.0.ebuild,
+ +xf86-video-ati-6.11.0.ebuild:
+ Restore back some versions of the driver to let users choose. Per bug
+ #264461.
14 May 2009; Tomas Chvatal <scarabeus@gentoo.org>
xf86-video-ati-6.6.3.ebuild, xf86-video-ati-6.8.0-r1.ebuild,
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.10.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.10.0.ebuild
new file mode 100644
index 000000000000..855ef0156107
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.10.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.10.0.ebuild,v 1.5 2009/05/14 17:42:41 scarabeus Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular eutils
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+#SRC_PATCHES="http://dev.gentooexperimental.org/~scarabeus/${PV}-patches-01.tar.bz2"
+SRC_URI="${SRC_URI}
+ ${SRC_PATCHES}"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ >=x11-libs/libdrm-2
+ >=x11-misc/util-macros-1.1.3
+ x11-proto/fontsproto
+ x11-proto/glproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86driproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+"
+CONFIGURE_OPTIONS="--enable-dri"
+
+#PATCHES=""
+
+src_unpack() {
+ x-modular_src_unpack
+ if [[ -n "${SRC_PATCHES}" ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "If you have a mach64 or r128 video card, read this"
+ ewarn "The mach64 and r128 drivers moved to their own packages,"
+ ewarn "xf86-video-mach64 and xf86-video-r128. If these weren't installed"
+ ewarn "automatically by xorg-server and you have one of these cards,"
+ ewarn "check your VIDEO_CARDS settings."
+ ebeep
+ epause
+}
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.11.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.11.0.ebuild
new file mode 100644
index 000000000000..debf8d1251fc
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.11.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.11.0.ebuild,v 1.4 2009/05/14 17:42:41 scarabeus Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular eutils
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+#SRC_PATCHES="http://dev.gentooexperimental.org/~scarabeus/${PV}-patches-01.tar.bz2"
+SRC_URI="${SRC_URI}
+ ${SRC_PATCHES}"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ >=x11-libs/libdrm-2
+ >=x11-misc/util-macros-1.1.3
+ x11-proto/fontsproto
+ x11-proto/glproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86driproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+"
+CONFIGURE_OPTIONS="--enable-dri"
+
+#PATCHES=""
+
+src_unpack() {
+ x-modular_src_unpack
+ if [[ -n "${SRC_PATCHES}" ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "If you have a mach64 or r128 video card, read this"
+ ewarn "The mach64 and r128 drivers moved to their own packages,"
+ ewarn "xf86-video-mach64 and xf86-video-r128. If these weren't installed"
+ ewarn "automatically by xorg-server and you have one of these cards,"
+ ewarn "check your VIDEO_CARDS settings."
+ ebeep
+ epause
+}
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild
new file mode 100644
index 000000000000..06830cfa82e6
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild,v 1.6 2009/05/14 17:42:41 scarabeus Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular eutils
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+#SRC_PATCHES="http://dev.gentooexperimental.org/~scarabeus/${PV}-patches-01.tar.bz2"
+SRC_URI="${SRC_URI}
+ ${SRC_PATCHES}"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ >=x11-libs/libdrm-2
+ >=x11-misc/util-macros-1.1.3
+ x11-proto/fontsproto
+ x11-proto/glproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86driproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+"
+CONFIGURE_OPTIONS="--enable-dri"
+
+#PATCHES=""
+
+src_unpack() {
+ x-modular_src_unpack
+ if [[ -n "${SRC_PATCHES}" ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "If you have a mach64 or r128 video card, read this"
+ ewarn "The mach64 and r128 drivers moved to their own packages,"
+ ewarn "xf86-video-mach64 and xf86-video-r128. If these weren't installed"
+ ewarn "automatically by xorg-server and you have one of these cards,"
+ ewarn "check your VIDEO_CARDS settings."
+ ebeep
+ epause
+}