summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2010-04-21 16:03:46 +0000
committerTony Vroon <chainsaw@gentoo.org>2010-04-21 16:03:46 +0000
commit9c2e989d9a78abf6849a856d15ce280a81ba5f20 (patch)
tree4a1119930cb7445b539f726dd0ccb68469b5e34a /x11-drivers
parentFixed bug #307119 (diff)
downloadgentoo-2-9c2e989d9a78abf6849a856d15ce280a81ba5f20.tar.gz
gentoo-2-9c2e989d9a78abf6849a856d15ce280a81ba5f20.tar.bz2
gentoo-2-9c2e989d9a78abf6849a856d15ce280a81ba5f20.zip
This one is for you pheand: Install an X.Org 1.8 InputClass policy control file to actually use the driver we installed. With thanks to Hanno Boeck & Stephen "steve" Klimaszewski, closes bug #314989.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog10
-rw-r--r--x11-drivers/xf86-input-synaptics/files/1.2.2-xorg-inputclass6
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r1.ebuild55
3 files changed, 70 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index 5f215f7759fd..6b8a304e7ac5 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.48 2010/04/10 09:46:50 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.49 2010/04/21 16:03:46 chainsaw Exp $
+
+*xf86-input-synaptics-1.2.2-r1 (21 Apr 2010)
+
+ 21 Apr 2010; <chainsaw@gentoo.org> +files/1.2.2-xorg-inputclass,
+ +xf86-input-synaptics-1.2.2-r1.ebuild:
+ Install an X.Org 1.8 InputClass policy control file to actually use the
+ driver we installed. With thanks to Hanno Boeck & Stephen "steve"
+ Klimaszewski, closes bug #314989.
10 Apr 2010; Tomáš Chvátal <scarabeus@gentoo.org>
xf86-input-synaptics-1.2.2.ebuild:
diff --git a/x11-drivers/xf86-input-synaptics/files/1.2.2-xorg-inputclass b/x11-drivers/xf86-input-synaptics/files/1.2.2-xorg-inputclass
new file mode 100644
index 000000000000..1d82a674a0df
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/files/1.2.2-xorg-inputclass
@@ -0,0 +1,6 @@
+Section "InputClass"
+Identifier "touchpad catchall"
+MatchIsTouchpad "on"
+MatchDevicePath "/dev/input/event*"
+Driver "synaptics"
+EndSection
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..4359829bea28
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.2.2-r1.ebuild,v 1.1 2010/04/21 16:03:46 chainsaw Exp $
+
+inherit linux-info x-modular
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="hal"
+
+RDEPEND="
+ >=x11-base/xorg-server-1.8
+ >=x11-libs/libXi-1.2
+ x11-libs/libXtst
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ x11-proto/inputproto
+ >=sys-apps/sed-4"
+
+src_install() {
+ DOCS="INSTALL TODO README"
+ x-modular_src_install
+
+ if use hal ; then
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ doins "${S}"/fdi/11-x11-synaptics.fdi
+ fi
+
+ insinto /etc/X11/xorg.conf.d
+ newins "${FILESDIR}/${PV}-xorg-inputclass" 04-synaptics.conf || die "Unable to install xorg inputclass policy file"
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+ if use hal ; then
+ elog "If you want to modify Synaptics settings, please create an fdi file in:"
+ elog "/etc/hal/fdi/policy/"
+ echo
+ ewarn "The current default are set by :"
+ ewarn "/usr/share/hal/fdi/policy/10osvendor/11-x11-synaptics.fdi"
+ ewarn "You can use this file for inspiration, but DO NOT EDIT IT directly."
+ fi
+}