summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-01-26 17:56:12 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2014-01-26 17:56:12 +0000
commitbe7657b683b24708f2a8a20a2b69ad437d49d3ef (patch)
treea1a93aaf83d29bce6d2a700527f06f241ddc7169 /x11-drivers
parentCleanup. (diff)
downloadgentoo-2-be7657b683b24708f2a8a20a2b69ad437d49d3ef.tar.gz
gentoo-2-be7657b683b24708f2a8a20a2b69ad437d49d3ef.tar.bz2
gentoo-2-be7657b683b24708f2a8a20a2b69ad437d49d3ef.zip
Fix building against kernel 3.13, bug #498766. Import of Emil Karlson's ebuild from the x11 overlay.
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog10
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-13.12.ebuild7
-rw-r--r--x11-drivers/ati-drivers/files/ati-drivers-kernel-3.8-acpihandle.patch14
-rw-r--r--x11-drivers/ati-drivers/files/ati-drivers-linux-3.13-acpi-handle.patch27
4 files changed, 48 insertions, 10 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
index 3816bff72aed..946d0a41c148 100644
--- a/x11-drivers/ati-drivers/ChangeLog
+++ b/x11-drivers/ati-drivers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/ati-drivers
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.349 2013/12/27 12:47:52 scarabeus Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.350 2014/01/26 17:56:12 chithanh Exp $
+
+ 26 Jan 2014; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/ati-drivers-linux-3.13-acpi-handle.patch, ati-drivers-13.12.ebuild,
+ files/ati-drivers-kernel-3.8-acpihandle.patch:
+ Fix building against kernel 3.13, bug #498766. Import of Emil Karlson's ebuild
+ from the x11 overlay.
*ati-drivers-13.12 (27 Dec 2013)
diff --git a/x11-drivers/ati-drivers/ati-drivers-13.12.ebuild b/x11-drivers/ati-drivers/ati-drivers-13.12.ebuild
index 46d944645743..970cf321ff68 100644
--- a/x11-drivers/ati-drivers/ati-drivers-13.12.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-13.12.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-13.12.ebuild,v 1.1 2013/12/27 12:47:52 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-13.12.ebuild,v 1.2 2014/01/26 17:56:12 chithanh Exp $
EAPI=5
@@ -307,6 +307,9 @@ src_prepare() {
# Fix build on new kernels
epatch "${FILESDIR}/ati-drivers-13.12-acpi.patch"
+ # Add support for linux-3.13. See #498766
+ epatch "${FILESDIR}/ati-drivers-linux-3.13-acpi-handle.patch"
+
# Compile fix, https://bugs.gentoo.org/show_bug.cgi?id=454870
use pax_kernel && epatch "${FILESDIR}/const-notifier-block.patch"
diff --git a/x11-drivers/ati-drivers/files/ati-drivers-kernel-3.8-acpihandle.patch b/x11-drivers/ati-drivers/files/ati-drivers-kernel-3.8-acpihandle.patch
index bdff4fb73450..145abc757c7f 100644
--- a/x11-drivers/ati-drivers/files/ati-drivers-kernel-3.8-acpihandle.patch
+++ b/x11-drivers/ati-drivers/files/ati-drivers-kernel-3.8-acpihandle.patch
@@ -1,6 +1,6 @@
---- common/lib/modules/fglrx/build_mod/kcl_acpi.c 2012-07-04 21:43:47.000000000 +0200
-+++ common/lib/modules/fglrx/build_mod/kcl_acpi.c.new 2012-12-23 11:25:38.000000000 +0100
-@@ -775,11 +775,7 @@
+--- common/lib/modules/fglrx/build_mod/kcl_acpi.c.ORIG 2014-01-21 10:38:08.951838343 +0100
++++ common/lib/modules/fglrx/build_mod/kcl_acpi.c 2014-01-21 10:42:25.728845582 +0100
+@@ -775,10 +775,10 @@
unsigned int ATI_API_CALL KCL_ACPI_GetHandles(kcl_match_info_t *pInfo)
{
#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12)
@@ -8,8 +8,10 @@
- pInfo->video_handle = pInfo->pcidev->dev.archdata.acpi_handle;
- #else
- pInfo->video_handle = pInfo->pcidev->dev.firmware_data;
-- #endif
-+ pInfo->video_handle = DEVICE_ACPI_HANDLE(&pInfo->pcidev->dev);
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,13,0)
++ pInfo->video_handle = (acpi_handle)ACPI_HANDLE(&pInfo->pcidev->dev);
++ #else
++ pInfo->video_handle = DEVICE_ACPI_HANDLE(&pInfo->pcidev->dev);
+ #endif
if ( pInfo->video_handle &&
(KCL_ACPI_videoDevice(pInfo->video_handle) != KCL_ACPI_OK) )
- {
diff --git a/x11-drivers/ati-drivers/files/ati-drivers-linux-3.13-acpi-handle.patch b/x11-drivers/ati-drivers/files/ati-drivers-linux-3.13-acpi-handle.patch
new file mode 100644
index 000000000000..3ecc7c451447
--- /dev/null
+++ b/x11-drivers/ati-drivers/files/ati-drivers-linux-3.13-acpi-handle.patch
@@ -0,0 +1,27 @@
+From 889165af52ba694f72d4d1e333a1f9ba14a82fde Mon Sep 17 00:00:00 2001
+From: Emil Karlson <jekarlson@gmail.com>
+Date: Tue, 21 Jan 2014 23:25:26 +0200
+Subject: [PATCH] ati-drivers: linux-3.13 acpi handle
+
+---
+ common/lib/modules/fglrx/build_mod/kcl_acpi.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/common/lib/modules/fglrx/build_mod/kcl_acpi.c b/common/lib/modules/fglrx/build_mod/kcl_acpi.c
+index d875bf9..e063057 100755
+--- a/common/lib/modules/fglrx/build_mod/kcl_acpi.c
++++ b/common/lib/modules/fglrx/build_mod/kcl_acpi.c
+@@ -792,7 +792,9 @@ static unsigned int KCL_ACPI_SearchHandles(KCL_ACPI_DevHandle handle, unsigned i
+ unsigned int ATI_API_CALL KCL_ACPI_GetHandles(kcl_match_info_t *pInfo)
+ {
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,12)
+- #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0)
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,13,0)
++ pInfo->video_handle = (acpi_handle)ACPI_HANDLE(&pInfo->pcidev->dev);
++ #elif LINUX_VERSION_CODE >= KERNEL_VERSION(3,8,0)
+ pInfo->video_handle = pInfo->pcidev->dev.acpi_node.handle;
+ #elif LINUX_VERSION_CODE > KERNEL_VERSION(2,6,19)
+ pInfo->video_handle = pInfo->pcidev->dev.archdata.acpi_handle;
+--
+1.8.3.2
+