summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2008-08-28 13:43:41 +0000
committerDoug Goldstein <cardoe@gentoo.org>2008-08-28 13:43:41 +0000
commit55f81e9496bee55d259f9a56f06f1d4fe2ec6e82 (patch)
tree73229bfa5add7e81f2f77014579bb5f2d5fac5b1 /x11-libs/cairo
parentSparc stable, Bug #235982. (diff)
downloadgentoo-2-55f81e9496bee55d259f9a56f06f1d4fe2ec6e82.tar.gz
gentoo-2-55f81e9496bee55d259f9a56f06f1d4fe2ec6e82.tar.bz2
gentoo-2-55f81e9496bee55d259f9a56f06f1d4fe2ec6e82.zip
Add development snapshot that's masked
(Portage version: 2.2_rc8/cvs/Linux 2.6.25-gentoo-r8 x86_64)
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/ChangeLog7
-rw-r--r--x11-libs/cairo/cairo-1.7.4.ebuild79
2 files changed, 85 insertions, 1 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index ac428a1b4939..35d9d98778a9 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/cairo
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.191 2008/08/24 21:01:45 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.192 2008/08/28 13:43:41 cardoe Exp $
+
+*cairo-1.7.4 (28 Aug 2008)
+
+ 28 Aug 2008; Doug Goldstein <cardoe@gentoo.org> +cairo-1.7.4.ebuild:
+ Add development snapshot that's masked
24 Aug 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
re-add opengl USE flag that was deleted
diff --git a/x11-libs/cairo/cairo-1.7.4.ebuild b/x11-libs/cairo/cairo-1.7.4.ebuild
new file mode 100644
index 000000000000..a7aa98e0dfd3
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.7.4.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.7.4.ebuild,v 1.1 2008/08/28 13:43:41 cardoe Exp $
+
+inherit eutils flag-o-matic libtool
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+SRC_URI="http://cairographics.org/snapshots/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug directfb doc glitz opengl svg test X xcb"
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="media-libs/fontconfig
+ >=media-libs/freetype-2.1.9
+ sys-libs/zlib
+ media-libs/libpng
+ >=x11-libs/pixman-0.10.0
+ X? (
+ x11-libs/libXrender
+ x11-libs/libXext
+ x11-libs/libX11
+ virtual/xft
+ xcb? ( x11-libs/libxcb
+ x11-libs/xcb-util )
+ )
+ directfb? ( >=dev-libs/DirectFB-0.9.24 )
+ glitz? ( >=media-libs/glitz-0.5.1 )
+ svg? ( dev-libs/libxml2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.19
+ X? ( x11-proto/renderproto
+ xcb? ( x11-proto/xcb-proto ) )
+ doc? (
+ >=dev-util/gtk-doc-1.6
+ ~app-text/docbook-xml-dtd-4.2
+ )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ elibtoolize
+}
+
+src_compile() {
+ local use_xcb
+
+ #gets rid of fbmmx.c inlining warnings
+ append-flags -finline-limit=1200
+
+ if use glitz && use opengl; then
+ export glitz_LIBS=-lglitz-glx
+ fi
+
+ use_xcb="--disable-xcb"
+ use X && use xcb && use_xcb="--enable-xcb"
+
+ econf $(use_enable X xlib) $(use_enable doc gtk-doc) \
+ $(use_enable directfb) ${use_xcb} \
+ $(use_enable svg) $(use_enable glitz) $(use_enable X xlib-xrender) \
+ $(use_enable debug test-surfaces) --enable-pdf --enable-png \
+ --enable-freetype --enable-ps \
+ || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}