summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-11-05 19:29:05 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-11-05 19:29:05 +0000
commitc676ea5558bf9bd02aa9397693de6f3829798b05 (patch)
treec10129ee9a02b59eb7e2862a1cdf2552e5922c3e /x11-libs/fox
parentadded X to DEPEND (diff)
downloadgentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.tar.gz
gentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.tar.bz2
gentoo-2-c676ea5558bf9bd02aa9397693de6f3829798b05.zip
Version bumps
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/ChangeLog7
-rw-r--r--x11-libs/fox/files/digest-fox-1.0.261
-rw-r--r--x11-libs/fox/fox-1.0.26.ebuild51
3 files changed, 58 insertions, 1 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
index 79103b8f6fa8..39bf7461f9e6 100644
--- a/x11-libs/fox/ChangeLog
+++ b/x11-libs/fox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fox
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.1 2002/07/29 20:35:08 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.2 2002/11/05 19:29:05 aliz Exp $
+
+*fox-1.0.26 (05 Nov 2002)
+
+ 05 Nov 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump.
*fox-1.0.17.ebuild (29 Jul 2002)
diff --git a/x11-libs/fox/files/digest-fox-1.0.26 b/x11-libs/fox/files/digest-fox-1.0.26
new file mode 100644
index 000000000000..b2e8caba4dcf
--- /dev/null
+++ b/x11-libs/fox/files/digest-fox-1.0.26
@@ -0,0 +1 @@
+MD5 a7a187a0405f498f03b09727184b53aa fox-1.0.26.tar.gz 2109079
diff --git a/x11-libs/fox/fox-1.0.26.ebuild b/x11-libs/fox/fox-1.0.26.ebuild
new file mode 100644
index 000000000000..707aeb12fb77
--- /dev/null
+++ b/x11-libs/fox/fox-1.0.26.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.0.26.ebuild,v 1.1 2002/11/05 19:29:05 aliz Exp $
+
+IUSE="cups opengl"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="C++ based Toolkit for developing Graphical User Interfaces easily a nd effectively"
+
+SRC_URI="http://www.fox-toolkit.org/ftp/${P}.tar.gz"
+
+HOMEPAGE="http://www.fox-toolkit.org"
+
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~sparc64"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc
+ virtual/x11
+ opengl? ( virtual/opengl )"
+
+
+src_compile() {
+
+ local myconf
+
+ use opengl || myconf="$myconf --with-opengl=no" #default enabled
+ use cups && myconf="$myconf --enable-cups" #default disabled
+
+ ./configure \
+ --prefix=/usr \
+ --mandir='${prefix}'/share/man \
+ --host=${CHOST} \
+ ${myconf} || die "Configuration Failed"
+
+ emake || die "Parallel Make Failed"
+}
+
+src_install () {
+
+ make prefix=${D}/usr/ \
+ install || die "Installation Failed"
+
+ dodoc README INSTALL LICENSE ADDITIONS AUTHORS TRACING
+
+ dodir /usr/share/doc/${PF}/html
+ mv ${D}/usr/fox/html/* ${D}/usr/share/doc/${PF}/html/
+ rmdir ${D}/usr/fox/html
+ rmdir ${D}/usr/fox
+}