summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2004-05-09 18:37:38 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2004-05-09 18:37:38 +0000
commitd7d3b41cb3efda0804156b67b7b6cbe78fc426a9 (patch)
treee472ca722e767f75c8ef8eae04d197d74fcc622f /x11-libs/gai
parentStable on x86, alpha and ppc. Don't assign default to S (Manifest recommit) (diff)
downloadgentoo-2-d7d3b41cb3efda0804156b67b7b6cbe78fc426a9.tar.gz
gentoo-2-d7d3b41cb3efda0804156b67b7b6cbe78fc426a9.tar.bz2
gentoo-2-d7d3b41cb3efda0804156b67b7b6cbe78fc426a9.zip
version bump (Bug #49950)
Diffstat (limited to 'x11-libs/gai')
-rw-r--r--x11-libs/gai/ChangeLog12
-rw-r--r--x11-libs/gai/Manifest5
-rw-r--r--x11-libs/gai/files/digest-gai-0.5.31
-rw-r--r--x11-libs/gai/gai-0.5.3.ebuild53
4 files changed, 69 insertions, 2 deletions
diff --git a/x11-libs/gai/ChangeLog b/x11-libs/gai/ChangeLog
index c16a3266ec4c..10db4a9f2cec 100644
--- a/x11-libs/gai/ChangeLog
+++ b/x11-libs/gai/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-libs/gai
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/ChangeLog,v 1.4 2004/02/18 15:34:30 lordvan Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/ChangeLog,v 1.5 2004/05/09 18:37:38 lordvan Exp $
+
+*gai-0.5.3 (09 May 2004)
+
+ 09 May 2004; Thomas Raschbacher <lordvan@gentoo.org> +gai-0.5.3.ebuild:
+ version bump (Bug #49950)
+
+*gai-0.5.2-r1 09 May 2004
+
+ 09 May 2004; <>
+ # INSERT ENTRY HERE
*gai-0.5.2 (18 Feb 2004)
diff --git a/x11-libs/gai/Manifest b/x11-libs/gai/Manifest
index c4ba41d6f386..e3a0c86560d4 100644
--- a/x11-libs/gai/Manifest
+++ b/x11-libs/gai/Manifest
@@ -1,6 +1,9 @@
MD5 41d0a3243e5ad6a4fec48c12c31b21d4 gai-0.5.0_pre6.ebuild 1462
MD5 75b18f4efa5d72c83fb9807b1498e8b3 gai-0.5.2.ebuild 1457
-MD5 5e8093267af982548041d57ff785b9cf ChangeLog 1030
+MD5 75b18f4efa5d72c83fb9807b1498e8b3 gai-0.5.3.ebuild 1457
+MD5 5beb33453b63c8fa94a16c6a1deda858 ChangeLog 1100
MD5 4de810beafe6af976494dfe29abd5c60 metadata.xml 405
MD5 2cc1df4e270e1be3a526f9609c89accc files/digest-gai-0.5.0_pre6 66
+MD5 72db507aad739b6917552b17dac52b3c files/digest-gai-0.5.2-r1 62
MD5 72db507aad739b6917552b17dac52b3c files/digest-gai-0.5.2 62
+MD5 1f1765cd80db536972ec0fbfccb73136 files/digest-gai-0.5.3 62
diff --git a/x11-libs/gai/files/digest-gai-0.5.3 b/x11-libs/gai/files/digest-gai-0.5.3
new file mode 100644
index 000000000000..378907aa3410
--- /dev/null
+++ b/x11-libs/gai/files/digest-gai-0.5.3
@@ -0,0 +1 @@
+MD5 732016d4cf133a50d2226153db395b85 gai-0.5.3.tar.bz2 233198
diff --git a/x11-libs/gai/gai-0.5.3.ebuild b/x11-libs/gai/gai-0.5.3.ebuild
new file mode 100644
index 000000000000..e0f002af8381
--- /dev/null
+++ b/x11-libs/gai/gai-0.5.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gai/gai-0.5.3.ebuild,v 1.1 2004/05/09 18:37:38 lordvan Exp $
+
+IUSE="opengl gnome"
+
+MY_P=${P/_/}
+DESCRIPTION="GAI, The General Applet Interface library is a library that will help applet programmers alot."
+HOMEPAGE="http://gai.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gai/${MY_P}.tar.bz2"
+
+SLOT="0"
+LICENSE="LGPL-2"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-libs/gtk+-2.0.0
+ opengl? ( >=x11-libs/gtkglext-1.0.5 )
+ gnome? ( >=gnome-base/gnome-panel-2.0.0 )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # works with just set prefix (doesn't hardcode the prefix anywhere)!
+ local myconf
+
+ # Someone please tell upstream that the way to enable/disable things in
+ # configure scripts should be bloody well consistent -- it's in poor taste
+ # and downright incompetent to have to use --with if you want something
+ # and --disable if you don't
+
+ use opengl \
+ && myconf="${myconf} --with-gl" \
+ || myconf="${myconf} --disable-gl"
+
+ use gnome \
+ && myconf="${myconf} --with-gnome" \
+ || myconf="${myconf} --disable-gnome"
+
+ econf \
+ --prefix=${D}/usr \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS BUGS COPYING.LIB ChangeLog INSTALL README \
+ README.gai THANKS TODO WINDOWMANAGERS
+ dohtml ${S}/docs/*
+ # install examples
+ cp -r ${S}/examples ${D}/usr/share/doc/${P}
+}