summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-07-16 06:49:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-07-16 06:49:24 +0000
commitfece5de56ecd191d7daa0ad7115b037c452ca8a4 (patch)
tree52b2839e68c497335827148eeb65751a2cfdfa73 /x11-libs/guile-gtk
parentVersion bump (diff)
downloadgentoo-2-fece5de56ecd191d7daa0ad7115b037c452ca8a4.tar.gz
gentoo-2-fece5de56ecd191d7daa0ad7115b037c452ca8a4.tar.bz2
gentoo-2-fece5de56ecd191d7daa0ad7115b037c452ca8a4.zip
Fix for brokentest fix
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/guile-gtk')
-rw-r--r--x11-libs/guile-gtk/ChangeLog7
-rw-r--r--x11-libs/guile-gtk/files/2.1-brokentest.patch29
2 files changed, 27 insertions, 9 deletions
diff --git a/x11-libs/guile-gtk/ChangeLog b/x11-libs/guile-gtk/ChangeLog
index f83102a061c4..c598488dfb78 100644
--- a/x11-libs/guile-gtk/ChangeLog
+++ b/x11-libs/guile-gtk/ChangeLog
@@ -1,10 +1,13 @@
# ChangeLog for x11-libs/guile-gtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/ChangeLog,v 1.35 2010/06/28 22:28:32 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/guile-gtk/ChangeLog,v 1.36 2010/07/16 06:49:24 jlec Exp $
+
+ 16 Jul 2010; Justin Lecher <jlec@gentoo.org> files/2.1-brokentest.patch:
+ Fix for brokentest fix
28 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/2.1-brokentest.patch,
guile-gtk-2.1.ebuild, +files/2.1-prll-install.patch:
- Fix prrll installation, 298803 and remoed broken test, #298802
+ Fix prll installation, 298803 and removed broken test, #298802
28 Jun 2010; Christoph Mende <angelos@gentoo.org> guile-gtk-2.1.ebuild:
Stable on amd64 wrt bug #326019
diff --git a/x11-libs/guile-gtk/files/2.1-brokentest.patch b/x11-libs/guile-gtk/files/2.1-brokentest.patch
index 9fe058cc6b12..ecba95174e0c 100644
--- a/x11-libs/guile-gtk/files/2.1-brokentest.patch
+++ b/x11-libs/guile-gtk/files/2.1-brokentest.patch
@@ -1,11 +1,15 @@
diff --git a/tests/gdk.scm b/tests/gdk.scm
-index 6e08f9f..36941f5 100644
+index 6e08f9f..6b01e83 100644
--- a/tests/gdk.scm
+++ b/tests/gdk.scm
-@@ -1106,13 +1106,6 @@
- ;; gdk-selection-property-get
- ;;
+@@ -1102,28 +1102,6 @@
+ (got (exact-positive-integer? (gdk-screen-height-mm))))
+ (test "gdk-screen-height-mm" #f want got))))
+-;;
+-;; gdk-selection-property-get
+-;;
+-
-(malloced-steady ;; with nothing ever requested
- (lambda ()
- (let* ((win sample-win)
@@ -13,6 +17,17 @@ index 6e08f9f..36941f5 100644
- (got (gdk-selection-property-get win)))
- (test "gdk-selection-property-get" sample-win want got))))
-
- (malloced-steady ;; on a destroyed window
- (lambda ()
- (let* ((win (gdk-window-new #f 100 100 '() 'input-output 'toplevel))
+-(malloced-steady ;; on a destroyed window
+- (lambda ()
+- (let* ((win (gdk-window-new #f 100 100 '() 'input-output 'toplevel))
+- (want '(#f NONE 0))
+- (got (begin
+- (gdk-window-destroy win)
+- (gdk-selection-property-get win))))
+- ;; final free()s only take place under the main loop, so need this to
+- ;; satisfy `malloced-steady
+- (gtk-main-iteration-do #f)
+- (test "gdk-selection-property-get" (list "destroyed win" win) want got))))
+
+ ;;
+ ;; gdk-text-extents