summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-07-03 08:46:57 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-07-03 08:46:57 +0000
commit1b09bb27155e95f40decdcd95d1c7dc3da6697ba (patch)
tree9cabb43bb7cef784e14c5c66d7f5c343ea13bc9a /x11-libs/libXi
parentAdd patch to fix building against xorg-server-1.14, bug #461536. (diff)
downloadgentoo-2-1b09bb27155e95f40decdcd95d1c7dc3da6697ba.tar.gz
gentoo-2-1b09bb27155e95f40decdcd95d1c7dc3da6697ba.tar.bz2
gentoo-2-1b09bb27155e95f40decdcd95d1c7dc3da6697ba.zip
Version bump.
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-libs/libXi')
-rw-r--r--x11-libs/libXi/ChangeLog8
-rw-r--r--x11-libs/libXi/libXi-1.7.2.ebuild38
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-libs/libXi/ChangeLog b/x11-libs/libXi/ChangeLog
index 256421f658d6..7d0896544c55 100644
--- a/x11-libs/libXi/ChangeLog
+++ b/x11-libs/libXi/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libXi
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.154 2013/06/27 13:56:12 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/ChangeLog,v 1.155 2013/07/03 08:46:57 chithanh Exp $
+
+*libXi-1.7.2 (03 Jul 2013)
+
+ 03 Jul 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +libXi-1.7.2.ebuild:
+ Version bump.
*libXi-1.7.1.901 (27 Jun 2013)
diff --git a/x11-libs/libXi/libXi-1.7.2.ebuild b/x11-libs/libXi/libXi-1.7.2.ebuild
new file mode 100644
index 000000000000..6c766fad94b8
--- /dev/null
+++ b/x11-libs/libXi/libXi-1.7.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libXi/libXi-1.7.2.ebuild,v 1.1 2013/07/03 08:46:57 chithanh Exp $
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Xi library"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE=""
+
+RDEPEND=">=x11-libs/libX11-1.4.99.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXfixes-5[${MULTILIB_USEDEP}]
+ >=x11-proto/inputproto-2.2.99.1[${MULTILIB_USEDEP}]
+ >=x11-proto/xproto-7.0.13[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.0.3[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ $(use_with doc asciidoc)
+ --without-fop
+ )
+ xorg-2_src_configure
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+
+ ewarn "Some special keys and keyboard layouts may stop working."
+ ewarn "To fix them, recompile xorg-server."
+}