summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-05-31 10:25:42 +0000
committerPacho Ramos <pacho@gentoo.org>2014-05-31 10:25:42 +0000
commit9295d79cbfe4b6849b81160f196a91f9209819b2 (patch)
treeb3b981a3d1575e49a0229df45c1b600156f8f233 /x11-libs/libgksu
parentAdd systemd_{do,new}userunit. (diff)
downloadgentoo-2-9295d79cbfe4b6849b81160f196a91f9209819b2.tar.gz
gentoo-2-9295d79cbfe4b6849b81160f196a91f9209819b2.tar.bz2
gentoo-2-9295d79cbfe4b6849b81160f196a91f9209819b2.zip
Needs to be rebuilt with libgtop soname bumps
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs/libgksu')
-rw-r--r--x11-libs/libgksu/ChangeLog10
-rw-r--r--x11-libs/libgksu/libgksu-2.0.12-r2.ebuild69
2 files changed, 76 insertions, 3 deletions
diff --git a/x11-libs/libgksu/ChangeLog b/x11-libs/libgksu/ChangeLog
index 92c1d857ce11..b54745d6367f 100644
--- a/x11-libs/libgksu/ChangeLog
+++ b/x11-libs/libgksu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libgksu
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libgksu/ChangeLog,v 1.86 2013/04/27 16:39:20 ssuominen Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libgksu/ChangeLog,v 1.87 2014/05/31 10:25:42 pacho Exp $
+
+*libgksu-2.0.12-r2 (31 May 2014)
+
+ 31 May 2014; Pacho Ramos <pacho@gentoo.org> +libgksu-2.0.12-r2.ebuild:
+ Needs to be rebuilt with libgtop soname bumps
27 Apr 2013; Samuli Suominen <ssuominen@gentoo.org> libgksu-2.0.12-r1.ebuild:
Fix automake-1.13 compability by using AC_CONFIG_HEADERS instead of the
@@ -337,4 +342,3 @@
+libgksu-1.2.5.ebuild:
Initial import to satisify gksu version bump in bug #88850. Ebuild by Kalle
Kotte <xake@telia.com>.
-
diff --git a/x11-libs/libgksu/libgksu-2.0.12-r2.ebuild b/x11-libs/libgksu/libgksu-2.0.12-r2.ebuild
new file mode 100644
index 000000000000..abb57e0ba4e8
--- /dev/null
+++ b/x11-libs/libgksu/libgksu-2.0.12-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libgksu/libgksu-2.0.12-r2.ebuild,v 1.1 2014/05/31 10:25:42 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="A library for integration of su into applications"
+HOMEPAGE="http://www.nongnu.org/gksu/"
+SRC_URI="http://people.debian.org/~kov/gksu/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="nls static-libs"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-2.12:2
+ >=gnome-base/gconf-2
+ gnome-base/libgnome-keyring
+ x11-libs/startup-notification
+ >=gnome-base/libgtop-2:2=
+ nls? ( >=sys-devel/gettext-0.14.1 )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35.5
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ app-admin/sudo
+"
+
+src_prepare() {
+ # Fix compilation on bsd
+ epatch "${FILESDIR}"/${PN}-2.0.0-fbsd.patch
+
+ # Fix wrong usage of LDFLAGS, bug #226837
+ epatch "${FILESDIR}/${PN}-2.0.7-libs.patch"
+
+ # Use po/LINGUAS
+ epatch "${FILESDIR}/${PN}-2.0.7-polinguas.patch"
+
+ # Don't forkpty; bug #298289
+ epatch "${FILESDIR}/${P}-revert-forkpty.patch"
+
+ # Make this gmake-3.82 compliant, bug #333961
+ epatch "${FILESDIR}/${P}-fix-make-3.82.patch"
+
+ # Do not build test programs that are never executed; also fixes bug
+ # #367397 (underlinking issues).
+ epatch "${FILESDIR}/${P}-notests.patch"
+
+ # Fix automake-1.11.2 compatibility, bug #397411
+ epatch "${FILESDIR}/${P}-automake-1.11.2.patch"
+
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die #467026
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}