summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-02 20:58:48 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-02 20:58:48 +0000
commit4f23f7d6901ad28da258cffe6e434141921379d8 (patch)
tree666c6c6261527fb608c09e44ff55d3dfeec32ee2 /x11-libs/libjwc_c
parentFix patch to include proper comments, to Gentoo required standard. (diff)
downloadgentoo-2-4f23f7d6901ad28da258cffe6e434141921379d8.tar.gz
gentoo-2-4f23f7d6901ad28da258cffe6e434141921379d8.tar.bz2
gentoo-2-4f23f7d6901ad28da258cffe6e434141921379d8.zip
First need split xlib from ccp4
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/libjwc_c')
-rw-r--r--x11-libs/libjwc_c/ChangeLog10
-rw-r--r--x11-libs/libjwc_c/files/612-gentoo.patch20
-rw-r--r--x11-libs/libjwc_c/libjwc_c-1.1-r1.ebuild29
-rw-r--r--x11-libs/libjwc_c/metadata.xml8
4 files changed, 67 insertions, 0 deletions
diff --git a/x11-libs/libjwc_c/ChangeLog b/x11-libs/libjwc_c/ChangeLog
new file mode 100644
index 000000000000..8f5a828d863d
--- /dev/null
+++ b/x11-libs/libjwc_c/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for x11-libs/libjwc_c
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libjwc_c/ChangeLog,v 1.1 2010/02/02 20:58:46 jlec Exp $
+
+*libjwc_c-1.1-r1 (02 Feb 2010)
+
+ 02 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/612-gentoo.patch, +libjwc_c-1.1-r1.ebuild, +metadata.xml:
+ First need split xlib from ccp4
+
diff --git a/x11-libs/libjwc_c/files/612-gentoo.patch b/x11-libs/libjwc_c/files/612-gentoo.patch
new file mode 100644
index 000000000000..af4a691febb9
--- /dev/null
+++ b/x11-libs/libjwc_c/files/612-gentoo.patch
@@ -0,0 +1,20 @@
+diff -Nu libjwc_c-1.1/imglib.c libjwc_c/imglib.c
+--- libjwc_c-1.1/imglib.c 1999-08-17 15:58:11.000000000 +0200
++++ libjwc_c/imglib.c 2004-06-03 14:24:05.000000000 +0200
+@@ -4259,7 +4259,7 @@
+ {
+
+ /* Note: In this routine the first local axis is called 'x' and the
+- second logal axi is called 'y' */
++ second local axis is called 'y' */
+
+ int mxcent; /* Current max no. of elements in active
+ spots array */
+@@ -4469,6 +4469,7 @@
+
+ /* skipping condition */
+
++ iymid = (actspots[j].iyend+actspots[j].iybeg)/2;
+ itmp = abs(iymid-actspots[j].iycent);
+ if (abs((actspots[j].iyend+actspots[j].iybeg) -(iel+ibl))>
+ abs((actspots[j].iyend-actspots[j].iybeg) +(iel-ibl))&&
diff --git a/x11-libs/libjwc_c/libjwc_c-1.1-r1.ebuild b/x11-libs/libjwc_c/libjwc_c-1.1-r1.ebuild
new file mode 100644
index 000000000000..c78a4bc8f0ec
--- /dev/null
+++ b/x11-libs/libjwc_c/libjwc_c-1.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libjwc_c/libjwc_c-1.1-r1.ebuild,v 1.1 2010/02/02 20:58:46 jlec Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+PATCH="612"
+
+DESCRIPTION="additional c library for ccp4"
+HOMEPAGE="http://www.ccp4.ac.uk/main.html"
+SRC_URI="ftp://ftp.ccp4.ac.uk/jwc/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PATCH}-gentoo.patch
+ rm missing || die
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README NEWS || die
+}
diff --git a/x11-libs/libjwc_c/metadata.xml b/x11-libs/libjwc_c/metadata.xml
new file mode 100644
index 000000000000..efb490d78817
--- /dev/null
+++ b/x11-libs/libjwc_c/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<maintainer>
+ <email>sci@gentoo.org</email>
+</maintainer>
+</pkgmetadata>