summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-06-19 19:34:54 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-06-19 19:34:54 +0000
commitaa8ad6d90bb08c9284eafa655d45d17cfece6f2a (patch)
treec40b5e62099148ce621a33c99c5abd8d5be469dd /x11-libs/libva
parentStable on alpha, bug #473190 (diff)
downloadgentoo-2-aa8ad6d90bb08c9284eafa655d45d17cfece6f2a.tar.gz
gentoo-2-aa8ad6d90bb08c9284eafa655d45d17cfece6f2a.tar.bz2
gentoo-2-aa8ad6d90bb08c9284eafa655d45d17cfece6f2a.zip
Add drm useflag, based on patch by grey dot in bug #466402. Enable it by default since it does not allow to drop the libdrm dependency and one backend is required to build libva.
(Portage version: 2.2.0_alpha181/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'x11-libs/libva')
-rw-r--r--x11-libs/libva/ChangeLog8
-rw-r--r--x11-libs/libva/libva-1.1.1.ebuild8
-rw-r--r--x11-libs/libva/libva-9999.ebuild8
-rw-r--r--x11-libs/libva/metadata.xml1
4 files changed, 18 insertions, 7 deletions
diff --git a/x11-libs/libva/ChangeLog b/x11-libs/libva/ChangeLog
index 61db7a0aae00..ce7bb9b69743 100644
--- a/x11-libs/libva/ChangeLog
+++ b/x11-libs/libva/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/libva
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.50 2013/03/26 16:31:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/ChangeLog,v 1.51 2013/06/19 19:34:54 aballier Exp $
+
+ 19 Jun 2013; Alexis Ballier <aballier@gentoo.org> libva-1.1.1.ebuild,
+ libva-9999.ebuild, metadata.xml:
+ Add drm useflag, based on patch by grey dot in bug #466402. Enable it by
+ default since it does not allow to drop the libdrm dependency and one backend
+ is required to build libva.
*libva-1.1.1 (26 Mar 2013)
diff --git a/x11-libs/libva/libva-1.1.1.ebuild b/x11-libs/libva/libva-1.1.1.ebuild
index ee80d4ee55cd..b5636ce450ee 100644
--- a/x11-libs/libva/libva-1.1.1.ebuild
+++ b/x11-libs/libva/libva-1.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-1.1.1.ebuild,v 1.1 2013/03/26 16:31:24 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-1.1.1.ebuild,v 1.2 2013/06/19 19:34:54 aballier Exp $
EAPI=4
@@ -29,7 +29,8 @@ if [ "${PV%9999}" = "${PV}" ] ; then
else
KEYWORDS=""
fi
-IUSE="egl opengl wayland X"
+IUSE="+drm egl opengl wayland X"
+REQUIRED_USE="|| ( drm wayland X )"
VIDEO_CARDS="dummy nvidia intel fglrx"
for x in ${VIDEO_CARDS}; do
@@ -67,7 +68,8 @@ src_configure() {
$(use_enable opengl glx) \
$(use_enable X x11) \
$(use_enable wayland) \
- $(use_enable egl)
+ $(use_enable egl) \
+ $(use_enable drm)
}
src_install() {
diff --git a/x11-libs/libva/libva-9999.ebuild b/x11-libs/libva/libva-9999.ebuild
index 1da634bb31e2..bd5aa5e5255e 100644
--- a/x11-libs/libva/libva-9999.ebuild
+++ b/x11-libs/libva/libva-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-9999.ebuild,v 1.14 2013/03/26 16:29:25 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libva/libva-9999.ebuild,v 1.15 2013/06/19 19:34:54 aballier Exp $
EAPI=4
@@ -29,7 +29,8 @@ if [ "${PV%9999}" = "${PV}" ] ; then
else
KEYWORDS=""
fi
-IUSE="egl opengl wayland X"
+IUSE="+drm egl opengl wayland X"
+REQUIRED_USE="|| ( drm wayland X )"
VIDEO_CARDS="dummy nvidia intel fglrx"
for x in ${VIDEO_CARDS}; do
@@ -67,7 +68,8 @@ src_configure() {
$(use_enable opengl glx) \
$(use_enable X x11) \
$(use_enable wayland) \
- $(use_enable egl)
+ $(use_enable egl) \
+ $(use_enable drm)
}
src_install() {
diff --git a/x11-libs/libva/metadata.xml b/x11-libs/libva/metadata.xml
index af702ea29fbe..8aef4bbadb48 100644
--- a/x11-libs/libva/metadata.xml
+++ b/x11-libs/libva/metadata.xml
@@ -7,5 +7,6 @@
</maintainer>
<use>
<flag name='egl'>Enables EGL support.</flag>
+ <flag name='drm'>Enables VA/DRM API support.</flag>
</use>
</pkgmetadata>