summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-12-08 11:33:27 +0000
committerMart Raudsepp <leio@gentoo.org>2006-12-08 11:33:27 +0000
commit2bfa5afc19022c1497ec5c9d130f64de2741af95 (patch)
tree9c577854aa4b5fcf15b7b2ac5198c48cb5e56ee5 /x11-libs/pango
parentadd dummy ebuild to pull in mail-client/claws-mail (diff)
downloadgentoo-2-2bfa5afc19022c1497ec5c9d130f64de2741af95.tar.gz
gentoo-2-2bfa5afc19022c1497ec5c9d130f64de2741af95.tar.bz2
gentoo-2-2bfa5afc19022c1497ec5c9d130f64de2741af95.zip
Version bump
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'x11-libs/pango')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/files/digest-pango-1.14.93
-rw-r--r--x11-libs/pango/pango-1.14.9.ebuild69
3 files changed, 78 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index fe1b2518cbcb..b66271fd8d63 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.159 2006/12/01 19:30:30 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.160 2006/12/08 11:33:27 leio Exp $
+
+*pango-1.14.9 (08 Dec 2006)
+
+ 08 Dec 2006; Mart Raudsepp <leio@gentoo.org> +pango-1.14.9.ebuild:
+ Version bump
01 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org> pango-1.14.7.ebuild:
Stable on hppa wrt #156572
diff --git a/x11-libs/pango/files/digest-pango-1.14.9 b/x11-libs/pango/files/digest-pango-1.14.9
new file mode 100644
index 000000000000..78e2e60dee7f
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.14.9
@@ -0,0 +1,3 @@
+MD5 58766a41693b917fda854b9a41d40834 pango-1.14.9.tar.bz2 1293201
+RMD160 5859892c175d6bd5b16a00d622f60bb5f4b20238 pango-1.14.9.tar.bz2 1293201
+SHA256 31baa3b606993efabe409c978982dea68f49504f494f196110780fe480fe2dc1 pango-1.14.9.tar.bz2 1293201
diff --git a/x11-libs/pango/pango-1.14.9.ebuild b/x11-libs/pango/pango-1.14.9.ebuild
new file mode 100644
index 000000000000..0ca9ccac110e
--- /dev/null
+++ b/x11-libs/pango/pango-1.14.9.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.14.9.ebuild,v 1.1 2006/12/08 11:33:27 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ >=dev-libs/glib-2.10.0
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >=x11-libs/cairo-1.2.2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ x11-proto/xproto
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO*"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Some enhancements from Redhat
+ # These NEED to go upstream.
+ epatch ${FILESDIR}/pango-1.11.3-xfonts.patch
+ epatch ${FILESDIR}/${PN}-1.10.2-slighthint.patch
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system
+ use amd64 && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ epunt_cxx
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm ${D}/etc/pango/pango.modules
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ einfo "Generating modules listing..."
+
+ use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
+
+ PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}