summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 14:37:38 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2010-09-21 14:37:38 +0000
commitb88fae2ba4cb7600aa6fc1e29056e5462f7d5850 (patch)
tree05fd3469d2ffaf69ad372106171958f7a7332e4a /x11-libs/qt-assistant
parentAdd LDFLAGS to ldflags and to lddlflags via config.over. Fixes bug #181435 (diff)
downloadgentoo-2-b88fae2ba4cb7600aa6fc1e29056e5462f7d5850.tar.gz
gentoo-2-b88fae2ba4cb7600aa6fc1e29056e5462f7d5850.tar.bz2
gentoo-2-b88fae2ba4cb7600aa6fc1e29056e5462f7d5850.zip
Version bump
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-assistant')
-rw-r--r--x11-libs/qt-assistant/ChangeLog8
-rw-r--r--x11-libs/qt-assistant/metadata.xml7
-rw-r--r--x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild86
3 files changed, 96 insertions, 5 deletions
diff --git a/x11-libs/qt-assistant/ChangeLog b/x11-libs/qt-assistant/ChangeLog
index 846360f91100..7da9d43072ca 100644
--- a/x11-libs/qt-assistant/ChangeLog
+++ b/x11-libs/qt-assistant/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/qt-assistant
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.84 2010/09/13 21:18:52 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/ChangeLog,v 1.85 2010/09/21 14:37:38 tampakrap Exp $
+
+*qt-assistant-4.7.0 (21 Sep 2010)
+
+ 21 Sep 2010; Theo Chatzimichos <tampakrap@gentoo.org>
+ +qt-assistant-4.7.0.ebuild:
+ Version bump
13 Sep 2010; Tobias Klausmann <klausman@gentoo.org>
qt-assistant-4.6.2.ebuild:
diff --git a/x11-libs/qt-assistant/metadata.xml b/x11-libs/qt-assistant/metadata.xml
index 26c910d4e964..6bde1b8bb16d 100644
--- a/x11-libs/qt-assistant/metadata.xml
+++ b/x11-libs/qt-assistant/metadata.xml
@@ -5,9 +5,8 @@
<use>
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
- <flag name='trace'>
- Build the qttracereplay utility which is required to play drawings
- recorded with the trace graphicssystem engine
- </flag>
+ <flag name='trace'>Build the qttracereplay utility which is required to
+ play drawings recorded with the trace graphicssystem engine</flag>
+ <flag name='glib'>Enable <pkg>dev-libs/glib</pkg> eventloop support</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
new file mode 100644
index 000000000000..38dfd5d8a26f
--- /dev/null
+++ b/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-assistant/qt-assistant-4.7.0.ebuild,v 1.1 2010/09/21 14:37:38 tampakrap Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The assistant help module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +glib trace"
+
+DEPEND="~x11-libs/qt-gui-${PV}[glib=,trace?]
+ ~x11-libs/qt-sql-${PV}[sqlite]
+ ~x11-libs/qt-webkit-${PV}
+ ~x11-libs/qt-declarative-${PV}"
+RDEPEND="${DEPEND}"
+
+# Pixeltool isn't really assistant related, but it relies on
+# the assistant libraries. doc/qch/
+QT4_TARGET_DIRECTORIES="
+ tools/assistant
+ tools/pixeltool
+ tools/qdoc3"
+QT4_EXTRACT_DIRECTORIES="
+ tools/
+ demos/
+ examples/
+ src/
+ include/
+ doc/"
+
+pkg_setup() {
+ use trace && QT4_TARGET_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ tools/qttracereplay"
+ QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+ ${QT4_EXTRACT_DIRECTORIES}"
+ qt4-build_pkg_setup
+}
+
+src_configure() {
+ myconf="${myconf} -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -iconv -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility
+ -no-fontconfig -no-multimedia -no-qt3support -no-svg"
+ ! use glib && myconf="${myconf} -no-glib"
+ qt4-build_src_configure
+}
+
+src_compile() {
+ # help libQtHelp find freshly built libQtCLucene (bug #289811)
+ export LD_LIBRARY_PATH="${S}/lib:${QTLIBDIR}"
+ export DYLD_LIBRARY_PATH="${S}/lib:${S}/lib/QtHelp.framework"
+
+ qt4-build_src_compile
+
+ # ugly hack to build docs
+ cd "${S}"
+ qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
+ emake qch_docs || die "emake qch_docs failed"
+ if use doc; then
+ emake docs || die "emake docs failed"
+ fi
+ qmake "LIBS+=-L${QTLIBDIR}" "CONFIG+=nostrip" projects.pro || die
+}
+
+src_install() {
+ qt4-build_src_install
+ cd "${S}"
+ emake INSTALL_ROOT="${D}" install_qchdocs \
+ || die "failed to install qch docs"
+ if use doc; then
+ emake INSTALL_ROOT="${D}" install_htmldocs \
+ || die "failed to install htmldocs"
+ fi
+ dobin "${S}"/bin/qdoc3 || die "Failed to install qdoc3"
+ # install correct assistant icon, bug 241208
+ dodir /usr/share/pixmaps/ || die
+ insinto /usr/share/pixmaps/
+ doins tools/assistant/tools/assistant/images/assistant.png || die
+ # Note: absolute image path required here!
+ make_desktop_entry /usr/bin/assistant Assistant \
+ /usr/share/pixmaps/assistant.png 'Qt;Development;GUIDesigner' || die
+}