summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-09-03 07:44:20 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-09-03 07:44:20 +0000
commitecc841502bc290c19af12290f59fa6dabd5bf9f6 (patch)
treeea86ebe56e69e78d96ea15d6c657b975583d7e4b /x11-libs/qt-gui
parentApply upstream patch to fix regression in pyuic's handling of custom widgets ... (diff)
downloadgentoo-2-ecc841502bc290c19af12290f59fa6dabd5bf9f6.tar.gz
gentoo-2-ecc841502bc290c19af12290f59fa6dabd5bf9f6.tar.bz2
gentoo-2-ecc841502bc290c19af12290f59fa6dabd5bf9f6.zip
Install qdbusviewer icon wrt bug 430726 by Samuel Bauer.
(Portage version: 2.2.0_alpha123-r2/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-gui')
-rw-r--r--x11-libs/qt-gui/ChangeLog6
-rw-r--r--x11-libs/qt-gui/qt-gui-4.8.1-r1.ebuild20
-rw-r--r--x11-libs/qt-gui/qt-gui-4.8.2.ebuild21
3 files changed, 26 insertions, 21 deletions
diff --git a/x11-libs/qt-gui/ChangeLog b/x11-libs/qt-gui/ChangeLog
index 10eef24e7db8..d21f0513852b 100644
--- a/x11-libs/qt-gui/ChangeLog
+++ b/x11-libs/qt-gui/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-gui
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.198 2012/07/19 21:01:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/ChangeLog,v 1.199 2012/09/03 07:44:20 pesa Exp $
+
+ 03 Sep 2012; Davide Pesavento <pesa@gentoo.org> qt-gui-4.8.1-r1.ebuild,
+ qt-gui-4.8.2.ebuild:
+ Install qdbusviewer icon wrt bug 430726 by Samuel Bauer.
19 Jul 2012; Markus Meier <maekke@gentoo.org> qt-gui-4.8.2.ebuild:
arm stable, bug #424625
diff --git a/x11-libs/qt-gui/qt-gui-4.8.1-r1.ebuild b/x11-libs/qt-gui/qt-gui-4.8.1-r1.ebuild
index 5a5a0bc0263c..0c2eae873d29 100644
--- a/x11-libs/qt-gui/qt-gui-4.8.1-r1.ebuild
+++ b/x11-libs/qt-gui/qt-gui-4.8.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/qt-gui-4.8.1-r1.ebuild,v 1.11 2012/07/13 11:12:20 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/qt-gui-4.8.1-r1.ebuild,v 1.12 2012/09/03 07:44:20 pesa Exp $
EAPI=4
@@ -195,7 +195,7 @@ src_install() {
# which are located under tools/designer/src/lib/*
# So instead of installing both, we create the private folder
# and drop tools/designer/src/lib/* headers in it.
- if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
insinto "${QTLIBDIR#${EPREFIX}}"/QtDesigner.framework/Headers/private/
else
insinto "${QTHEADERDIR#${EPREFIX}}"/QtDesigner/private/
@@ -204,14 +204,14 @@ src_install() {
doins "${S}"/tools/designer/src/lib/sdk/*
# install private headers
- if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
insinto "${QTLIBDIR#${EPREFIX}}"/QtGui.framework/Headers/private/
else
insinto "${QTHEADERDIR#${EPREFIX}}"/QtGui/private
fi
find "${S}"/src/gui -type f -name '*_p.h' -exec doins {} +
- if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
# rerun to get links to headers right
fix_includes
fi
@@ -228,14 +228,14 @@ src_install() {
}
pkg_postinst() {
- # raster is the default graphicssystems, set it if first install
+ # raster is the default graphicssystems, set it on first install
eselect qtgraphicssystem set raster --use-old
- elog "Starting with Qt 4.8.0, you may choose the active Qt Graphics System"
+
+ elog "Starting with Qt 4.8, you may choose the active Qt Graphics System"
elog "by using a new eselect module called qtgraphicssystem."
- elog "Run"
- elog " eselect qtgraphicssystem"
- elog "for more information."
- if use gtkstyle ; then
+ elog "Run \`eselect qtgraphicssystem\` for more information."
+
+ if use gtkstyle; then
# see bug 388551
elog "For Qt's GTK style to work, you need to either export"
elog "the following variable into your environment:"
diff --git a/x11-libs/qt-gui/qt-gui-4.8.2.ebuild b/x11-libs/qt-gui/qt-gui-4.8.2.ebuild
index 0880d7627d76..ab740f78cbff 100644
--- a/x11-libs/qt-gui/qt-gui-4.8.2.ebuild
+++ b/x11-libs/qt-gui/qt-gui-4.8.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/qt-gui-4.8.2.ebuild,v 1.10 2012/07/19 21:01:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-gui/qt-gui-4.8.2.ebuild,v 1.11 2012/09/03 07:44:20 pesa Exp $
EAPI=4
@@ -199,7 +199,7 @@ src_install() {
# which are located under tools/designer/src/lib/*
# So instead of installing both, we create the private folder
# and drop tools/designer/src/lib/* headers in it.
- if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
insinto "${QTLIBDIR#${EPREFIX}}"/QtDesigner.framework/Headers/private/
else
insinto "${QTHEADERDIR#${EPREFIX}}"/QtDesigner/private/
@@ -208,14 +208,14 @@ src_install() {
doins "${S}"/tools/designer/src/lib/sdk/*
# install private headers
- if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
insinto "${QTLIBDIR#${EPREFIX}}"/QtGui.framework/Headers/private/
else
insinto "${QTHEADERDIR#${EPREFIX}}"/QtGui/private
fi
find "${S}"/src/gui -type f -name '*_p.h' -exec doins {} +
- if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]] ; then
+ if use aqua && [[ ${CHOST##*-darwin} -ge 9 ]]; then
# rerun to get links to headers right
fix_includes
fi
@@ -227,19 +227,20 @@ src_install() {
doicon tools/designer/src/designer/images/designer.png \
tools/linguist/linguist/images/icons/linguist-128-32.png
+ use dbus && doicon tools/qdbus/qdbusviewer/images/qdbusviewer-128.png
make_desktop_entry designer Designer designer 'Qt;Development;GUIDesigner'
make_desktop_entry linguist Linguist linguist-128-32 'Qt;Development;GUIDesigner'
}
pkg_postinst() {
- # raster is the default graphicssystems, set it if first install
+ # raster is the default graphicssystems, set it on first install
eselect qtgraphicssystem set raster --use-old
- elog "Starting with Qt 4.8.0, you may choose the active Qt Graphics System"
+
+ elog "Starting with Qt 4.8, you may choose the active Qt Graphics System"
elog "by using a new eselect module called qtgraphicssystem."
- elog "Run"
- elog " eselect qtgraphicssystem"
- elog "for more information."
- if use gtkstyle ; then
+ elog "Run \`eselect qtgraphicssystem\` for more information."
+
+ if use gtkstyle; then
# see bug 388551
elog "For Qt's GTK style to work, you need to either export"
elog "the following variable into your environment:"