summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-06-13 09:51:26 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-06-13 09:51:26 +0000
commit43fdc27e57a2b41bbfd1ab1a8f78f736ff0fa5f2 (patch)
treec04bbbe029401add567b962c221c4e000bb9b86a /x11-libs/qt-sql
parentRevision bump to work with latest grass. (diff)
downloadgentoo-2-43fdc27e57a2b41bbfd1ab1a8f78f736ff0fa5f2.tar.gz
gentoo-2-43fdc27e57a2b41bbfd1ab1a8f78f736ff0fa5f2.tar.bz2
gentoo-2-43fdc27e57a2b41bbfd1ab1a8f78f736ff0fa5f2.zip
Introduce tds use flag. Fixes bug #323515
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/qt-sql')
-rw-r--r--x11-libs/qt-sql/ChangeLog9
-rw-r--r--x11-libs/qt-sql/metadata.xml1
-rw-r--r--x11-libs/qt-sql/qt-sql-4.6.3-r1.ebuild73
3 files changed, 82 insertions, 1 deletions
diff --git a/x11-libs/qt-sql/ChangeLog b/x11-libs/qt-sql/ChangeLog
index 9f1a3738b839..467b8e61afa3 100644
--- a/x11-libs/qt-sql/ChangeLog
+++ b/x11-libs/qt-sql/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/qt-sql
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.80 2010/06/08 12:21:32 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/ChangeLog,v 1.81 2010/06/13 09:51:26 hwoarang Exp $
+
+*qt-sql-4.6.3-r1 (13 Jun 2010)
+
+ 13 Jun 2010; Markos Chandras <hwoarang@gentoo.org>
+ +qt-sql-4.6.3-r1.ebuild:
+ Introduce tds use flag. Fixes bug #323515. Thanks to Rion
+ <rion4ik@gmail.com> for the patch
*qt-sql-4.6.3 (08 Jun 2010)
diff --git a/x11-libs/qt-sql/metadata.xml b/x11-libs/qt-sql/metadata.xml
index 753c3c20a9d3..90c827e6848f 100644
--- a/x11-libs/qt-sql/metadata.xml
+++ b/x11-libs/qt-sql/metadata.xml
@@ -6,5 +6,6 @@
<flag name='exceptions'>Add support for exceptions - like catching them
inside the event loop (recommended by Nokia)</flag>
<flag name='qt3support'>Enable the Qt3Support libraries for Qt4</flag>
+ <flag name='tds'>Enable support for freetds databases driver</flag>
</use>
</pkgmetadata>
diff --git a/x11-libs/qt-sql/qt-sql-4.6.3-r1.ebuild b/x11-libs/qt-sql/qt-sql-4.6.3-r1.ebuild
new file mode 100644
index 000000000000..517c54b90422
--- /dev/null
+++ b/x11-libs/qt-sql/qt-sql-4.6.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-sql/qt-sql-4.6.3-r1.ebuild,v 1.1 2010/06/13 09:51:26 hwoarang Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The SQL module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="firebird iconv mysql odbc postgres qt3support +sqlite tds"
+
+DEPEND="~x11-libs/qt-core-${PV}[aqua=,debug=,qt3support=]
+ firebird? ( dev-db/firebird )
+ mysql? ( virtual/mysql )
+ odbc? ( dev-db/unixODBC )
+ postgres? ( virtual/postgresql-base )
+ sqlite? ( dev-db/sqlite:3 )
+ tds? ( dev-db/freetds )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/sql src/plugins/sqldrivers"
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtSql/
+include/QtScript/
+src/src.pro
+src/corelib/
+src/plugins
+src/3rdparty
+src/tools"
+
+PATCHES=(
+ "${FILESDIR}/qt-4.6-nolibx11.patch"
+)
+
+pkg_setup() {
+ if ! (use firebird || use mysql || use odbc || use postgres || use sqlite || use tds ); then
+ ewarn "You need to enable at least one SQL driver. Enable at least"
+ ewarn "one of these USE flags: \"firebird mysql odbc postgres sqlite tds\""
+ die "Enable at least one SQL driver."
+ fi
+
+ qt4-build_pkg_setup
+}
+
+src_prepare() {
+ qt4-build_src_prepare
+
+ sed -e '/pg_config --libs/d' -i "${S}"/configure \
+ || die "sed to fix postgresql usage in ./configure failed"
+}
+
+src_configure() {
+ # Don't support sqlite2 anymore
+ myconf="${myconf} -no-sql-sqlite2
+ $(qt_use mysql sql-mysql plugin) $(use mysql && echo "-I${EPREFIX}/usr/include/mysql -L${EPREFIX}/usr/$(get_libdir)/mysql ")
+ $(qt_use postgres sql-psql plugin) $(use postgres && echo "-I${EPREFIX}/usr/include/postgresql/pgsql ")
+ $(qt_use sqlite sql-sqlite plugin) $(use sqlite && echo '-system-sqlite')
+ $(qt_use odbc sql-odbc plugin)
+ $(qt_use tds sql-tds plugin)
+ $(qt_use qt3support)"
+
+ myconf="${myconf} $(qt_use iconv) -no-xkb -no-fontconfig -no-xrender -no-xrandr
+ -no-xfixes -no-xcursor -no-xinerama -no-xshape -no-sm -no-opengl
+ -no-nas-sound -no-dbus -no-cups -no-nis -no-gif -no-libpng
+ -no-libmng -no-libjpeg -no-openssl -system-zlib -no-webkit -no-phonon
+ -no-xmlpatterns -no-freetype -no-libtiff -no-accessibility -no-fontconfig
+ -no-glib -no-opengl -no-svg -no-gtkstyle"
+
+ qt4-build_src_configure
+}