summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2003-05-13 21:15:26 +0000
committerMarinus Schraal <foser@gentoo.org>2003-05-13 21:15:26 +0000
commit336996b40b4fbddbfec86cd435c6c770f7bbd6eb (patch)
tree48da5a4c28b2acb29b6732a1cb5f2657bd9592ef /x11-libs/vte/vte-0.10.28.ebuild
parentmissing patch (diff)
downloadgentoo-2-336996b40b4fbddbfec86cd435c6c770f7bbd6eb.tar.gz
gentoo-2-336996b40b4fbddbfec86cd435c6c770f7bbd6eb.tar.bz2
gentoo-2-336996b40b4fbddbfec86cd435c6c770f7bbd6eb.zip
new version
Diffstat (limited to 'x11-libs/vte/vte-0.10.28.ebuild')
-rw-r--r--x11-libs/vte/vte-0.10.28.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/vte/vte-0.10.28.ebuild b/x11-libs/vte/vte-0.10.28.ebuild
new file mode 100644
index 000000000000..f17135f7171c
--- /dev/null
+++ b/x11-libs/vte/vte-0.10.28.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.10.28.ebuild,v 1.1 2003/05/13 21:15:26 foser Exp $
+
+inherit gnome2 flag-o-matic
+
+# -Os takes us down (#16173)
+replace-flags "-Os" "-O2"
+
+IUSE="doc python"
+
+DESCRIPTION="Xft powered terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="LGPL-2"
+
+RDEPEND="virtual/glibc
+ >=dev-libs/glib-2
+ >=x11-libs/gtk+-2
+ >=x11-libs/pango-1.2"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.6 )
+ python? ( >=dev-python/pygtk-1.99
+ >=dev-lang/python-2.2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+DOCS="AUTHORS COPY* README HACKING INSTALL NEWS TODO ChangeLog"
+
+use python \
+ && G2CONF="${G2CONF} --enable-python" \
+ || G2CONF="${G2CONF} --disable-python" \