summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2014-04-27 21:51:38 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2014-04-27 21:51:38 +0000
commit59e15989ee2b8dd027e1a8ca487f9717dc22c685 (patch)
treefbd3c7154c5c17a5aa740167c655180dfe2a9d54 /x11-libs/vte
parentClean up colord deps. (diff)
downloadgentoo-2-59e15989ee2b8dd027e1a8ca487f9717dc22c685.tar.gz
gentoo-2-59e15989ee2b8dd027e1a8ca487f9717dc22c685.tar.bz2
gentoo-2-59e15989ee2b8dd027e1a8ca487f9717dc22c685.zip
Version bump for Gnome 3.12. Move CFLAGS and configure switch manipulation to src_configure.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'x11-libs/vte')
-rw-r--r--x11-libs/vte/ChangeLog8
-rw-r--r--x11-libs/vte/vte-0.36.0.ebuild70
2 files changed, 77 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index 659d26801e3a..7a098227456f 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.385 2014/04/27 09:42:19 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.386 2014/04/27 21:51:38 eva Exp $
+
+*vte-0.36.0 (27 Apr 2014)
+
+ 27 Apr 2014; Gilles Dartiguelongue <eva@gentoo.org> +vte-0.36.0.ebuild:
+ Version bump for Gnome 3.12. Move CFLAGS and configure switch manipulation to
+ src_configure.
27 Apr 2014; Pacho Ramos <pacho@gentoo.org> -vte-0.28.2-r204.ebuild,
-vte-0.34.2.ebuild, -vte-0.34.7.ebuild, -vte-0.34.8.ebuild:
diff --git a/x11-libs/vte/vte-0.36.0.ebuild b/x11-libs/vte/vte-0.36.0.ebuild
new file mode 100644
index 000000000000..f24b1e9b2c35
--- /dev/null
+++ b/x11-libs/vte/vte-0.36.0.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.36.0.ebuild,v 1.1 2014/04/27 21:51:38 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+
+inherit eutils gnome2
+
+DESCRIPTION="Library providing a virtual terminal emulator widget"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/Terminal/VTE"
+
+LICENSE="LGPL-2+"
+SLOT="2.90"
+IUSE="debug glade +introspection"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+PDEPEND="=x11-libs/gnome-pty-helper-${PV}"
+RDEPEND="
+ >=dev-libs/glib-2.31.13:2
+ >=x11-libs/gtk+-3.1.9:3[introspection?]
+ >=x11-libs/pango-1.22.0
+
+ sys-libs/ncurses
+ x11-libs/libX11
+ x11-libs/libXft
+
+ glade? ( >=dev-util/glade-3.9:3.10 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.0 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.13
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # https://bugzilla.gnome.org/show_bug.cgi?id=663779
+ epatch "${FILESDIR}/${PN}-0.30.1-alt-meta.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ local myconf=""
+
+ if [[ ${CHOST} == *-interix* ]]; then
+ myconf="${myconf} --disable-Bsymbolic"
+
+ # interix stropts.h is empty...
+ export ac_cv_header_stropts_h=no
+ fi
+
+ # Python bindings are via gobject-introspection
+ # Ex: from gi.repository import Vte
+ # Do not disable gnome-pty-helper, bug #401389
+ gnome2_src_configure \
+ --disable-deprecation \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable glade glade-catalogue) \
+ $(use_enable introspection)
+}
+
+src_install() {
+ DOCS="AUTHORS ChangeLog HACKING NEWS README"
+ gnome2_src_install
+ rm -v "${ED}usr/libexec/gnome-pty-helper" || die
+}