summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-10-08 00:04:35 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-10-08 00:04:35 +0000
commit1d02bcb63548036dbf9517ba2790c90aa9e0e209 (patch)
tree64e5e797b951a7275c9edd5324d1b5ceced55bf5 /x11-libs/wxGTK
parentversion bump, fixes many gtk2 problems. also in p.mask (diff)
downloadgentoo-2-1d02bcb63548036dbf9517ba2790c90aa9e0e209.tar.gz
gentoo-2-1d02bcb63548036dbf9517ba2790c90aa9e0e209.tar.bz2
gentoo-2-1d02bcb63548036dbf9517ba2790c90aa9e0e209.zip
small touchup
Diffstat (limited to 'x11-libs/wxGTK')
-rw-r--r--x11-libs/wxGTK/Manifest2
-rw-r--r--x11-libs/wxGTK/wxGTK-2.4.2.ebuild9
2 files changed, 6 insertions, 5 deletions
diff --git a/x11-libs/wxGTK/Manifest b/x11-libs/wxGTK/Manifest
index 10649cab730a..6f298e87ebc6 100644
--- a/x11-libs/wxGTK/Manifest
+++ b/x11-libs/wxGTK/Manifest
@@ -3,7 +3,7 @@ MD5 4fca175f747a090fd2b7b8ce22fbc06d metadata.xml 162
MD5 f2c6a482f909a8b55480b1ba1cb662f3 wxGTK-2.4.0.ebuild 2697
MD5 5930febd267796b3c7bef3c18132ffeb wxGTK-2.4.1-r1.ebuild 2683
MD5 4d34b0942b01217ef99c488f6c42c79c wxGTK-2.4.1.ebuild 2497
-MD5 88a8ce35ecee60253c0ff415359bad5e wxGTK-2.4.2.ebuild 2281
+MD5 9ba40725b8334e44a6bfef21af45c848 wxGTK-2.4.2.ebuild 2328
MD5 16ea0622454512339b2c613af61a9aa4 files/digest-wxGTK-2.4.0 65
MD5 86ee1d94ec752953d445a824f643fef5 files/digest-wxGTK-2.4.1 65
MD5 86ee1d94ec752953d445a824f643fef5 files/digest-wxGTK-2.4.1-r1 65
diff --git a/x11-libs/wxGTK/wxGTK-2.4.2.ebuild b/x11-libs/wxGTK/wxGTK-2.4.2.ebuild
index ddd4aca6573c..6bfef5dc2503 100644
--- a/x11-libs/wxGTK/wxGTK-2.4.2.ebuild
+++ b/x11-libs/wxGTK/wxGTK-2.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.2.ebuild,v 1.1 2003/10/07 23:49:33 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/wxGTK/wxGTK-2.4.2.ebuild,v 1.2 2003/10/08 00:04:29 liquidx Exp $
DESCRIPTION="GTK+ version of wxWindows, a cross-platform C++ GUI toolkit."
SRC_URI="mirror://sourceforge/wxwindows/${P}.tar.bz2"
@@ -42,7 +42,6 @@ src_unpack() {
src_compile() {
local myconf
- myconf="${myconf} `use_with odbc`"
myconf="${myconf} `use_with opengl`"
myconf="${myconf} --with-gtk"
myconf="${myconf} `use_enable debug`"
@@ -55,10 +54,12 @@ src_compile() {
#
# bug #20116 - liquidx@gentoo.org (07 May 2003)
- #use gtk2 && myconf="${myconf} --enable-gtk2 --enable-unicode"
use gtk2 && myconf="${myconf} --enable-gtk2"
+ # only allow unicode if using gtk2
use gtk2 && use unicode && myconf="${myconf} --enable-unicode"
-
+ # only enable odbc if unicode is not enabled.
+ ( use gtk2 && use unicode ) || myconf="${myconf} --with-odbc"
+
econf ${myconf}
emake || die "make failed"