summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-01-02 11:53:03 +0000
committerPacho Ramos <pacho@gentoo.org>2015-01-02 11:53:03 +0000
commit03c0968ac901d81be237ad6a8bffe648f1abe5ef (patch)
treeb5b8f1c2388ebf2f5c9a72e543b185027ef4449a /x11-libs
parentNewer gtk+ is needed (#532596 by Uros) (diff)
downloadgentoo-2-03c0968ac901d81be237ad6a8bffe648f1abe5ef.tar.gz
gentoo-2-03c0968ac901d81be237ad6a8bffe648f1abe5ef.tar.bz2
gentoo-2-03c0968ac901d81be237ad6a8bffe648f1abe5ef.zip
Include image data in the builtin icon cache (#518352 by Leho Kraav, Rafał Mużyło and more), newer gdbus-codegen needed (#500216 by Vladimir Dolzhenko), unset DISPLAY to make tests work in more environments (#527682 by Gangræna Gorgeous, Mark Wright and Alexander Tsoy).
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog12
-rw-r--r--x11-libs/gtk+/files/gtk+-3.12.2-builtin-icon.patch29
-rw-r--r--x11-libs/gtk+/gtk+-3.12.2-r2.ebuild256
-rw-r--r--x11-libs/gtk+/gtk+-3.14.6.ebuild7
4 files changed, 300 insertions, 4 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index a80b74131e0d..e614305b05b6 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.752 2015/01/01 21:14:20 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.753 2015/01/02 11:53:03 pacho Exp $
+
+*gtk+-3.12.2-r2 (02 Jan 2015)
+
+ 02 Jan 2015; Pacho Ramos <pacho@gentoo.org>
+ +files/gtk+-3.12.2-builtin-icon.patch, +gtk+-3.12.2-r2.ebuild,
+ gtk+-3.14.6.ebuild:
+ Include image data in the builtin icon cache (#518352 by Leho Kraav, Rafał
+ Mużyło and more), newer gdbus-codegen needed (#500216 by Vladimir Dolzhenko),
+ unset DISPLAY to make tests work in more environments (#527682 by Gangræna
+ Gorgeous, Mark Wright and Alexander Tsoy).
01 Jan 2015; Markus Meier <maekke@gentoo.org> gtk+-2.24.25.ebuild:
arm stable, bug #529964
diff --git a/x11-libs/gtk+/files/gtk+-3.12.2-builtin-icon.patch b/x11-libs/gtk+/files/gtk+-3.12.2-builtin-icon.patch
new file mode 100644
index 000000000000..176583fef9d5
--- /dev/null
+++ b/x11-libs/gtk+/files/gtk+-3.12.2-builtin-icon.patch
@@ -0,0 +1,29 @@
+From 46ac7e51d96c8ffb41c1c055fbe97474dcf096f8 Mon Sep 17 00:00:00 2001
+From: Matthias Clasen <mclasen@redhat.com>
+Date: Fri, 15 Aug 2014 10:37:05 -0400
+Subject: Include image data in the builtin icon cache
+
+
+diff --git a/gtk/Makefile.am b/gtk/Makefile.am
+index c281666..9369273 100644
+--- a/gtk/Makefile.am
++++ b/gtk/Makefile.am
+@@ -1779,8 +1779,13 @@ else
+ $(AM_V_at) $(MAKE) $(AM_MAKEFLAGS) gtk-update-icon-cache$(EXEEXT)
+ endif
+ endif
+- $(AM_V_GEN) $(gtk_update_icon_cache_program) --quiet --force --ignore-theme-index \
+- --source builtin_icons stock-icons > gtkbuiltincache.h.tmp && \
++ $(AM_V_GEN) $(gtk_update_icon_cache_program) \
++ --quiet \
++ --force \
++ --ignore-theme-index \
++ --include-image-data \
++ --source builtin_icons stock-icons \
++ > gtkbuiltincache.h.tmp && \
+ mv gtkbuiltincache.h.tmp gtkbuiltincache.h
+
+ EXTRA_DIST += \
+--
+cgit v0.10.1
+
diff --git a/x11-libs/gtk+/gtk+-3.12.2-r2.ebuild b/x11-libs/gtk+/gtk+-3.12.2-r2.ebuild
new file mode 100644
index 000000000000..a1499345f4d4
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-3.12.2-r2.ebuild
@@ -0,0 +1,256 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.12.2-r2.ebuild,v 1.1 2015/01/02 11:53:03 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils flag-o-matic gnome2 multilib virtualx multilib-minimal
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2+"
+SLOT="3"
+# NOTE: This gtk+ has multi-gdk-backend support, see:
+# * http://blogs.gnome.org/kris/2010/12/29/gdk-3-0-on-mac-os-x/
+# * http://mail.gnome.org/archives/gtk-devel-list/2010-November/msg00099.html
+# I tried this and got it all compiling, but the end result is unusable as it
+# horribly mixes up the backends -- grobian
+IUSE="aqua cloudprint colord cups debug examples +introspection test vim-syntax wayland X xinerama"
+REQUIRED_USE="
+ || ( aqua wayland X )
+ xinerama? ( X )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# FIXME: introspection data is built against system installation of gtk+:3
+# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
+# Use gtk+:2 for gtk-update-icon-cache
+COMMON_DEPEND="
+ >=dev-libs/atk-2.7.5[introspection?,${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.39.5:2[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ >=x11-libs/cairo-1.12[aqua?,glib,svg,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gdk-pixbuf-2.27.1:2[introspection?,X?,${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24:2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.32.4[introspection?,${MULTILIB_USEDEP}]
+ x11-misc/shared-mime-info
+
+ cloudprint? (
+ >=net-libs/rest-0.7[${MULTILIB_USEDEP}]
+ >=dev-libs/json-glib-1.0[${MULTILIB_USEDEP}] )
+ colord? ( >=x11-misc/colord-0.1.9:0=[${MULTILIB_USEDEP}] )
+ cups? ( >=net-print/cups-1.2[${MULTILIB_USEDEP}] )
+ introspection? ( >=dev-libs/gobject-introspection-1.39 )
+ wayland? (
+ >=dev-libs/wayland-1.3.90[${MULTILIB_USEDEP}]
+ media-libs/mesa[wayland,${MULTILIB_USEDEP}]
+ >=x11-libs/libxkbcommon-0.2[${MULTILIB_USEDEP}]
+ )
+ X? (
+ >=app-accessibility/at-spi2-atk-2.5.3[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ >=x11-libs/libXi-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ >=x11-libs/libXrandr-1.3[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ xinerama? ( x11-libs/libXinerama[${MULTILIB_USEDEP}] )
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/libxslt
+ >=dev-util/gdbus-codegen-2.38.2
+ >=dev-util/gtk-doc-am-1.20
+ sys-devel/gettext
+ virtual/pkgconfig[${MULTILIB_USEDEP}]
+ X? (
+ x11-proto/xextproto[${MULTILIB_USEDEP}]
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ x11-proto/inputproto[${MULTILIB_USEDEP}]
+ x11-proto/damageproto[${MULTILIB_USEDEP}]
+ xinerama? ( x11-proto/xineramaproto[${MULTILIB_USEDEP}] )
+ )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )
+"
+# gtk+-3.2.2 breaks Alt key handling in <=x11-libs/vte-0.30.1:2.90
+# gtk+-3.3.18 breaks scrolling in <=x11-libs/vte-0.31.0:2.90
+# >=xorg-server-1.11.4 needed for
+# http://mail.gnome.org/archives/desktop-devel-list/2012-March/msg00024.html
+RDEPEND="${COMMON_DEPEND}
+ !<gnome-base/gail-1000
+ !<x11-libs/vte-0.31.0:2.90
+ X? ( !<x11-base/xorg-server-1.11.4 )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20140508-r3
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )
+"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+MULTILIB_CHOST_TOOLS=(
+ /usr/bin/gtk-query-immodules-3.0
+)
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+src_prepare() {
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ # Build fix on Darwin 10.6; bug #519058
+ epatch "${FILESDIR}/${P}-darwin10.6.patch"
+
+ # Include image data in the builtin icon cache, needs --enable-gtk2-dependency
+ # and, then, upstream reverted this patch lately. Fixed in 3.14.x, bug #518352
+ epatch "${FILESDIR}/${PN}-3.12.2-builtin-icon.patch"
+
+ if ! use test ; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS testsuite Makefile.am
+ strip_builddir SRC_SUBDIRS testsuite Makefile.in
+ strip_builddir SRC_SUBDIRS tests Makefile.am
+ strip_builddir SRC_SUBDIRS tests Makefile.in
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.am
+ strip_builddir SRC_SUBDIRS demos Makefile.in
+ strip_builddir SRC_SUBDIRS examples Makefile.am
+ strip_builddir SRC_SUBDIRS examples Makefile.in
+ fi
+
+ eautoreconf
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ # Passing --disable-debug is not recommended for production use
+ # need libdir here to avoid a double slash in a path that libtool doesn't
+ # grok so well during install (// between $EPREFIX and usr ...)
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(use_enable aqua quartz-backend) \
+ $(use_enable cloudprint) \
+ $(use_enable colord) \
+ $(use_enable cups cups auto) \
+ $(usex debug --enable-debug=yes "") \
+ $(multilib_native_use_enable introspection) \
+ $(use_enable wayland wayland-backend) \
+ $(use_enable X x11-backend) \
+ $(use_enable X xcomposite) \
+ $(use_enable X xdamage) \
+ $(use_enable X xfixes) \
+ $(use_enable X xkb) \
+ $(use_enable X xrandr) \
+ $(use_enable xinerama) \
+ --disable-papi \
+ --enable-man \
+ --enable-gtk2-dependency \
+ --with-xml-catalog="${EPREFIX}"/etc/xml/catalog \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
+ CUPS_CONFIG="${EPREFIX}/usr/bin/${CHOST}-cups-config"
+
+ # work-around gtk-doc out-of-source brokedness
+ if multilib_is_native_abi; then
+ local d
+ for d in gdk gtk libgail-util; do
+ ln -s "${S}"/docs/reference/${d}/html docs/reference/${d}/html || die
+ done
+ fi
+}
+
+multilib_src_test() {
+ # Tests require a new gnome-themes-standard, but adding it to DEPEND
+ # would result in circular dependencies.
+ # https://bugzilla.gnome.org/show_bug.cgi?id=669562
+ if ! has_version '>=x11-themes/gnome-themes-standard-3.6[gtk]'; then
+ ewarn "Tests will be skipped because >=gnome-themes-standard-3.6[gtk]"
+ ewarn "is not installed. Please re-run tests after installing the"
+ ewarn "required version of gnome-themes-standard."
+ return 0
+ fi
+
+ # FIXME: this should be handled at eclass level
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ unset DISPLAY #527682
+ GSETTINGS_SCHEMA_DIR="${S}/gtk" Xemake check
+}
+
+multilib_src_install() {
+ gnome2_src_install
+
+ # add -framework Carbon to the .pc files
+ if use aqua ; then
+ for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
+ sed -e "s:Libs\: :Libs\: -framework Carbon :" \
+ -i "${ED}"usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
+ done
+ fi
+}
+
+multilib_src_install_all() {
+ insinto /etc/gtk-3.0
+ doins "${FILESDIR}"/settings.ini
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+}
+
+pkg_preinst() {
+ gnome2_pkg_preinst
+
+ multilib_pkg_preinst() {
+ # Make sure loaders.cache belongs to gdk-pixbuf alone
+ local cache="usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache"
+
+ if [[ -e ${EROOT}${cache} ]]; then
+ cp "${EROOT}"${cache} "${ED}"/${cache} || die
+ else
+ touch "${ED}"/${cache} || die
+ fi
+ }
+ multilib_parallel_foreach_abi multilib_pkg_preinst
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ gnome2_query_immodules_gtk3
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your settings.ini file."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+
+ if [[ -z ${REPLACED_BY_VERSIONS} ]]; then
+ multilib_pkg_postrm() {
+ rm -f "${EROOT}"usr/$(get_libdir)/gtk-3.0/3.0.0/immodules.cache
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+ fi
+}
diff --git a/x11-libs/gtk+/gtk+-3.14.6.ebuild b/x11-libs/gtk+/gtk+-3.14.6.ebuild
index d3445915b485..54816298f15d 100644
--- a/x11-libs/gtk+/gtk+-3.14.6.ebuild
+++ b/x11-libs/gtk+/gtk+-3.14.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.14.6.ebuild,v 1.3 2014/12/28 23:10:20 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.14.6.ebuild,v 1.4 2015/01/02 11:53:03 pacho Exp $
EAPI="5"
GCONF_DEBUG="no"
@@ -69,7 +69,7 @@ DEPEND="${COMMON_DEPEND}
app-text/docbook-xml-dtd:4.1.2
dev-libs/libxslt
dev-libs/gobject-introspection-common
- dev-util/gdbus-codegen
+ >=dev-util/gdbus-codegen-2.38.2
>=dev-util/gtk-doc-am-1.20
sys-devel/gettext
virtual/pkgconfig[${MULTILIB_USEDEP}]
@@ -190,6 +190,7 @@ multilib_src_test() {
"${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/gtk" || die
unset DBUS_SESSION_BUS_ADDRESS
+ unset DISPLAY #527682
GSETTINGS_SCHEMA_DIR="${S}/gtk" Xemake check
}