summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2012-03-27 08:57:56 +0000
committerPacho Ramos <pacho@gentoo.org>2012-03-27 08:57:56 +0000
commit0f578bcccf6855dafb24e3f3e928186bb712d913 (patch)
tree64cf36dac98679211f18279e9cfc7fa190e08521 /x11-libs
parentDoes not work with networkmanager-0.9 (diff)
downloadgentoo-2-0f578bcccf6855dafb24e3f3e928186bb712d913.tar.gz
gentoo-2-0f578bcccf6855dafb24e3f3e928186bb712d913.tar.bz2
gentoo-2-0f578bcccf6855dafb24e3f3e928186bb712d913.zip
Version bump, remove old.
(Portage version: 2.1.10.51/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/rep-gtk/ChangeLog10
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.90.3.ebuild34
-rw-r--r--x11-libs/rep-gtk/rep-gtk-0.90.8.ebuild43
3 files changed, 51 insertions, 36 deletions
diff --git a/x11-libs/rep-gtk/ChangeLog b/x11-libs/rep-gtk/ChangeLog
index 6659bfff667e..a77f1d912507 100644
--- a/x11-libs/rep-gtk/ChangeLog
+++ b/x11-libs/rep-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/rep-gtk
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.73 2011/10/30 17:44:53 armin76 Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/ChangeLog,v 1.74 2012/03/27 08:57:56 pacho Exp $
+
+*rep-gtk-0.90.8 (27 Mar 2012)
+
+ 27 Mar 2012; Pacho Ramos <pacho@gentoo.org> +rep-gtk-0.90.8.ebuild,
+ -rep-gtk-0.90.3.ebuild:
+ Version bump, remove old.
30 Oct 2011; Raúl Porcel <armin76@gentoo.org> rep-gtk-0.90.7.ebuild:
alpha/ia64/sparc stable wrt #385699
diff --git a/x11-libs/rep-gtk/rep-gtk-0.90.3.ebuild b/x11-libs/rep-gtk/rep-gtk-0.90.3.ebuild
deleted file mode 100644
index 623294bbec96..000000000000
--- a/x11-libs/rep-gtk/rep-gtk-0.90.3.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.90.3.ebuild,v 1.5 2011/08/07 17:39:40 armin76 Exp $
-
-EAPI="1"
-
-inherit eutils multilib
-
-DESCRIPTION="A GTK+/libglade/GNOME language binding for the librep Lisp environment"
-HOMEPAGE="http://rep-gtk.sourceforge.net/"
-SRC_URI="http://download.tuxfamily.org/sawfish/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="gtk-2.0"
-KEYWORDS="alpha amd64 ia64 ~ppc ~ppc64 sparc x86"
-IUSE=""
-
-RDEPEND=">=dev-libs/librep-0.90.5
- >=dev-libs/glib-2.6:2
- >=x11-libs/gtk+-2.12:2"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.12.0"
-
-src_compile() {
- econf \
- --libdir=/usr/$(get_libdir) || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
-
- dodoc AUTHORS BUGS ChangeLog HACKING README* TODO
-}
diff --git a/x11-libs/rep-gtk/rep-gtk-0.90.8.ebuild b/x11-libs/rep-gtk/rep-gtk-0.90.8.ebuild
new file mode 100644
index 000000000000..36b9ff54220a
--- /dev/null
+++ b/x11-libs/rep-gtk/rep-gtk-0.90.8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/rep-gtk/rep-gtk-0.90.8.ebuild,v 1.1 2012/03/27 08:57:56 pacho Exp $
+
+EAPI="4"
+
+inherit eutils multilib
+
+DESCRIPTION="A GTK+/libglade/GNOME language binding for the librep Lisp environment"
+HOMEPAGE="http://sawfish.wikia.com/wiki/Main_Page"
+SRC_URI="http://download.tuxfamily.org/librep/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="gtk-2.0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/librep-0.90.5
+ >=dev-libs/glib-2.6:2
+ >=x11-libs/gtk+-2.24.0:2
+ >=x11-libs/gdk-pixbuf-2.23:2"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ app-arch/xz-utils"
+
+#src_prepare() {
+ # Fix undefined symbol problems like bug #367623
+ # http://listengine.tuxfamily.org/lists.tuxfamily.org/sawfish/2011/09/msg00026.html
+ # TODO: Doesn't apply, if some people still get the failure, try to push a bit upstream
+ #epatch "${FILESDIR}/${PN}-0.90.7-implicit-def-new.patch"
+#}
+
+src_configure() {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --disable-static
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ find "${D}" -name '*.la' -exec rm -f {} + || die "la file removal failed"
+ dodoc AUTHORS ChangeLog README* TODO
+}