summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavide Pesavento <pesa@gentoo.org>2012-04-04 13:29:25 +0000
committerDavide Pesavento <pesa@gentoo.org>2012-04-04 13:29:25 +0000
commit44caeebfa299eb701e1892b2fa350fc73f20fdb2 (patch)
tree1d64ad577525d6395afab81cd75c25d7e0f0abe3 /x11-libs
parentdev-python/six: Keyworded for ~-linux tested by me (diff)
downloadgentoo-2-44caeebfa299eb701e1892b2fa350fc73f20fdb2.tar.gz
gentoo-2-44caeebfa299eb701e1892b2fa350fc73f20fdb2.tar.bz2
gentoo-2-44caeebfa299eb701e1892b2fa350fc73f20fdb2.zip
Fix build with >=dev-libs/glib-2.31 (bug 401855).
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/ChangeLog6
-rw-r--r--x11-libs/qt-webkit/files/qt-webkit-4.8.1+glib-2.31.patch30
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.8.1.ebuild3
3 files changed, 37 insertions, 2 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index aa45868b1c12..90d960c62e39 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.139 2012/03/29 22:17:41 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.140 2012/04/04 13:29:25 pesa Exp $
+
+ 04 Apr 2012; Davide Pesavento <pesa@gentoo.org>
+ +files/qt-webkit-4.8.1+glib-2.31.patch, qt-webkit-4.8.1.ebuild:
+ Fix build with >=dev-libs/glib-2.31 (bug 401855).
*qt-webkit-4.8.1 (29 Mar 2012)
diff --git a/x11-libs/qt-webkit/files/qt-webkit-4.8.1+glib-2.31.patch b/x11-libs/qt-webkit/files/qt-webkit-4.8.1+glib-2.31.patch
new file mode 100644
index 000000000000..ced3794caed5
--- /dev/null
+++ b/x11-libs/qt-webkit/files/qt-webkit-4.8.1+glib-2.31.patch
@@ -0,0 +1,30 @@
+diff -Naur qt-everywhere-opensource-src-4.8.1.orig/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GOwnPtr.h qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GOwnPtr.h
+--- qt-everywhere-opensource-src-4.8.1.orig/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GOwnPtr.h 2012-04-01 19:32:46.621395314 +0200
++++ qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GOwnPtr.h 2012-04-01 19:34:23.693181749 +0200
+@@ -24,6 +24,7 @@
+
+ #if ENABLE(GLIB_SUPPORT)
+
++#include <glib.h>
+ #include <algorithm>
+ #include <wtf/Assertions.h>
+ #include <wtf/Noncopyable.h>
+diff -Naur qt-everywhere-opensource-src-4.8.1.orig/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h
+--- qt-everywhere-opensource-src-4.8.1.orig/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h 2012-04-01 19:32:46.624395278 +0200
++++ qt-everywhere-opensource-src-4.8.1/src/3rdparty/webkit/Source/JavaScriptCore/wtf/gobject/GTypedefs.h 2012-04-01 19:34:09.420360184 +0200
+@@ -39,7 +39,6 @@
+ typedef struct _GAsyncResult GAsyncResult;
+ typedef struct _GCancellable GCancellable;
+ typedef struct _GCharsetConverter GCharsetConverter;
+-typedef struct _GCond GCond;
+ typedef struct _GDir GDir;
+ typedef struct _GdkAtom* GdkAtom;
+ typedef struct _GdkCursor GdkCursor;
+@@ -52,7 +51,6 @@
+ typedef struct _GHashTable GHashTable;
+ typedef struct _GInputStream GInputStream;
+ typedef struct _GList GList;
+-typedef struct _GMutex GMutex;
+ typedef struct _GPatternSpec GPatternSpec;
+ typedef struct _GPollableOutputStream GPollableOutputStream;
+ typedef struct _GSocketClient GSocketClient;
diff --git a/x11-libs/qt-webkit/qt-webkit-4.8.1.ebuild b/x11-libs/qt-webkit/qt-webkit-4.8.1.ebuild
index 8599ff7ffc78..b85345474a15 100644
--- a/x11-libs/qt-webkit/qt-webkit-4.8.1.ebuild
+++ b/x11-libs/qt-webkit/qt-webkit-4.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.8.1.ebuild,v 1.1 2012/03/29 22:17:41 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.8.1.ebuild,v 1.2 2012/04/04 13:29:25 pesa Exp $
EAPI=4
@@ -28,6 +28,7 @@ RDEPEND="${DEPEND}"
PATCHES=(
"${FILESDIR}/${PN}-4.8.0-c++0x-fix.patch"
+ "${FILESDIR}/${P}+glib-2.31.patch"
)
pkg_setup() {