summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-08-11 13:00:51 +0000
committerBen de Groot <yngwin@gentoo.org>2008-08-11 13:00:51 +0000
commit64af4869347108ee5408f497b4003f3314cb8ed7 (patch)
tree768e8ad2f54e2e142eb2d8231a3af8511074def9 /x11-libs
parentVersion bump to 4.4.1 (diff)
downloadgentoo-2-64af4869347108ee5408f497b4003f3314cb8ed7.tar.gz
gentoo-2-64af4869347108ee5408f497b4003f3314cb8ed7.tar.bz2
gentoo-2-64af4869347108ee5408f497b4003f3314cb8ed7.zip
Version bump to 4.4.1
(Portage version: 2.2_rc7/cvs/Linux 2.6.26-hh1 i686)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-dbus/ChangeLog7
-rw-r--r--x11-libs/qt-dbus/qt-dbus-4.4.1.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/x11-libs/qt-dbus/ChangeLog b/x11-libs/qt-dbus/ChangeLog
index c8d3ec6d1d80..b76e63be76e1 100644
--- a/x11-libs/qt-dbus/ChangeLog
+++ b/x11-libs/qt-dbus/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-dbus
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.10 2008/06/13 23:20:45 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/ChangeLog,v 1.11 2008/08/11 13:00:51 yngwin Exp $
+
+*qt-dbus-4.4.1 (11 Aug 2008)
+
+ 11 Aug 2008; Ben de Groot <yngwin@gentoo.org> +qt-dbus-4.4.1.ebuild:
+ Version bump
13 Jun 2008; Ingmar Vanhassel <ingmar@gentoo.org> qt-dbus-4.4.0.ebuild:
Make all split Qt4 ebuilds block the old monolithic ebuild.
diff --git a/x11-libs/qt-dbus/qt-dbus-4.4.1.ebuild b/x11-libs/qt-dbus/qt-dbus-4.4.1.ebuild
new file mode 100644
index 000000000000..8100f403d485
--- /dev/null
+++ b/x11-libs/qt-dbus/qt-dbus-4.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-dbus/qt-dbus-4.4.1.ebuild,v 1.1 2008/08/11 13:00:51 yngwin Exp $
+
+EAPI="1"
+inherit qt4-build
+
+DESCRIPTION="The DBus module for the Qt toolkit."
+HOMEPAGE="http://www.trolltech.com/"
+
+LICENSE="|| ( GPL-3 GPL-2 )"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# depend on gui instead of core. There's a GUI based viewer that's built, and since it's a desktop
+# protocol I don't know if there's value trying to derive it out into a core build
+# The library itself, however, only depends on core and xml
+DEPEND="~x11-libs/qt-core-${PV}
+ >=sys-apps/dbus-1.0.2
+ !<=x11-libs/qt-4.4.0_alpha:${SLOT}"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="
+src/dbus
+tools/qdbus/qdbus
+tools/qdbus/qdbusxml2cpp
+tools/qdbus/qdbuscpp2xml"
+QCONFIG_ADD="dbus dbus-linked"
+QCONFIG_DEFINE="QT_DBUS"
+
+#FIXME: Check if these are still needed with the header package
+QT4_EXTRACT_DIRECTORIES="${QT4_TARGET_DIRECTORIES}
+include/Qt/
+include/QtCore/
+include/QtDBus/
+src/corelib/global/
+src/corelib/io/
+src/corelib/kernel/
+src/corelib/thread/
+src/corelib/tools/
+"
+
+src_compile() {
+ local myconf
+ myconf="${myconf} -dbus-linked"
+
+ qt4-build_src_compile
+}