summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-03-04 21:01:59 +0000
committerBen de Groot <yngwin@gentoo.org>2009-03-04 21:01:59 +0000
commit66ee224b5dee12ade12f95706b385cbc2161cda3 (patch)
tree421a0edc0b075704e5c332261241244f66dcf9d3 /x11-libs
parentBump KDE 4.2.1 (diff)
downloadgentoo-2-66ee224b5dee12ade12f95706b385cbc2161cda3.tar.gz
gentoo-2-66ee224b5dee12ade12f95706b385cbc2161cda3.tar.bz2
gentoo-2-66ee224b5dee12ade12f95706b385cbc2161cda3.zip
Qt 4.5.0 release version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/qt-webkit/ChangeLog7
-rw-r--r--x11-libs/qt-webkit/qt-webkit-4.5.0.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/x11-libs/qt-webkit/ChangeLog b/x11-libs/qt-webkit/ChangeLog
index 1a8d4f7ae719..1d3d9aa84d56 100644
--- a/x11-libs/qt-webkit/ChangeLog
+++ b/x11-libs/qt-webkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/qt-webkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.22 2009/02/18 20:15:21 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/ChangeLog,v 1.23 2009/03/04 21:01:59 yngwin Exp $
+
+*qt-webkit-4.5.0 (04 Mar 2009)
+
+ 04 Mar 2009; Ben de Groot <yngwin@gentoo.org> +qt-webkit-4.5.0.ebuild:
+ Version bump
18 Feb 2009; Jeroen Roovers <jer@gentoo.org> qt-webkit-4.4.2.ebuild:
Stable for HPPA (bug #248083).
diff --git a/x11-libs/qt-webkit/qt-webkit-4.5.0.ebuild b/x11-libs/qt-webkit/qt-webkit-4.5.0.ebuild
new file mode 100644
index 000000000000..b27ab21f86d6
--- /dev/null
+++ b/x11-libs/qt-webkit/qt-webkit-4.5.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/qt-webkit/qt-webkit-4.5.0.ebuild,v 1.1 2009/03/04 21:01:59 yngwin Exp $
+
+EAPI="2"
+inherit qt4-build
+
+DESCRIPTION="The Webkit module for the Qt toolkit"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+DEPEND="~x11-libs/qt-core-${PV}[debug=,ssl]
+ ~x11-libs/qt-gui-${PV}[debug=]
+ || ( ~x11-libs/qt-phonon-${PV}:${SLOT}[debug=] media-sound/phonon )"
+RDEPEND="${DEPEND}"
+
+QT4_TARGET_DIRECTORIES="src/3rdparty/webkit/WebCore tools/designer/src/plugins/qwebview"
+QT4_EXTRACT_DIRECTORIES="
+include/
+src/
+tools/"
+QCONFIG_ADD="webkit"
+QCONFIG_DEFINE="QT_WEBKIT"
+
+src_prepare() {
+ [[ $(tc-arch) == "ppc64" ]] && append-flags -mminimal-toc #241900
+ qt4-build_src_prepare
+}
+
+src_configure() {
+ myconf="${myconf} -webkit"
+ qt4-build_src_configure
+}