summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-06-14 02:42:37 +0000
committerMart Raudsepp <leio@gentoo.org>2007-06-14 02:42:37 +0000
commit83e0dcc3e78052b9d8817f43f8901f4fe176b227 (patch)
tree1d91a876f3058edf38bdc7e8c0db3e17fd3e1852 /x11-libs
parentStable on mips, per #181965. (diff)
downloadgentoo-2-83e0dcc3e78052b9d8817f43f8901f4fe176b227.tar.gz
gentoo-2-83e0dcc3e78052b9d8817f43f8901f4fe176b227.tar.bz2
gentoo-2-83e0dcc3e78052b9d8817f43f8901f4fe176b227.zip
Version bump for bug fixes. Should also fix our bug #180669
(Portage version: 2.1.2.9)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog7
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.10.133
-rw-r--r--x11-libs/gtk+/gtk+-2.10.13.ebuild154
3 files changed, 163 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index cd67b69b308c..d87eca5dc374 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.317 2007/06/02 02:39:38 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.318 2007/06/14 02:42:37 leio Exp $
+
+*gtk+-2.10.13 (14 Jun 2007)
+
+ 14 Jun 2007; Mart Raudsepp <leio@gentoo.org> +gtk+-2.10.13.ebuild:
+ Version bump for bug fixes. Should also fix our bug #180669
02 Jun 2007; Brent Baude <ranger@gentoo.org> gtk+-2.10.11.ebuild:
Marking gtk+-2.10.11 ppc stable for bug #171107
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.10.13 b/x11-libs/gtk+/files/digest-gtk+-2.10.13
new file mode 100644
index 000000000000..96dba50326a8
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.10.13
@@ -0,0 +1,3 @@
+MD5 d0af87715f3b0f05bf38a3312a528012 gtk+-2.10.13.tar.bz2 15163566
+RMD160 bd812db8b11fbca5283e04958660fd3beec23caa gtk+-2.10.13.tar.bz2 15163566
+SHA256 6443ecc087a7cf771406264044e3f942ca49cc5fcb84f66d700fd291d55d0b4e gtk+-2.10.13.tar.bz2 15163566
diff --git a/x11-libs/gtk+/gtk+-2.10.13.ebuild b/x11-libs/gtk+/gtk+-2.10.13.ebuild
new file mode 100644
index 000000000000..a65e053995bf
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.10.13.ebuild
@@ -0,0 +1,154 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.10.13.ebuild,v 1.1 2007/06/14 02:42:37 leio Exp $
+
+inherit gnome.org flag-o-matic eutils autotools virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc jpeg tiff xinerama"
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ x11-libs/libXcursor
+ x11-libs/libXrandr
+ x11-libs/libXfixes
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.12.1
+ >=x11-libs/pango-1.12.0
+ >=dev-libs/atk-1.10.1
+ >=x11-libs/cairo-1.2.0
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )"
+
+DEPEND="${RDEPEND}
+ sys-devel/autoconf
+ >=dev-util/pkgconfig-0.9
+ =sys-devel/automake-1.7*
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ xinerama? ( x11-proto/xineramaproto )
+ doc? (
+ >=dev-util/gtk-doc-1.4
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+RESTRICT="confcache"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo X; then
+ einfo "Please re-emerge x11-libs/cairo with the X USE flag set"
+ die "cairo needs the X flag set"
+ fi
+}
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Optionalize xinerama support
+ epatch "${FILESDIR}/${PN}-2.8.10-xinerama.patch"
+
+ # Make gtk-update-icon-cache check subdirs in it's update check
+ epatch "${FILESDIR}"/${PN}-2.10.11-update-icon-subdirs.patch
+
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ has_multilib_profile && epatch "${FILESDIR}/${PN}-2.8.0-multilib.patch"
+
+ # Revert DND change that makes mozilla products DND broken
+ EPATCH_OPTS="-R" epatch "${FILESDIR}/${PN}-2.10.7-mozilla-dnd-fix.patch"
+
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ use ppc64 && append-flags -mminimal-toc
+
+ # remember, eautoreconf applies elibtoolize.
+ # if you remove this, you should manually run elibtoolize
+ export WANT_AUTOMAKE=1.7
+ cp aclocal.m4 old_macros.m4
+ AT_M4DIR="."
+ eautoreconf
+
+ epunt_cxx
+}
+
+src_compile() {
+ # png always on to display icons (foser)
+ local myconf="$(use_enable doc gtk-doc) \
+ $(use_with jpeg libjpeg) \
+ $(use_with tiff libtiff) \
+ $(use_enable xinerama) \
+ --with-libpng \
+ --with-gdktarget=x11 \
+ --with-xinput"
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf} || die "configure failed"
+
+ emake || die "compile failed"
+}
+
+src_test() {
+ Xmake check || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
+
+ # see bug #133241
+ echo 'gtk-fallback-icon-theme = "gnome"' > ${D}/${GTK2_CONFDIR}/gtkrc
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ dodir /etc/env.d
+ echo "GDK_USE_XFT=1" > ${D}/etc/env.d/50gtk2
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ if [ -d "${ROOT}${GTK2_CONFDIR}" ]; then
+ gtk-query-immodules-2.0 > ${ROOT}${GTK2_CONFDIR}/gtk.immodules
+ gdk-pixbuf-query-loaders > ${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders
+ else
+ ewarn "The destination path ${ROOT}${GTK2_CONFDIR} doesn't exist;"
+ ewarn "to complete the installation of GTK+, please create the"
+ ewarn "directory and then manually run:"
+ ewarn " cd ${ROOT}${GTK2_CONFDIR}"
+ ewarn " gtk-query-immodules-2.0 > gtk.immodules"
+ ewarn " gdk-pixbuf-query-loaders > gdk-pixbuf.loaders"
+ fi
+
+ if [ -e /usr/lib/gtk-2.0/2.[^1]* ]; then
+ elog "You need to rebuild ebuilds that installed into" /usr/lib/gtk-2.0/2.[^1]*
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC /usr/lib/gtk-2.0/2.[^1]*)"
+ fi
+}