summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-10-13 01:48:33 +0000
committerMart Raudsepp <leio@gentoo.org>2006-10-13 01:48:33 +0000
commit8ef3426f6e7a6fc6b734d9e9d9a9fd9de3fae335 (patch)
tree796a9ecebb7cab6896ba570deb82f4a2bb132926 /x11-libs
parentVersion bump. (diff)
downloadgentoo-2-8ef3426f6e7a6fc6b734d9e9d9a9fd9de3fae335.tar.gz
gentoo-2-8ef3426f6e7a6fc6b734d9e9d9a9fd9de3fae335.tar.bz2
gentoo-2-8ef3426f6e7a6fc6b734d9e9d9a9fd9de3fae335.zip
Bump
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/pango/ChangeLog7
-rw-r--r--x11-libs/pango/files/digest-pango-1.14.63
-rw-r--r--x11-libs/pango/pango-1.14.6.ebuild75
3 files changed, 84 insertions, 1 deletions
diff --git a/x11-libs/pango/ChangeLog b/x11-libs/pango/ChangeLog
index 4c6b5af3cc11..88f348ef9bfd 100644
--- a/x11-libs/pango/ChangeLog
+++ b/x11-libs/pango/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/pango
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.150 2006/10/07 06:13:56 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/ChangeLog,v 1.151 2006/10/13 01:48:33 leio Exp $
+
+*pango-1.14.6 (13 Oct 2006)
+
+ 13 Oct 2006; Mart Raudsepp <leio@gentoo.org> +pango-1.14.6.ebuild:
+ Version bump for more cjk goodness
*pango-1.14.5 (07 Oct 2006)
diff --git a/x11-libs/pango/files/digest-pango-1.14.6 b/x11-libs/pango/files/digest-pango-1.14.6
new file mode 100644
index 000000000000..4b426ced18ed
--- /dev/null
+++ b/x11-libs/pango/files/digest-pango-1.14.6
@@ -0,0 +1,3 @@
+MD5 e2c9658c6ed0b1f6bdc3b7c1171bf90f pango-1.14.6.tar.bz2 1288450
+RMD160 3c5b61e28befd2b205fa92b279b99c08e51da154 pango-1.14.6.tar.bz2 1288450
+SHA256 5847ed8f46062635657015fd76bfc86689df073472eb3d05469974a3f71d1a17 pango-1.14.6.tar.bz2 1288450
diff --git a/x11-libs/pango/pango-1.14.6.ebuild b/x11-libs/pango/pango-1.14.6.ebuild
new file mode 100644
index 000000000000..86397b992578
--- /dev/null
+++ b/x11-libs/pango/pango-1.14.6.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/pango/pango-1.14.6.ebuild,v 1.1 2006/10/13 01:48:33 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="Text rendering and layout library"
+HOMEPAGE="http://www.pango.org/"
+
+LICENSE="LGPL-2 FTL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND="|| (
+ (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXft
+ )
+ virtual/x11
+ )
+ >=dev-libs/glib-2.10.0
+ >=media-libs/fontconfig-1.0.1
+ >=media-libs/freetype-2
+ >=x11-libs/cairo-1.2.2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ || ( x11-proto/xproto virtual/x11 )
+ doc? (
+ >=dev-util/gtk-doc-1
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+
+DOCS="AUTHORS ChangeLog* NEWS README TODO*"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # Some enhancements from Redhat
+ # These NEED to go upstream.
+ epatch ${FILESDIR}/pango-1.11.3-xfonts.patch
+ epatch ${FILESDIR}/${PN}-1.10.2-slighthint.patch
+
+ # make config file location host specific so that a 32bit and 64bit pango
+ # wont fight with each other on a multilib system
+ use amd64 && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && epatch ${FILESDIR}/pango-1.2.5-lib64.patch
+
+ epunt_cxx
+}
+
+src_install() {
+ gnome2_src_install
+
+ rm ${D}/etc/pango/pango.modules
+}
+
+pkg_postinst() {
+ if [ "${ROOT}" == "/" ] ; then
+ einfo "Generating modules listing..."
+
+ use amd64 && PANGO_CONFDIR="/etc/pango/${CHOST}"
+ use x86 && [ "${CONF_LIBDIR}" == "lib32" ] && PANGO_CONFDIR="/etc/pango/${CHOST}"
+
+ PANGO_CONFDIR=${PANGO_CONFDIR:=/etc/pango}
+ mkdir -p ${PANGO_CONFDIR}
+
+ pango-querymodules > ${PANGO_CONFDIR}/pango.modules
+ fi
+}