summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-02 21:51:12 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2014-05-02 21:51:12 +0000
commit9ea00116c9433747f893a0522ae0520031e66522 (patch)
treeaecd2ef317523c821a65835032b06789a6e5dee9 /x11-libs
parentBump bino to 1.4.4 thanks to PhobosK, see bug #501374, #499772 and #482938 (diff)
downloadgentoo-2-9ea00116c9433747f893a0522ae0520031e66522.tar.gz
gentoo-2-9ea00116c9433747f893a0522ae0520031e66522.tar.bz2
gentoo-2-9ea00116c9433747f893a0522ae0520031e66522.zip
Fix firefox crash (bug #507478, thanks to Jaak Ristioja and Patrice Levesque). Make lto optional (but enabled by default because cairo is a performance-critical library) and check for enough memory for it (bug #467278, thanks to Alex). Fix build with USE="opengl -X" (bug #483574, thanks to Sergey Popov).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key CF0ADD61)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/cairo/ChangeLog16
-rw-r--r--x11-libs/cairo/cairo-1.12.16-r3.ebuild208
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild34
-rw-r--r--x11-libs/cairo/files/cairo-1.12.16-all-clipped-1.patch38
-rw-r--r--x11-libs/cairo/files/cairo-1.12.16-all-clipped-2.patch28
-rw-r--r--x11-libs/cairo/files/cairo-1.12.16-all-clipped-3.patch28
-rw-r--r--x11-libs/cairo/files/cairo-1.12.16-lto-optional.patch28
-rw-r--r--x11-libs/cairo/metadata.xml3
8 files changed, 379 insertions, 4 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index bb5f2555a465..82be0a4926af 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,20 @@
# ChangeLog for x11-libs/cairo
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.375 2014/05/02 09:51:49 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.376 2014/05/02 21:51:12 tetromino Exp $
+
+*cairo-1.12.16-r3 (02 May 2014)
+
+ 02 May 2014; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +cairo-1.12.16-r3.ebuild, cairo-9999.ebuild,
+ +files/cairo-1.12.16-all-clipped-1.patch,
+ +files/cairo-1.12.16-all-clipped-2.patch,
+ +files/cairo-1.12.16-all-clipped-3.patch,
+ +files/cairo-1.12.16-lto-optional.patch, metadata.xml:
+ Fix firefox crash (bug #507478, thanks to Jaak Ristioja and Patrice
+ Levesque). Make lto optional (but enabled by default because cairo is a
+ performance-critical library) and check for enough memory for it (bug
+ #467278, thanks to Alex). Fix build with USE="opengl -X" (bug #483574, thanks
+ to Sergey Popov).
02 May 2014; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
cairo-1.10.2-r3.ebuild, cairo-1.12.14-r4.ebuild, cairo-1.12.16-r2.ebuild,
diff --git a/x11-libs/cairo/cairo-1.12.16-r3.ebuild b/x11-libs/cairo/cairo-1.12.16-r3.ebuild
new file mode 100644
index 000000000000..9f439daf4a99
--- /dev/null
+++ b/x11-libs/cairo/cairo-1.12.16-r3.ebuild
@@ -0,0 +1,208 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.12.16-r3.ebuild,v 1.1 2014/05/02 21:51:12 tetromino Exp $
+
+EAPI=5
+
+inherit check-reqs eutils flag-o-matic autotools multilib-minimal
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-2
+ EGIT_REPO_URI="git://anongit.freedesktop.org/git/cairo"
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://cairographics.org/releases/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="A vector graphics library with cross-device output support"
+HOMEPAGE="http://cairographics.org/"
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+IUSE="X aqua debug directfb drm gallium gles2 +glib legacy-drivers +lto opengl openvg qt4 static-libs +svg valgrind xcb xlib-xcb"
+# gtk-doc regeneration doesn't seem to work with out-of-source builds
+#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
+
+# Test causes a circular depend on gtk+... since gtk+ needs cairo but test needs gtk+ so we need to block it
+RESTRICT="test"
+
+RDEPEND="dev-libs/lzo[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libpng:0=[${MULTILIB_USEDEP}]
+ sys-libs/zlib[${MULTILIB_USEDEP}]
+ >=x11-libs/pixman-0.28.0[${MULTILIB_USEDEP}]
+ directfb? ( dev-libs/DirectFB )
+ gles2? ( media-libs/mesa[gles2,${MULTILIB_USEDEP}] )
+ glib? ( >=dev-libs/glib-2.28.6:2[${MULTILIB_USEDEP}] )
+ opengl? ( || ( media-libs/mesa[egl,${MULTILIB_USEDEP}] media-libs/opengl-apple ) )
+ openvg? ( media-libs/mesa[openvg,${MULTILIB_USEDEP}] )
+ qt4? ( >=dev-qt/qtgui-4.8:4 )
+ X? (
+ >=x11-libs/libXrender-0.6[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ drm? (
+ >=virtual/udev-136[${MULTILIB_USEDEP}]
+ gallium? ( media-libs/mesa[gallium,${MULTILIB_USEDEP}] )
+ )
+ )
+ xcb? (
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ )
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtklibs-20131008-r1
+ !app-emulation/emul-linux-x86-gtklibs[-abi_x86_32(-)]
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-devel/libtool-2
+ X? (
+ x11-proto/renderproto[${MULTILIB_USEDEP}]
+ drm? (
+ x11-proto/xproto[${MULTILIB_USEDEP}]
+ >=x11-proto/xextproto-7.1[${MULTILIB_USEDEP}]
+ )
+ )"
+#[[ ${PV} == *9999* ]] && DEPEND="${DEPEND}
+# doc? (
+# >=dev-util/gtk-doc-1.6
+# ~app-text/docbook-xml-dtd-4.2
+# )"
+
+# drm module requires X
+# for gallium we need to enable drm
+REQUIRED_USE="
+ drm? ( X )
+ gallium? ( drm )
+ gles2? ( !opengl )
+ openvg? ( || ( gles2 opengl ) )
+ xlib-xcb? ( xcb )
+"
+
+MULTILIB_WRAPPED_HEADERS=(
+ /usr/include/cairo/cairo-features.h
+ /usr/include/cairo/cairo-directfb.h
+)
+
+CHECKREQS_MEMORY="768M"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use lto; then
+ einfo "Checking for sufficient memory to build $PN with USE=lto"
+ check-reqs_pkg_pretend
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use lto; then
+ check-reqs_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
+ use legacy-drivers && epatch "${FILESDIR}"/${PN}-1.10.0-buggy_gradients.patch
+ epatch "${FILESDIR}"/${PN}-respect-fontconfig.patch
+
+ # all-clipped handling from 1.13
+ epatch "${FILESDIR}"/${PN}-1.12.16-all-clipped-{1,2}.patch
+ # bug #507478, https://bugs.freedesktop.org/show_bug.cgi?id=77931
+ epatch "${FILESDIR}"/${PN}-1.12.16-all-clipped-3.patch
+
+ # allow the automagically injected -flto flag to be not injected
+ epatch "${FILESDIR}"/${PN}-1.12.16-lto-optional.patch
+
+ # tests and perf tools require X, bug #483574
+ if ! use X; then
+ sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
+ fi
+
+ epatch_user
+
+ # Slightly messed build system YAY
+ if [[ ${PV} == *9999* ]]; then
+ touch boilerplate/Makefile.am.features
+ touch src/Makefile.am.features
+ touch ChangeLog
+ fi
+
+ # We need to run elibtoolize to ensure correct so versioning on FreeBSD
+ # upgraded to an eautoreconf for the above interix patch.
+ eautoreconf
+}
+
+multilib_src_configure() {
+ local myopts
+
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_REENTRANT
+
+ use elibc_FreeBSD && myopts+=" --disable-symbol-lookup"
+
+ # TODO: remove this (and add USE-dep) when DirectFB is converted,
+ # bug #484248 -- but beware of the circular dep.
+ if ! multilib_is_native_abi; then
+ myopts+=" --disable-directfb"
+ fi
+
+ # TODO: remove this (and add USE-dep) when qtgui is converted, bug #498010
+ if ! multilib_is_native_abi; then
+ myopts+=" --disable-qt"
+ fi
+
+ # [[ ${PV} == *9999* ]] && myopts+=" $(use_enable doc gtk-doc)"
+
+ ECONF_SOURCE="${S}" \
+ econf \
+ --disable-dependency-tracking \
+ $(use_with X x) \
+ $(use_enable X tee) \
+ $(use_enable X xlib) \
+ $(use_enable X xlib-xrender) \
+ $(use_enable aqua quartz) \
+ $(use_enable aqua quartz-image) \
+ $(use_enable debug test-surfaces) \
+ $(use_enable drm) \
+ $(use_enable directfb) \
+ $(use_enable gallium) \
+ $(use_enable gles2 glesv2) \
+ $(use_enable glib gobject) \
+ $(use_enable lto) \
+ $(use_enable openvg vg) \
+ $(use_enable opengl gl) \
+ $(use_enable qt4 qt) \
+ $(use_enable static-libs static) \
+ $(use_enable svg) \
+ $(use_enable valgrind) \
+ $(use_enable xcb) \
+ $(use_enable xcb xcb-shm) \
+ $(use_enable xlib-xcb) \
+ --enable-ft \
+ --enable-pdf \
+ --enable-png \
+ --enable-ps \
+ ${myopts}
+}
+
+multilib_src_install() {
+ # parallel make install fails
+ emake -j1 DESTDIR="${D}" install
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --all
+ einstalldocs
+}
+
+pkg_postinst() {
+ if use !xlib-xcb; then
+ if has_version net-misc/nxserver-freenx \
+ || has_version net-misc/x2goserver; then
+ ewarn "cairo-1.12 is known to cause GTK+ errors with NX servers."
+ ewarn "Enable USE=\"xlib-xcb\" if you notice incorrect behavior in GTK+"
+ ewarn "applications that are running inside NX sessions. For details, see"
+ ewarn "https://bugs.gentoo.org/441878 or https://bugs.freedesktop.org/59173"
+ fi
+ fi
+}
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index d5531b58f83b..e5017b4c06ab 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-9999.ebuild,v 1.41 2014/05/02 09:51:49 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-9999.ebuild,v 1.42 2014/05/02 21:51:12 tetromino Exp $
EAPI=5
-inherit eutils flag-o-matic autotools multilib-minimal
+inherit check-reqs eutils flag-o-matic autotools multilib-minimal
if [[ ${PV} == *9999* ]]; then
inherit git-2
@@ -20,7 +20,7 @@ DESCRIPTION="A vector graphics library with cross-device output support"
HOMEPAGE="http://cairographics.org/"
LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
SLOT="0"
-IUSE="X aqua debug directfb drm gallium gles2 +glib legacy-drivers opengl openvg qt4 static-libs +svg valgrind xcb xlib-xcb"
+IUSE="X aqua debug directfb drm gallium gles2 +glib legacy-drivers +lto opengl openvg qt4 static-libs +svg valgrind xcb xlib-xcb"
# gtk-doc regeneration doesn't seem to work with out-of-source builds
#[[ ${PV} == *9999* ]] && IUSE="${IUSE} doc" # API docs are provided in tarball, no need to regenerate
@@ -86,10 +86,37 @@ MULTILIB_WRAPPED_HEADERS=(
/usr/include/cairo/cairo-directfb.h
)
+CHECKREQS_MEMORY="768M"
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use lto; then
+ einfo "Checking for sufficient memory to build $PN with USE=lto"
+ check-reqs_pkg_pretend
+ fi
+}
+
+pkg_setup() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use lto; then
+ check-reqs_pkg_setup
+ fi
+}
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
use legacy-drivers && epatch "${FILESDIR}"/${PN}-1.10.0-buggy_gradients.patch
epatch "${FILESDIR}"/${PN}-respect-fontconfig.patch
+
+ # bug #507478, https://bugs.freedesktop.org/show_bug.cgi?id=77931
+ epatch "${FILESDIR}"/${PN}-1.12.16-all-clipped-3.patch
+
+ # allow the automagically injected -flto flag to be not injected
+ epatch "${FILESDIR}"/${PN}-1.12.16-lto-optional.patch
+
+ # tests and perf tools require X, bug #483574
+ if ! use X; then
+ sed -e '/^SUBDIRS/ s#boilerplate test perf# #' -i Makefile.am || die
+ fi
+
epatch_user
# Slightly messed build system YAY
@@ -139,6 +166,7 @@ multilib_src_configure() {
$(use_enable gallium) \
$(use_enable gles2 glesv2) \
$(use_enable glib gobject) \
+ $(use_enable lto) \
$(use_enable openvg vg) \
$(use_enable opengl gl) \
$(use_enable qt4 qt) \
diff --git a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-1.patch b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-1.patch
new file mode 100644
index 000000000000..cef9e2928154
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-1.patch
@@ -0,0 +1,38 @@
+From 3b261bea7d8e8094ff3899aefab6bbc8628a3585 Mon Sep 17 00:00:00 2001
+From: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Thu, 06 Mar 2014 08:34:10 +0000
+Subject: clip: Do not modify the special all-clipped cairo_clip_t
+
+Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
+Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=75819
+---
+diff --git a/src/cairo-clip-boxes.c b/src/cairo-clip-boxes.c
+index bbb4197..352654f 100644
+--- a/src/cairo-clip-boxes.c
++++ b/src/cairo-clip-boxes.c
+@@ -173,7 +173,7 @@ _cairo_clip_intersect_rectangle_box (cairo_clip_t *clip,
+ clip->extents = *r;
+ } else {
+ if (! _cairo_rectangle_intersect (&clip->extents, r))
+- clip = _cairo_clip_set_all_clipped (clip);
++ return _cairo_clip_set_all_clipped (clip);
+ }
+ if (clip->path == NULL)
+ clip->is_region = _cairo_box_is_pixel_aligned (box);
+@@ -312,10 +312,12 @@ _cairo_clip_intersect_boxes (cairo_clip_t *clip,
+ _cairo_boxes_extents (boxes, &limits);
+
+ _cairo_box_round_to_rectangle (&limits, &extents);
+- if (clip->path == NULL)
++ if (clip->path == NULL) {
+ clip->extents = extents;
+- else if (! _cairo_rectangle_intersect (&clip->extents, &extents))
++ } else if (! _cairo_rectangle_intersect (&clip->extents, &extents)) {
+ clip = _cairo_clip_set_all_clipped (clip);
++ goto out;
++ }
+
+ if (clip->region) {
+ cairo_region_destroy (clip->region);
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-2.patch b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-2.patch
new file mode 100644
index 000000000000..df537da1ab70
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-2.patch
@@ -0,0 +1,28 @@
+From ed175b2a2bebb6def85133257bc11a875d13b0dd Mon Sep 17 00:00:00 2001
+From: Uli Schlachter <psychon@znc.in>
+Date: Thu, 06 Mar 2014 08:45:08 +0000
+Subject: clip: Fix handling of special all-clipped cairo_clip_t
+
+_cairo_clip_intersect_box() wasn't checking if it was called with the special,
+read-only all-clipped clip and thus could have ended up writing to read-only
+memory.
+
+References: https://bugs.freedesktop.org/show_bug.cgi?id=75819
+Signed-off-by: Uli Schlachter <psychon@znc.in>
+---
+diff --git a/src/cairo-clip-boxes.c b/src/cairo-clip-boxes.c
+index 352654f..7bcbeb1 100644
+--- a/src/cairo-clip-boxes.c
++++ b/src/cairo-clip-boxes.c
+@@ -258,6 +258,9 @@ _cairo_clip_intersect_box (cairo_clip_t *clip,
+ {
+ cairo_rectangle_int_t r;
+
++ if (_cairo_clip_is_all_clipped (clip))
++ return clip;
++
+ _cairo_box_round_to_rectangle (box, &r);
+ if (r.width == 0 || r.height == 0)
+ return _cairo_clip_set_all_clipped (clip);
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-libs/cairo/files/cairo-1.12.16-all-clipped-3.patch b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-3.patch
new file mode 100644
index 000000000000..98cd4d503d67
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.12.16-all-clipped-3.patch
@@ -0,0 +1,28 @@
+From 180fead4390089e56c28dba0fcfaa99d127722c1 Mon Sep 17 00:00:00 2001
+From: Chris Wilson <chris@chris-wilson.co.uk>
+Date: Thu May 1 23:39:01 PDT 2014
+Subject: [PATCH] segfault in cairo-xcb-surface-render.c
+
+http://lists.cairographics.org/archives/cairo/2014-May/025197.html
+https://bugs.freedesktop.org/show_bug.cgi?id=77931
+---
+ src/cairo-xcb-surface-render.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/cairo-xcb-surface-render.c b/src/cairo-xcb-surface-render.c
+index 9625953..54307d5 100644
+--- a/src/cairo-xcb-surface-render.c
++++ b/src/cairo-xcb-surface-render.c
+@@ -3121,6 +3121,9 @@ _clip_and_composite_boxes (cairo_xcb_surface_t *dst,
+
+ clip = _cairo_clip_copy (extents->clip);
+ clip = _cairo_clip_intersect_boxes (clip, boxes);
++ if (_cairo_clip_is_all_clipped (clip))
++ return CAIRO_INT_STATUS_NOTHING_TO_DO;
++
+ status = _cairo_clip_get_polygon (clip, &polygon,
+ &fill_rule, &antialias);
+ _cairo_clip_path_destroy (clip->path);
+--
+1.9.2
+
diff --git a/x11-libs/cairo/files/cairo-1.12.16-lto-optional.patch b/x11-libs/cairo/files/cairo-1.12.16-lto-optional.patch
new file mode 100644
index 000000000000..641cceaae99c
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.12.16-lto-optional.patch
@@ -0,0 +1,28 @@
+diff --git a/build/configure.ac.warnings b/build/configure.ac.warnings
+index f984eb2..15b3da2 100644
+--- a/build/configure.ac.warnings
++++ b/build/configure.ac.warnings
+@@ -38,13 +38,18 @@ dnl options. Namely, the following:
+
+ dnl -flto working really needs a test link, not just a compile
+
+-safe_MAYBE_WARN="$MAYBE_WARN"
+-MAYBE_WARN="$MAYBE_WARN -flto"
+-AC_TRY_LINK([],[
++AC_ARG_ENABLE(lto,
++ AS_HELP_STRING([--disable-lto],
++ [Do not try to use Link-Time Optimization]))
++if test "x$enable_lto" != "xno"; then
++ safe_MAYBE_WARN="$MAYBE_WARN"
++ MAYBE_WARN="$MAYBE_WARN -flto"
++ AC_TRY_LINK([],[
+ int main(int argc, char **argv) { return 0; }
+-],[],[
++ ],[],[
+ MAYBE_WARN="$safe_MAYBE_WARN"
+-])
++ ])
++fi
+
+ MAYBE_WARN="$MAYBE_WARN -fno-strict-aliasing -fno-common"
+
diff --git a/x11-libs/cairo/metadata.xml b/x11-libs/cairo/metadata.xml
index b41c8e361040..c5ad21464814 100644
--- a/x11-libs/cairo/metadata.xml
+++ b/x11-libs/cairo/metadata.xml
@@ -19,6 +19,9 @@
<flag name="gles2">Use OpenGL ES 2 backend for acceleration.</flag>
<flag name="glib">Compile with GLib Object System support</flag>
<flag name="legacy-drivers">Include the buggy gradients patch (for legacy drivers, such as nvidia-drivers older than 304.30)</flag>
+ <flag name="lto">Try to build with Link-Time Optimization if supported by
+ the compiler. This is recommended by upstream, but can cause build
+ failure in some environments and on machines with little memory.</flag>
<flag name="openvg">Use OpenVG for backend acceleration</flag>
<flag name="valgrind">Built-in support to mark memory regions</flag>
<flag name="xlib-xcb">Use XCB renderer backend for acceleration over xlib</flag>