summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-09-09 20:16:59 +0000
committerPacho Ramos <pacho@gentoo.org>2011-09-09 20:16:59 +0000
commita0ffb98c57d05308b44d73a4432ac282a9b5a79e (patch)
tree4deed11b18f292c33bf3e8b1abe022449dc8a28d /x11-libs
parentVersion bump, remove old. (diff)
downloadgentoo-2-a0ffb98c57d05308b44d73a4432ac282a9b5a79e.tar.gz
gentoo-2-a0ffb98c57d05308b44d73a4432ac282a9b5a79e.tar.bz2
gentoo-2-a0ffb98c57d05308b44d73a4432ac282a9b5a79e.zip
Version bump, remove old.
(Portage version: 2.1.10.14/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/ChangeLog8
-rw-r--r--x11-libs/gtk+/gtk+-2.24.6.ebuild233
-rw-r--r--x11-libs/gtk+/gtk+-3.0.11.ebuild194
3 files changed, 240 insertions, 195 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index eb5ef8d6b3bd..9e427a12f2ec 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gtk+
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.530 2011/09/04 09:10:11 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.531 2011/09/09 20:16:59 pacho Exp $
+
+*gtk+-2.24.6 (09 Sep 2011)
+
+ 09 Sep 2011; Pacho Ramos <pacho@gentoo.org> +gtk+-2.24.6.ebuild,
+ -gtk+-3.0.11.ebuild:
+ Version bump, remove old.
04 Sep 2011; Fabian Groffen <grobian@gentoo.org> gtk+-3.0.12.ebuild:
Fix compilation on Solaris
diff --git a/x11-libs/gtk+/gtk+-2.24.6.ebuild b/x11-libs/gtk+/gtk+-2.24.6.ebuild
new file mode 100644
index 000000000000..6b1570454d85
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.24.6.ebuild
@@ -0,0 +1,233 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.24.6.ebuild,v 1.1 2011/09/09 20:16:59 pacho Exp $
+
+EAPI="3"
+GNOME_TARBALL_SUFFIX="xz"
+PYTHON_DEPEND="2:2.4"
+
+inherit eutils flag-o-matic gnome.org libtool python virtualx autotools
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="${SRC_URI} mirror://gentoo/introspection.m4.bz2"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="aqua cups debug doc examples +introspection test vim-syntax xinerama"
+
+# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
+RDEPEND="!aqua? (
+ x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.3
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ >=x11-libs/cairo-1.6[X,svg]
+ x11-libs/gdk-pixbuf:2[X,introspection?]
+ )
+ aqua? (
+ >=x11-libs/cairo-1.6[aqua,svg]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ )
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.27.3:2
+ >=x11-libs/pango-1.20[introspection?]
+ >=dev-libs/atk-1.29.2[introspection?]
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ cups? ( net-print/cups )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3 )
+ !<gnome-base/gail-1000"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ !aqua? (
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ )
+ xinerama? ( x11-proto/xineramaproto )
+ >=dev-util/gtk-doc-am-1.11
+ doc? (
+ >=dev-util/gtk-doc-1.11
+ ~app-text/docbook-xml-dtd-4.1.2 )
+ test? (
+ media-fonts/font-misc-misc
+ media-fonts/font-cursor-misc )"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+strip_builddir() {
+ local rule=$1
+ shift
+ local directory=$1
+ shift
+ sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
+ || die "Could not strip director ${directory} from build."
+}
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+}
+
+src_prepare() {
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ epatch "${FILESDIR}/${PN}-2.21.3-multilib.patch"
+
+ # Don't break inclusion of gtkclist.h, upstream bug 536767
+ epatch "${FILESDIR}/${PN}-2.14.3-limit-gtksignal-includes.patch"
+
+ # Create symlinks to old icons until apps are ported, bug #339319
+ epatch "${FILESDIR}/${PN}-2.24.4-old-icons.patch"
+
+ # fix building with gir #372953
+ epatch "${FILESDIR}"/${PN}-2.24.5-darwin-quartz-introspection.patch
+
+ # Stop trying to build unmaintained docs, bug #349754
+ strip_builddir SUBDIRS tutorial docs/Makefile.am docs/Makefile.in
+ strip_builddir SUBDIRS faq docs/Makefile.am docs/Makefile.in
+
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ use ppc64 && append-flags -mminimal-toc
+
+ # Non-working test in gentoo's env
+ sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
+ -i gtk/tests/testing.c || die "sed 1 failed"
+
+ # Cannot work because glib is too clever to find real user's home
+ # gentoo bug #285687, upstream bug #639832
+ # XXX: /!\ Pay extra attention to second sed when bumping /!\
+ sed '/TEST_PROGS.*recentmanager/d' -i gtk/tests/Makefile.am \
+ || die "failed to disable recentmanager test (1)"
+ sed '/^TEST_PROGS =/,+3 s/recentmanager//' -i gtk/tests/Makefile.in \
+ || die "failed to disable recentmanager test (2)"
+ sed 's:\({ "GtkFileChooserButton".*},\):/*\1*/:g' -i gtk/tests/object.c \
+ || die "failed to disable recentmanager test (3)"
+
+ if ! use test; then
+ # don't waste time building tests
+ strip_builddir SRC_SUBDIRS tests Makefile.am Makefile.in
+ else
+ # Skip tests known to fail
+ # https://bugzilla.gnome.org/show_bug.cgi?id=646609
+ sed -e '/g_test_add_func.*test_text_access/s:^://:' \
+ -i "${S}/gtk/tests/testing.c" || die
+ fi
+
+ if ! use examples; then
+ # don't waste time building demos
+ strip_builddir SRC_SUBDIRS demos Makefile.am Makefile.in
+ fi
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=371907
+ mkdir -p "${S}/m4" || die
+ mv "${WORKDIR}/introspection.m4" "${S}/m4macros" || die
+ AT_M4DIR=m4macros eautoreconf
+ # Use elibtoolize in place of eautoreconf when it will be dropped
+ #elibtoolize
+}
+
+src_configure() {
+ local myconf="$(use_enable doc gtk-doc)
+ $(use_enable xinerama)
+ $(use_enable cups cups auto)
+ $(use_enable introspection)
+ --disable-papi"
+ if use aqua; then
+ myconf="${myconf} --with-gdktarget=quartz"
+ else
+ myconf="${myconf} --with-gdktarget=x11 --with-xinput"
+ fi
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf}
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+ # Exporting HOME fixes tests using XDG directories spec since all defaults
+ # are based on $HOME. It is also backward compatible with functions not
+ # yet ported to this spec.
+ XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR} || die "dodir failed"
+ keepdir ${GTK2_CONFDIR}
+
+ # see bug #133241
+ echo 'gtk-fallback-icon-theme = "gnome"' > "${T}/gtkrc"
+ insinto /etc/gtk-2.0
+ doins "${T}"/gtkrc || die "doins gtkrc failed"
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ echo "GDK_USE_XFT=1" > "${T}"/50gtk2
+ doenvd "${T}"/50gtk2 || die "doenvd failed"
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README* || die "dodoc failed"
+
+ # add -framework Carbon to the .pc files
+ use aqua && for i in gtk+-2.0.pc gtk+-quartz-2.0.pc gtk+-unix-print-2.0.pc; do
+ sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED%/}"/usr/lib/pkgconfig/$i || die "sed failed"
+ done
+
+ python_convert_shebangs 2 "${ED}"usr/bin/gtk-builder-convert
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ # gtk.immodules should be in their CHOST directories respectively.
+ gtk-query-immodules-2.0 > "${EROOT%/}${GTK2_CONFDIR}/gtk.immodules" \
+ || ewarn "Failed to run gtk-query-immodules-2.0"
+
+ if [ -e "${EROOT%/}/etc/gtk-2.0/gtk.immodules" ]; then
+ elog "File /etc/gtk-2.0/gtk.immodules has been moved to \$CHOST"
+ elog "aware location. Removing deprecated file."
+ rm -f ${EROOT%/}/etc/gtk-2.0/gtk.immodules
+ fi
+
+ # pixbufs are now handled by x11-libs/gdk-pixbuf
+ if [ -e "${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders" ]; then
+ elog "File ${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders is now handled by x11-libs/gdk-pixbuf"
+ elog "Removing deprecated file."
+ rm -f ${EROOT%/}${GTK2_CONFDIR}/gdk-pixbuf.loaders
+ fi
+
+ # two checks needed since we dropped multilib conditional
+ if [ -e "${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders" ]; then
+ elog "File ${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders is now handled by x11-libs/gdk-pixbuf"
+ elog "Removing deprecated file."
+ rm -f ${EROOT%/}/etc/gtk-2.0/gdk-pixbuf.loaders
+ fi
+
+ if [ -e "${EROOT%/}"/usr/lib/gtk-2.0/2.[^1]* ]; then
+ elog "You need to rebuild ebuilds that installed into" "${EROOT%/}"/usr/lib/gtk-2.0/2.[^1]*
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC ${EPREFIX}/usr/lib/gtk-2.0/2.[^1]*)"
+ fi
+
+ if ! has_version "app-text/evince"; then
+ elog "Please install app-text/evince for print preview functionality."
+ elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
+ elog "add it to your gtkrc."
+ fi
+}
diff --git a/x11-libs/gtk+/gtk+-3.0.11.ebuild b/x11-libs/gtk+/gtk+-3.0.11.ebuild
deleted file mode 100644
index 73a8b4c0f856..000000000000
--- a/x11-libs/gtk+/gtk+-3.0.11.ebuild
+++ /dev/null
@@ -1,194 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-3.0.11.ebuild,v 1.4 2011/07/11 15:43:06 mattst88 Exp $
-
-EAPI="3"
-GNOME_TARBALL_SUFFIX="xz"
-
-inherit eutils flag-o-matic gnome.org gnome2-utils libtool virtualx
-
-DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="3"
-# NOTE: This gtk+ has multi-gdk-backend support, see:
-# * http://blogs.gnome.org/kris/2010/12/29/gdk-3-0-on-mac-os-x/
-# * http://mail.gnome.org/archives/gtk-devel-list/2010-November/msg00099.html
-# I tried this and got it all compiling, but the end result is unusable as it
-# horribly mixes up the backends -- grobian
-IUSE="aqua cups debug doc examples +introspection test vim-syntax xinerama"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-
-# FIXME: introspection data is built against system installation of gtk+:3
-# NOTE: cairo[svg] dep is due to bug 291283 (not patched to avoid eautoreconf)
-# Use gtk+:2 for gtk-update-icon-cache and gtk-builder-convert
-# >=x11-libs/gtk+-2.24:2 is needed for bug 359555
-COMMON_DEPEND="!aqua? (
- x11-libs/libXrender
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXt
- x11-libs/libXext
- >=x11-libs/libXrandr-1.3
- x11-libs/libXcursor
- x11-libs/libXfixes
- x11-libs/libXcomposite
- x11-libs/libXdamage
- >=x11-libs/cairo-1.10.0[X,glib,svg]
- >=x11-libs/gdk-pixbuf-2.22.0:2[X,introspection?]
- )
- aqua? (
- >=x11-libs/cairo-1.10.0[aqua,glib,svg]
- >=x11-libs/gdk-pixbuf-2.22.0:2[introspection?]
- )
- xinerama? ( x11-libs/libXinerama )
- >=dev-libs/glib-2.28.0
- >=x11-libs/pango-1.24.0[introspection?]
- >=dev-libs/atk-1.30[introspection?]
- >=x11-libs/gtk+-2.24:2
- media-libs/fontconfig
- x11-misc/shared-mime-info
- cups? ( net-print/cups )
- introspection? ( >=dev-libs/gobject-introspection-0.10.1 )"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/pkgconfig-0.9
- !aqua? (
- x11-proto/xextproto
- x11-proto/xproto
- x11-proto/inputproto
- x11-proto/damageproto
- )
- x86-interix? (
- sys-libs/itx-bind
- )
- xinerama? ( x11-proto/xineramaproto )
- >=dev-util/gtk-doc-am-1.11
- doc? (
- >=dev-util/gtk-doc-1.11
- ~app-text/docbook-xml-dtd-4.1.2 )
- test? (
- media-fonts/font-misc-misc
- media-fonts/font-cursor-misc )"
-RDEPEND="${COMMON_DEPEND}
- !<gnome-base/gail-1000"
-PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
-
-strip_builddir() {
- local rule=$1
- shift
- local directory=$1
- shift
- sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
- || die "Could not strip director ${directory} from build."
-}
-
-src_prepare() {
- # -O3 and company cause random crashes in applications. Bug #133469
- replace-flags -O3 -O2
- strip-flags
-
- # Non-working test in gentoo's env
- sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
- -i gtk/tests/testing.c || die "sed 1 failed"
- sed '\%/recent-manager/add%,/recent_manager_purge/ d' \
- -i gtk/tests/recentmanager.c || die "sed 2 failed"
-
- if use x86-interix; then
- # activate the itx-bind package...
- append-flags "-I${EPREFIX}/usr/include/bind"
- append-ldflags "-L${EPREFIX}/usr/lib/bind"
- fi
-
- if ! use test; then
- # don't waste time building tests
- strip_builddir SRC_SUBDIRS tests Makefile.am
- strip_builddir SRC_SUBDIRS tests Makefile.in
- fi
-
- if ! use examples; then
- # don't waste time building demos
- strip_builddir SRC_SUBDIRS demos Makefile.am
- strip_builddir SRC_SUBDIRS demos Makefile.in
- fi
-
- # http://mail.gnome.org/archives/commits-list/2011-March/msg04372.html
- epatch "${FILESDIR}"/${PN}-3.0.8-darwin-quartz.patch
- # fix building with gir #372953
- epatch "${FILESDIR}"/${PN}-3.0.11-darwin-quartz-introspection.patch
-}
-
-src_configure() {
- # FIXME: PackageKit support
- # png always on to display icons (foser)
- local myconf="$(use_enable doc gtk-doc)
- $(use_enable xinerama)
- $(use_enable cups cups auto)
- $(use_enable introspection)
- --disable-packagekit
- --disable-papi
- --enable-gtk2-dependency"
-
- # XXX: Maybe with multi-backend we should enable x11 all the time?
- if use aqua; then
- myconf="${myconf} --enable-quartz-backend --disable-xinput"
- else
- myconf="${myconf} --enable-x11-backend --enable-xinput"
- fi
-
- # Passing --disable-debug is not recommended for production use
- use debug && myconf="${myconf} --enable-debug=yes"
-
- # need libdir here to avoid a double slash in a path that libtool doesn't
- # grok so well during install (// between $EPREFIX and usr ...)
- econf --libdir="${EPREFIX}/usr/$(get_libdir)" ${myconf}
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- # Exporting HOME fixes tests using XDG directories spec since all defaults
- # are based on $HOME. It is also backward compatible with functions not
- # yet ported to this spec.
- XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
-
- # see bug #133241
- echo 'gtk-fallback-icon-theme = "gnome"' > "${T}/gtkrc"
- insinto /etc/gtk-3.0
- doins "${T}"/gtkrc || die "doins gtkrc failed"
-
- dodoc AUTHORS ChangeLog* HACKING NEWS* README* || die "dodoc failed"
-
- # Remove unneeded *.la files
- find "${ED}" -name "*.la" -delete
-
- # add -framework Carbon to the .pc files
- use aqua && for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
- sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED}"usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
- done
-}
-
-pkg_preinst() {
- gnome2_schemas_savelist
-}
-
-pkg_postinst() {
- gnome2_schemas_update
-
- local GTK3_MODDIR="${EROOT}usr/$(get_libdir)/gtk-3.0/3.0.0"
- gtk-query-immodules-3.0 > "${GTK3_MODDIR}/immodules.cache" \
- || ewarn "Failed to run gtk-query-immodules-3.0"
-
- if ! has_version "app-text/evince"; then
- elog "Please install app-text/evince for print preview functionality."
- elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
- elog "add it to your gtkrc."
- fi
-}
-
-pkg_postrm() {
- gnome2_schemas_update --uninstall
-}