summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-03-26 21:02:52 +0000
committerPacho Ramos <pacho@gentoo.org>2011-03-26 21:02:52 +0000
commita1e6abc80064259180a41df18d7e6b0b6dd1eb63 (patch)
tree0f2fdedc867b9023cc1bbb810eab63a16f11fc36 /x11-libs
parentStable on alpha, bug #337160 (diff)
downloadgentoo-2-a1e6abc80064259180a41df18d7e6b0b6dd1eb63.tar.gz
gentoo-2-a1e6abc80064259180a41df18d7e6b0b6dd1eb63.tar.bz2
gentoo-2-a1e6abc80064259180a41df18d7e6b0b6dd1eb63.zip
Version bump with bugfixes and including a gsettings backend. As it's still considered experimental, this version still uses gconf as previous version. Remove old.
(Portage version: 2.1.9.44/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/goffice/ChangeLog10
-rw-r--r--x11-libs/goffice/goffice-0.8.14.ebuild (renamed from x11-libs/goffice/goffice-0.8.12.ebuild)18
-rw-r--r--x11-libs/goffice/goffice-0.8.6.ebuild56
3 files changed, 22 insertions, 62 deletions
diff --git a/x11-libs/goffice/ChangeLog b/x11-libs/goffice/ChangeLog
index d8d2f6064223..d091cd3216f3 100644
--- a/x11-libs/goffice/ChangeLog
+++ b/x11-libs/goffice/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-libs/goffice
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.90 2011/03/22 19:57:47 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/ChangeLog,v 1.91 2011/03/26 21:02:52 pacho Exp $
+
+*goffice-0.8.14 (26 Mar 2011)
+
+ 26 Mar 2011; Pacho Ramos <pacho@gentoo.org> -goffice-0.8.6.ebuild,
+ -goffice-0.8.12.ebuild, +goffice-0.8.14.ebuild:
+ Version bump with bugfixes and including a gsettings backend. As it's still
+ considered experimental, this version still uses gconf as previous version.
+ Remove old.
22 Mar 2011; Brent Baude <ranger@gentoo.org> goffice-0.8.13.ebuild:
Marking goffice-0.8.13 ppc stable for bug 353436
diff --git a/x11-libs/goffice/goffice-0.8.12.ebuild b/x11-libs/goffice/goffice-0.8.14.ebuild
index 2d381b2c35e2..50c50a97221b 100644
--- a/x11-libs/goffice/goffice-0.8.12.ebuild
+++ b/x11-libs/goffice/goffice-0.8.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.8.12.ebuild,v 1.3 2011/01/13 19:59:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.8.14.ebuild,v 1.1 2011/03/26 21:02:52 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -19,13 +19,13 @@ IUSE="doc gnome"
# FIXME: add lasem to tree
RDEPEND=">=dev-libs/glib-2.16:2
>=gnome-extra/libgsf-1.14.9
- >=dev-libs/libxml2-2.4.12
+ >=dev-libs/libxml2-2.4.12:2
>=x11-libs/pango-1.8.1
>=x11-libs/cairo-1.2[svg]
x11-libs/libXext
x11-libs/libXrender
>=x11-libs/gtk+-2.16:2
- gnome? ( >=gnome-base/gconf-2 )
+ gnome? ( >=gnome-base/gconf-2:2 )
"
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.18
@@ -34,10 +34,18 @@ DEPEND="${RDEPEND}
pkg_setup() {
DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+ # Gsettings is still experimental
+ if use gnome; then
+ G2CONF="${G2CONF} --with-config-backend=gconf"
+ else
+ G2CONF="${G2CONF} --with-config-backend=keyfile"
+ fi
+
G2CONF="${G2CONF}
--without-lasem
- --with-gtk
- $(use_with gnome gconf)"
+ --with-gtk"
+
filter-flags -ffast-math
}
diff --git a/x11-libs/goffice/goffice-0.8.6.ebuild b/x11-libs/goffice/goffice-0.8.6.ebuild
deleted file mode 100644
index 315a6b1008fe..000000000000
--- a/x11-libs/goffice/goffice-0.8.6.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.8.6.ebuild,v 1.8 2011/03/16 09:10:51 nirbheek Exp $
-
-EAPI="2"
-GCONF_DEBUG="no"
-
-inherit eutils gnome2 flag-o-matic
-
-DESCRIPTION="A library of document-centric objects and utilities"
-HOMEPAGE="http://freshmeat.net/projects/goffice/"
-
-LICENSE="GPL-2"
-SLOT="0.8"
-KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
-IUSE="doc gnome"
-
-# Build fails with -gtk
-# FIXME: add lasem to tree
-RDEPEND=">=dev-libs/glib-2.16:2
- >=gnome-extra/libgsf-1.14.9[gnome?]
- >=dev-libs/libxml2-2.4.12:2
- >=x11-libs/pango-1.8.1
- >=x11-libs/cairo-1.2[svg]
- x11-libs/libXext
- x11-libs/libXrender
- >=x11-libs/gtk+-2.16:2
- gnome? ( >=gnome-base/gconf-2:2 )
-"
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.18
- >=dev-util/intltool-0.35
- doc? ( >=dev-util/gtk-doc-1.11 )"
-
-DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --without-lasem
- --with-gtk
- $(use_with gnome gconf)"
- filter-flags -ffast-math
-}
-
-src_prepare() {
- gnome2_src_prepare
-
- # Fix intltoolize broken file, see upstream #577133
- sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
- || die "sed failed"
-}
-
-src_install() {
- gnome2_src_install
- find "${D}" -name "*.la" -delete || die
-}