summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2014-10-26 14:45:09 +0000
committerRémi Cardona <remi@gentoo.org>2014-10-26 14:45:09 +0000
commitbffa0ea5b8977df5e395e796c94a497a14aa1464 (patch)
treedb751cb72965d023a4ee2a14804f91e6b8e771bb /x11-libs
parentsci-mathematics/dataplot: Drop bashisms from configure.ac, #526888 (diff)
downloadgentoo-2-bffa0ea5b8977df5e395e796c94a497a14aa1464.tar.gz
gentoo-2-bffa0ea5b8977df5e395e796c94a497a14aa1464.tar.bz2
gentoo-2-bffa0ea5b8977df5e395e796c94a497a14aa1464.zip
x11-libs/libxkbcommon: bump to 0.5.0
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 901AB08A)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libxkbcommon/ChangeLog7
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.5.0.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-libs/libxkbcommon/ChangeLog b/x11-libs/libxkbcommon/ChangeLog
index 23a111e8420c..54eace65ee53 100644
--- a/x11-libs/libxkbcommon/ChangeLog
+++ b/x11-libs/libxkbcommon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libxkbcommon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxkbcommon/ChangeLog,v 1.9 2014/06/18 21:07:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxkbcommon/ChangeLog,v 1.10 2014/10/26 14:45:09 remi Exp $
+
+*libxkbcommon-0.5.0 (26 Oct 2014)
+
+ 26 Oct 2014; Rémi Cardona <remi@gentoo.org> +libxkbcommon-0.5.0.ebuild:
+ Bump to 0.5.0, add test USE flag (see bug #526914)
18 Jun 2014; Michał Górny <mgorny@gentoo.org> libxkbcommon-0.4.1.ebuild:
Update dependencies to require guaranteed EAPI=5 or multilib ebuilds, bug
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.5.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.5.0.ebuild
new file mode 100644
index 000000000000..48ad604ea611
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libxkbcommon/libxkbcommon-0.5.0.ebuild,v 1.1 2014/10/26 14:45:09 remi Exp $
+
+EAPI=5
+XORG_EAUTORECONF="yes"
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="git://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="http://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ sys-devel/flex
+ X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.6-r1[${MULTILIB_USEDEP}]
+ doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}