summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2006-09-07 04:15:07 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2006-09-07 04:15:07 +0000
commitf3ae11f09ae8c8f1b8d48d30108bc7ac9a0b6d5c (patch)
tree0233f605d97d886c211eaf9860a894d333356501 /x11-libs
parentgnome 2.16 (diff)
downloadgentoo-2-f3ae11f09ae8c8f1b8d48d30108bc7ac9a0b6d5c.tar.gz
gentoo-2-f3ae11f09ae8c8f1b8d48d30108bc7ac9a0b6d5c.tar.bz2
gentoo-2-f3ae11f09ae8c8f1b8d48d30108bc7ac9a0b6d5c.zip
gnome 2.16
(Portage version: 2.1.1_rc1-r2)
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/vte/ChangeLog8
-rw-r--r--x11-libs/vte/files/digest-vte-0.14.03
-rw-r--r--x11-libs/vte/files/vte-0.13.2-no-lazy-bindings.patch11
-rw-r--r--x11-libs/vte/vte-0.14.0.ebuild52
4 files changed, 73 insertions, 1 deletions
diff --git a/x11-libs/vte/ChangeLog b/x11-libs/vte/ChangeLog
index b1503a654a60..1f76c23b9ee3 100644
--- a/x11-libs/vte/ChangeLog
+++ b/x11-libs/vte/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/vte
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.128 2006/08/16 18:15:53 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/ChangeLog,v 1.129 2006/09/07 04:15:07 dang Exp $
+
+*vte-0.14.0 (07 Sep 2006)
+
+ 07 Sep 2006; Daniel Gryniewicz <dang@gentoo.org>
+ +files/vte-0.13.2-no-lazy-bindings.patch, +vte-0.14.0.ebuild:
+ New version for gnome 2.16
16 Aug 2006; Markus Rothe <corsair@gentoo.org> vte-0.12.2.ebuild:
Stable on ppc64
diff --git a/x11-libs/vte/files/digest-vte-0.14.0 b/x11-libs/vte/files/digest-vte-0.14.0
new file mode 100644
index 000000000000..beeaeb1dbbe9
--- /dev/null
+++ b/x11-libs/vte/files/digest-vte-0.14.0
@@ -0,0 +1,3 @@
+MD5 42c6929f2072f1373cf37942896bb332 vte-0.14.0.tar.bz2 1010026
+RMD160 6193b01fcd1193a3ff64fea45c8294ca95747926 vte-0.14.0.tar.bz2 1010026
+SHA256 b807803603b3b0c8b57ffba4bd6c6bc4060ffcc3393571829427c1442c6bccf9 vte-0.14.0.tar.bz2 1010026
diff --git a/x11-libs/vte/files/vte-0.13.2-no-lazy-bindings.patch b/x11-libs/vte/files/vte-0.13.2-no-lazy-bindings.patch
new file mode 100644
index 000000000000..3eaa3bb2dc6e
--- /dev/null
+++ b/x11-libs/vte/files/vte-0.13.2-no-lazy-bindings.patch
@@ -0,0 +1,11 @@
+--- gnome-pty-helper/Makefile.am 2006-06-13 21:36:27.000000000 -0500
++++ gnome-pty-helper/Makefile.am 2006-06-13 21:37:08.000000000 -0500
+@@ -1,7 +1,7 @@
+ libexec_PROGRAMS = gnome-pty-helper
+
+ AM_CFLAGS = $(GLIB_CFLAGS)
+-AM_LDFLAGS = $(LDFLAGS) $(GLIB_LIBS)
++AM_LDFLAGS = -Wl,-z,now $(LDFLAGS) $(GLIB_LIBS)
+
+ gnome_pty_helper_SOURCES = \
+ gnome-pty.h \
diff --git a/x11-libs/vte/vte-0.14.0.ebuild b/x11-libs/vte/vte-0.14.0.ebuild
new file mode 100644
index 000000000000..db1a5af92a3b
--- /dev/null
+++ b/x11-libs/vte/vte-0.14.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/vte/vte-0.14.0.ebuild,v 1.1 2006/09/07 04:15:07 dang Exp $
+
+inherit eutils gnome2 autotools
+
+DESCRIPTION="Xft powered terminal widget"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug doc python opengl"
+
+RDEPEND=">=dev-libs/glib-2.9
+ >=x11-libs/gtk+-2.6
+ >=x11-libs/pango-1.1
+ >=media-libs/freetype-2.0.2
+ media-libs/fontconfig
+ sys-libs/ncurses
+ python? (
+ >=dev-python/pygtk-2.4
+ >=dev-lang/python-2.2
+ )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ )
+ || ( x11-libs/libX11 virtual/x11 )
+ virtual/xft"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-1.0 )
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+pkg_setup() {
+ G2CONF="$(use_enable debug debugging) $(use_enable python) \
+ $(use_with opengl glX) --with-xft2 --with-pangox"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ epatch ${FILESDIR}/${PN}-0.13.2-no-lazy-bindings.patch
+
+ cd ${S}/gnome-pty-helper
+ eautomake
+}