summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-09-17 21:16:32 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-09-17 21:16:32 +0000
commit1f6e217d210abcc01e5971aea0cea373b5a32fd8 (patch)
tree90d2e709919ebba764163ad6f49abf106ac59b77 /x11-misc/bbmail/bbmail-0.9.3.ebuild
parenttest commit (diff)
downloadgentoo-2-1f6e217d210abcc01e5971aea0cea373b5a32fd8.tar.gz
gentoo-2-1f6e217d210abcc01e5971aea0cea373b5a32fd8.tar.bz2
gentoo-2-1f6e217d210abcc01e5971aea0cea373b5a32fd8.zip
Version bump, and remove old version.
(Portage version: 2.2_rc8/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'x11-misc/bbmail/bbmail-0.9.3.ebuild')
-rw-r--r--x11-misc/bbmail/bbmail-0.9.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-misc/bbmail/bbmail-0.9.3.ebuild b/x11-misc/bbmail/bbmail-0.9.3.ebuild
new file mode 100644
index 000000000000..a0f9393642fa
--- /dev/null
+++ b/x11-misc/bbmail/bbmail-0.9.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/bbmail/bbmail-0.9.3.ebuild,v 1.1 2008/09/17 21:16:31 coldwind Exp $
+
+inherit eutils
+
+DESCRIPTION="blackbox mail notification"
+HOMEPAGE="http://www.sourceforge.net/projects/bbtools"
+SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ virtual/blackbox
+ x11-libs/libX11
+ x11-libs/libXext"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dobin scripts/bbmailparsefm.pl
+ dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
+}