summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGrant Goodyear <g2boojum@gentoo.org>2004-05-06 13:17:25 +0000
committerGrant Goodyear <g2boojum@gentoo.org>2004-05-06 13:17:25 +0000
commitb58df9573852a66740a5d5313006185703436cc3 (patch)
tree95ebc627a0d82f8833c1ad20d728a15f3df03fea /x11-misc/dclock/dclock-2.1.2_p5.ebuild
parentNow also installing hotplug related files, see bug #49815 (Manifest recommit) (diff)
downloadgentoo-2-b58df9573852a66740a5d5313006185703436cc3.tar.gz
gentoo-2-b58df9573852a66740a5d5313006185703436cc3.tar.bz2
gentoo-2-b58df9573852a66740a5d5313006185703436cc3.zip
New package to make the fvwm folks happy
Diffstat (limited to 'x11-misc/dclock/dclock-2.1.2_p5.ebuild')
-rw-r--r--x11-misc/dclock/dclock-2.1.2_p5.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/dclock/dclock-2.1.2_p5.ebuild b/x11-misc/dclock/dclock-2.1.2_p5.ebuild
new file mode 100644
index 000000000000..e494fad0c663
--- /dev/null
+++ b/x11-misc/dclock/dclock-2.1.2_p5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/dclock/dclock-2.1.2_p5.ebuild,v 1.1 2004/05/06 13:17:25 g2boojum Exp $
+
+DESCRIPTION="Digital clock for the X window system."
+SRC_URI="http://ftp.debian.org/debian/pool/main/d/${PN}/${PN}_${PV/_p*/}.orig.tar.gz
+ http://ftp.debian.org/debian/pool/main/d/${PN}/${PN}_${PV/_p/-}.diff.gz"
+HOMEPAGE="ftp://ftp.ac-grenoble.fr/ge/Xutils/"
+
+S=${WORKDIR}/${PN}
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+DEPEND="virtual/x11"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p1 < ../${PN}_${PV/_p/-}.diff || die "patch failed"
+ ln -sf dclock.1 dclock.man # needed to fix xmkmf breakage
+}
+
+src_compile() {
+ xmkmf || die "xmkmf failed"
+ make CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ make DESTDIR=${D} install.man || die "make install.man failed"
+ insinto /usr/share/sounds
+ doins sounds/*
+ insinto /etc/X11/app-defaults
+ newins Dclock.ad DClock
+ dodoc README TODO
+}