summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-11-04 00:59:03 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-11-04 00:59:03 +0000
commit273a1e71f61b5491a0faaf0aeb6ee85dea5cd783 (patch)
treebaa110c9949b142695bfe2ff4753e270f7e0458c /x11-misc/evolvotron/evolvotron-0.3.1.ebuild
parentVersion bump. (Manifest recommit) (diff)
downloadgentoo-2-273a1e71f61b5491a0faaf0aeb6ee85dea5cd783.tar.gz
gentoo-2-273a1e71f61b5491a0faaf0aeb6ee85dea5cd783.tar.bz2
gentoo-2-273a1e71f61b5491a0faaf0aeb6ee85dea5cd783.zip
version bump (bug #63369)
Diffstat (limited to 'x11-misc/evolvotron/evolvotron-0.3.1.ebuild')
-rw-r--r--x11-misc/evolvotron/evolvotron-0.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/evolvotron/evolvotron-0.3.1.ebuild b/x11-misc/evolvotron/evolvotron-0.3.1.ebuild
new file mode 100644
index 000000000000..252e66d08483
--- /dev/null
+++ b/x11-misc/evolvotron/evolvotron-0.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/evolvotron/evolvotron-0.3.1.ebuild,v 1.1 2004/11/04 00:59:03 mr_bones_ Exp $
+
+DESCRIPTION="An interactive generative art application"
+HOMEPAGE="http://www.bottlenose.demon.co.uk/share/evolvotron/index.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND=">=x11-libs/qt-3"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e '/QMAKE_CXXFLAGS_RELEASE .*march/d' \
+ -e "/^QMAKE_CXXFLAGS_RELEASE += -O3/ s:=.*:= ${CXXFLAGS}:" \
+ -e '/^INSTALLPATH/ s:=.*:= /usr/bin:' ${S}/common.pro \
+ || die "sed common.pro failed"
+}
+
+src_compile() {
+ econf fs || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make INSTALL_ROOT="${D}" install || die "make install failed"
+ dodoc BUGS CHANGES README TODO USAGE
+}