summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-04-24 08:50:35 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-04-24 08:50:35 +0000
commited6944395e4d849fdea972163ee2378eca89fd94 (patch)
tree92e29d21141eccd540494c27624603477c3ff766 /x11-misc/fbdesk
parentinitial import (diff)
downloadgentoo-2-ed6944395e4d849fdea972163ee2378eca89fd94.tar.gz
gentoo-2-ed6944395e4d849fdea972163ee2378eca89fd94.tar.bz2
gentoo-2-ed6944395e4d849fdea972163ee2378eca89fd94.zip
Compile with GCC 4.3; patch by Peter Alfredsen. (bug #218336)
(Portage version: 2.1.5_rc3)
Diffstat (limited to 'x11-misc/fbdesk')
-rw-r--r--x11-misc/fbdesk/ChangeLog8
-rw-r--r--x11-misc/fbdesk/fbdesk-1.4.1.ebuild11
-rw-r--r--x11-misc/fbdesk/files/fbdesk-1.4.1-gcc-4.3.patch146
3 files changed, 161 insertions, 4 deletions
diff --git a/x11-misc/fbdesk/ChangeLog b/x11-misc/fbdesk/ChangeLog
index 99c2519e5e82..815845e13f18 100644
--- a/x11-misc/fbdesk/ChangeLog
+++ b/x11-misc/fbdesk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/fbdesk
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.24 2007/12/05 19:54:47 lack Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/ChangeLog,v 1.25 2008/04/24 08:50:34 omp Exp $
+
+ 24 Apr 2008; David Shakaryan <omp@gentoo.org>
+ +files/fbdesk-1.4.1-gcc-4.3.patch, fbdesk-1.4.1.ebuild:
+ Compile with GCC 4.3; patch by Peter Alfredsen. (bug #218336)
05 Dec 2007; Jim Ramsay <lack@gentoo.org> fbdesk-1.2.1.ebuild,
fbdesk-1.4.1.ebuild:
diff --git a/x11-misc/fbdesk/fbdesk-1.4.1.ebuild b/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
index 9879dfcff3db..04d6a884b3b1 100644
--- a/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
+++ b/x11-misc/fbdesk/fbdesk-1.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.4.1.ebuild,v 1.2 2007/12/05 19:54:47 lack Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/fbdesk/fbdesk-1.4.1.ebuild,v 1.3 2008/04/24 08:50:34 omp Exp $
inherit eutils
@@ -20,6 +20,13 @@ RDEPEND="png? ( media-libs/libpng )
DEPEND="${RDEPEND}
x11-proto/xextproto"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch"
+}
+
src_compile() {
econf \
$(use_enable imlib2) \
diff --git a/x11-misc/fbdesk/files/fbdesk-1.4.1-gcc-4.3.patch b/x11-misc/fbdesk/files/fbdesk-1.4.1-gcc-4.3.patch
new file mode 100644
index 000000000000..fba8bfe97176
--- /dev/null
+++ b/x11-misc/fbdesk/files/fbdesk-1.4.1-gcc-4.3.patch
@@ -0,0 +1,146 @@
+--- fbdesk-1.4.1.orig/src/FbDesk.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbDesk.cc 2008-04-18 23:23:53.000000000 +0200
+@@ -37,10 +37,11 @@
+ #include <iostream>
+ #include <fstream>
+ #include <algorithm>
+ #include <unistd.h>
+ #include <cstdio>
++#include <cstring>
+
+ using namespace std;
+ using namespace FbTk;
+
+
+--- fbdesk-1.4.1.orig/src/FbTk/FbPixmap.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbTk/FbPixmap.cc 2008-04-18 22:55:06.000000000 +0200
+@@ -28,10 +28,11 @@
+
+ #include <X11/Xutil.h>
+ #include <X11/Xatom.h>
+ #include <iostream>
+ #include <string>
++#include <cstring>
+
+ using namespace std;
+
+ namespace FbTk {
+
+--- fbdesk-1.4.1.orig/src/FbTk/KeyUtil.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbTk/KeyUtil.cc 2008-04-18 22:56:17.000000000 +0200
+@@ -23,10 +23,11 @@
+
+ #include "KeyUtil.hh"
+ #include "App.hh"
+
+ #include <string>
++#include <cstring>
+
+ namespace {
+
+ struct t_modlist{
+ char *str;
+--- fbdesk-1.4.1.orig/src/FbTk/StringUtil.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbTk/StringUtil.cc 2008-04-18 22:52:54.000000000 +0200
+@@ -47,10 +47,11 @@
+
+
+ #include <memory>
+ #include <algorithm>
+ #include <string>
++#include <cstring>
+
+ using std::string;
+ using std::transform;
+
+ namespace FbTk {
+--- fbdesk-1.4.1.orig/src/FbTk/TextBox.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbTk/TextBox.cc 2008-04-18 22:58:22.000000000 +0200
+@@ -34,10 +34,11 @@
+ #endif
+ #include <X11/keysym.h>
+ #include <X11/Xutil.h>
+
+ #include <iostream>
++#include <cstdlib>
+
+ namespace FbTk {
+
+ TextBox::TextBox(int screen_num,
+ const Font &font, const std::string &text):
+--- fbdesk-1.4.1.orig/src/FbTk/TextureRender.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbTk/TextureRender.cc 2008-04-18 22:48:18.000000000 +0200
+@@ -31,10 +31,11 @@
+ #include "FbPixmap.hh"
+ #include "GContext.hh"
+
+ #include <iostream>
+ #include <string>
++#include <cstring>
+ #ifdef HAVE_CSTDIO
+ #include <cstdio>
+ #else
+ #include <stdio.h>
+ #endif
+--- fbdesk-1.4.1.orig/src/FbTk/Theme.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbTk/Theme.cc 2008-04-18 22:49:14.000000000 +0200
+@@ -34,10 +34,11 @@
+ #else
+ #include <stdio.h>
+ #endif
+ #include <memory>
+ #include <iostream>
++#include <algorithm>
+
+ using namespace std;
+
+ namespace FbTk {
+
+--- fbdesk-1.4.1.orig/src/FbTk/ThemeItems.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbTk/ThemeItems.cc 2008-04-18 23:22:03.000000000 +0200
+@@ -46,10 +46,12 @@
+ #include <stdio.h>
+ #endif
+
+ #include <iostream>
+ #include <memory>
++#include <cstdlib>
++#include <cstring>
+
+ namespace FbTk {
+
+ using std::string;
+ using std::cerr;
+--- fbdesk-1.4.1.orig/src/FbTk/XFontImp.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/FbTk/XFontImp.cc 2008-04-18 22:45:31.000000000 +0200
+@@ -26,10 +26,11 @@
+ #include "GContext.hh"
+ #include "FbPixmap.hh"
+
+ #include <X11/Xutil.h>
+
++#include <cstdlib>
+ #include <iostream>
+ #include <new>
+ #ifdef HAVE_CSTDIO
+ #include <cstdio>
+ #else
+--- fbdesk-1.4.1.orig/src/main.cc 2008-04-18 22:42:17.000000000 +0200
++++ fbdesk-1.4.1/src/main.cc 2008-04-18 23:24:47.000000000 +0200
+@@ -21,14 +21,16 @@
+
+ #include "App.hh"
+ #include "FbDesk.hh"
+ #include "version.h"
+
++#include <cstdlib>
+ #include <iostream>
+ #include <stdexcept>
+ #include <signal.h>
+ #include <sys/wait.h>
++#include <cstring>
+
+ using namespace std;
+
+ /// handles system signals
+ void signalhandler(int sig) {