summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYuri Vasilevski <yvasilev@gentoo.org>2006-03-13 00:19:07 +0000
committerYuri Vasilevski <yvasilev@gentoo.org>2006-03-13 00:19:07 +0000
commit4a4846f8aba9eb77e6fcf7068bf220dae9c9457f (patch)
tree470b6b674e54b8bcda1239c822ec9c3c15fc8e03 /x11-misc/matchbox-panel-manager/matchbox-panel-manager-0.1.ebuild
parentversion bump (diff)
downloadgentoo-2-4a4846f8aba9eb77e6fcf7068bf220dae9c9457f.tar.gz
gentoo-2-4a4846f8aba9eb77e6fcf7068bf220dae9c9457f.tar.bz2
gentoo-2-4a4846f8aba9eb77e6fcf7068bf220dae9c9457f.zip
- Initial import. Original ebuild by Priit Laes, modifications by Björn Ruberg and Yuri Vasilevski.
(Portage version: 2.1_pre6)
Diffstat (limited to 'x11-misc/matchbox-panel-manager/matchbox-panel-manager-0.1.ebuild')
-rw-r--r--x11-misc/matchbox-panel-manager/matchbox-panel-manager-0.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-misc/matchbox-panel-manager/matchbox-panel-manager-0.1.ebuild b/x11-misc/matchbox-panel-manager/matchbox-panel-manager-0.1.ebuild
new file mode 100644
index 000000000000..87da055afec3
--- /dev/null
+++ b/x11-misc/matchbox-panel-manager/matchbox-panel-manager-0.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2006-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/matchbox-panel-manager/matchbox-panel-manager-0.1.ebuild,v 1.1 2006/03/13 00:19:07 yvasilev Exp $
+
+inherit versionator
+
+DESCRIPTION="Matchbox panel configuration utility."
+HOMEPAGE="http://projects.o-hand.com/matchbox/"
+SRC_URI="http://projects.o-hand.com/matchbox/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libmatchbox-1.5
+ >=x11-libs/gtk+-2.0.3"
+
+RDEPEND="${DEPEND}
+ x11-wm/matchbox-panel"
+
+src_compile() {
+ econf || die "Configuration failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc AUTHORS Changelog INSTALL NEWS README
+}