summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-10 08:45:36 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-10 08:45:36 +0000
commit977737f8c1dd5ed91c6ff1cda903a1524dde64b9 (patch)
tree919dff37412cb292ef2362f44a1cf9bfc59ba58d /x11-misc/notify-osd
parentStable for amd64, wrt bug #411015 (diff)
downloadgentoo-2-977737f8c1dd5ed91c6ff1cda903a1524dde64b9.tar.gz
gentoo-2-977737f8c1dd5ed91c6ff1cda903a1524dde64b9.tar.bz2
gentoo-2-977737f8c1dd5ed91c6ff1cda903a1524dde64b9.zip
Version bump and use libdir instead of libexecdir.
(Portage version: 2.2.0_alpha99/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/notify-osd')
-rw-r--r--x11-misc/notify-osd/ChangeLog8
-rw-r--r--x11-misc/notify-osd/notify-osd-0.9.34.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/x11-misc/notify-osd/ChangeLog b/x11-misc/notify-osd/ChangeLog
index 80fcb125fe9a..cfdeaa6a92e2 100644
--- a/x11-misc/notify-osd/ChangeLog
+++ b/x11-misc/notify-osd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/notify-osd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/ChangeLog,v 1.12 2012/03/17 19:55:40 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/ChangeLog,v 1.13 2012/04/10 08:45:36 ssuominen Exp $
+
+*notify-osd-0.9.34 (10 Apr 2012)
+
+ 10 Apr 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +notify-osd-0.9.34.ebuild:
+ Version bump and use libdir instead of libexecdir.
*notify-osd-0.9.33 (17 Mar 2012)
diff --git a/x11-misc/notify-osd/notify-osd-0.9.34.ebuild b/x11-misc/notify-osd/notify-osd-0.9.34.ebuild
new file mode 100644
index 000000000000..fdd31742296a
--- /dev/null
+++ b/x11-misc/notify-osd/notify-osd-0.9.34.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/notify-osd/notify-osd-0.9.34.ebuild,v 1.1 2012/04/10 08:45:36 ssuominen Exp $
+
+EAPI=4
+inherit autotools gnome2-utils multilib savedconfig
+
+DESCRIPTION="Canonical's on-screen-display notification agent"
+HOMEPAGE="http://launchpad.net/notify-osd"
+SRC_URI="http://launchpad.net/${PN}/precise/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="minimal"
+
+COMMON_DEPEND=">=dev-libs/dbus-glib-0.98
+ >=dev-libs/glib-2.16
+ >=x11-libs/gtk+-3.2:3
+ >=x11-libs/libnotify-0.7
+ >=x11-libs/libwnck-3
+ x11-libs/libX11
+ x11-libs/pixman
+ !x11-misc/notification-daemon
+ !x11-misc/qtnotifydaemon"
+RDEPEND="${COMMON_DEPEND}
+ !minimal? ( x11-themes/notify-osd-icons )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ gnome-base/gnome-common
+ x11-proto/xproto"
+
+RESTRICT="test" # virtualx.eclass: 1 of 1: FAIL: test-modules
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_prepare() {
+ sed -i -e 's:noinst_PROG:check_PROG:' tests/Makefile.am || die
+ restore_config src/{bubble,defaults}.c
+ eautoreconf
+}
+
+src_configure() {
+ econf --libexecdir=/usr/$(get_libdir)/${PN}
+}
+
+src_install() {
+ default
+ save_config src/{bubble,defaults}.c
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+ gnome2_schemas_savelist
+}
+pkg_postinst() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}