summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2013-12-15 17:46:33 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2013-12-15 17:46:33 +0000
commitc70b5344008a7b9e923899901ecbcd29720cbfb1 (patch)
tree1d019d40383f630de7764ed63c8ba7089e5ac567 /x11-misc/py3status
parentStable for x86, wrt bug #492282 (diff)
downloadgentoo-2-c70b5344008a7b9e923899901ecbcd29720cbfb1.tar.gz
gentoo-2-c70b5344008a7b9e923899901ecbcd29720cbfb1.tar.bz2
gentoo-2-c70b5344008a7b9e923899901ecbcd29720cbfb1.zip
version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'x11-misc/py3status')
-rw-r--r--x11-misc/py3status/ChangeLog7
-rw-r--r--x11-misc/py3status/py3status-1.1.ebuild27
2 files changed, 33 insertions, 1 deletions
diff --git a/x11-misc/py3status/ChangeLog b/x11-misc/py3status/ChangeLog
index e89e3329b8a7..c5912f8c1ffe 100644
--- a/x11-misc/py3status/ChangeLog
+++ b/x11-misc/py3status/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/py3status
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/py3status/ChangeLog,v 1.3 2013/09/05 19:44:56 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/py3status/ChangeLog,v 1.4 2013/12/15 17:46:33 ultrabug Exp $
+
+*py3status-1.1 (15 Dec 2013)
+
+ 15 Dec 2013; Ultrabug <ultrabug@gentoo.org> +py3status-1.1.ebuild:
+ version bump
05 Sep 2013; Michał Górny <mgorny@gentoo.org> py3status-1.0.ebuild:
Clean up PYTHON_COMPAT from old implementations.
diff --git a/x11-misc/py3status/py3status-1.1.ebuild b/x11-misc/py3status/py3status-1.1.ebuild
new file mode 100644
index 000000000000..4f420a4ce96b
--- /dev/null
+++ b/x11-misc/py3status/py3status-1.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/py3status/py3status-1.1.ebuild,v 1.1 2013/12/15 17:46:33 ultrabug Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
+
+SRC_URI="https://github.com/ultrabug/py3status/archive/${PV}.tar.gz"
+
+inherit distutils-r1
+
+MY_PN="py3status"
+MY_P="${MY_PN}-${PV/_/-}"
+
+DESCRIPTION="py3status is an extensible i3status wrapper written in python"
+HOMEPAGE="https://github.com/ultrabug/py3status"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-misc/i3status"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}