summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJauhien Piatlicki <jauhien@gentoo.org>2014-05-26 22:37:38 +0000
committerJauhien Piatlicki <jauhien@gentoo.org>2014-05-26 22:37:38 +0000
commitae82fcfd5355a62adad3b3fa99e1713826c52bc7 (patch)
tree2ec0fe3e24f1a225428dd5123bd660861c9fcd5a /x11-misc/sddm
parentVersion bump, bug #508932 (diff)
downloadgentoo-2-ae82fcfd5355a62adad3b3fa99e1713826c52bc7.tar.gz
gentoo-2-ae82fcfd5355a62adad3b3fa99e1713826c52bc7.tar.bz2
gentoo-2-ae82fcfd5355a62adad3b3fa99e1713826c52bc7.zip
revert changing pam file. add warning for user, see bug #511484
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB2EFA1D4)
Diffstat (limited to 'x11-misc/sddm')
-rw-r--r--x11-misc/sddm/ChangeLog6
-rw-r--r--x11-misc/sddm/files/sddm-0.1.0-consolekit.patch21
-rw-r--r--x11-misc/sddm/sddm-0.1.0-r1.ebuild12
-rw-r--r--x11-misc/sddm/sddm-0.1.0.ebuild46
4 files changed, 18 insertions, 67 deletions
diff --git a/x11-misc/sddm/ChangeLog b/x11-misc/sddm/ChangeLog
index f27e54c5d80a..9593cf2cdcb1 100644
--- a/x11-misc/sddm/ChangeLog
+++ b/x11-misc/sddm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/sddm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sddm/ChangeLog,v 1.4 2014/05/26 21:58:35 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sddm/ChangeLog,v 1.5 2014/05/26 22:37:38 jauhien Exp $
+
+ 26 May 2014; <jauhien@gentoo.org> -sddm-0.1.0.ebuild,
+ files/sddm-0.1.0-consolekit.patch, sddm-0.1.0-r1.ebuild:
+ revert changing pam file. add warning for user, see bug #511484
*sddm-0.1.0-r1 (26 May 2014)
diff --git a/x11-misc/sddm/files/sddm-0.1.0-consolekit.patch b/x11-misc/sddm/files/sddm-0.1.0-consolekit.patch
index 42ebf67671d0..a5ac62ac47f8 100644
--- a/x11-misc/sddm/files/sddm-0.1.0-consolekit.patch
+++ b/x11-misc/sddm/files/sddm-0.1.0-consolekit.patch
@@ -1,6 +1,5 @@
-diff -r -u sddm-0.1.0/data/scripts/Xsession sddm-0.1.0.patched/data/scripts/Xsession
---- sddm-0.1.0/data/scripts/Xsession 2013-03-19 21:23:36.000000000 +0100
-+++ sddm-0.1.0.patched/data/scripts/Xsession 2014-05-26 23:40:09.654374811 +0200
+--- data/scripts/Xsession
++++ data/scripts/Xsession
@@ -74,13 +74,13 @@
exec xterm -geometry 80x24-0-0
;;
@@ -18,19 +17,3 @@ diff -r -u sddm-0.1.0/data/scripts/Xsession sddm-0.1.0.patched/data/scripts/Xses
;;
esac
exec xmessage -center -buttons OK:0 -default OK "Sorry, cannot execute $session. Check $DESKTOP_SESSION.desktop."
-diff -r -u sddm-0.1.0/services/sddm.pam sddm-0.1.0.patched/services/sddm.pam
---- sddm-0.1.0/services/sddm.pam 2013-03-19 21:23:36.000000000 +0100
-+++ sddm-0.1.0.patched/services/sddm.pam 2014-05-26 23:39:52.484616252 +0200
-@@ -3,4 +3,11 @@
- auth include system-login
- account include system-login
- password include system-login
--session include system-login
-+
-+session optional pam_loginuid.so
-+session required pam_env.so
-+session optional pam_lastlog.so silent
-+session include system-auth
-+-session optional pam_ck_connector.so
-+session optional pam_motd.so motd=/etc/motd
-+session optional pam_mail.so
diff --git a/x11-misc/sddm/sddm-0.1.0-r1.ebuild b/x11-misc/sddm/sddm-0.1.0-r1.ebuild
index 97065c36650b..cd3630ad31a3 100644
--- a/x11-misc/sddm/sddm-0.1.0-r1.ebuild
+++ b/x11-misc/sddm/sddm-0.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sddm/sddm-0.1.0-r1.ebuild,v 1.1 2014/05/26 21:58:34 jauhien Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sddm/sddm-0.1.0-r1.ebuild,v 1.2 2014/05/26 22:37:38 jauhien Exp $
EAPI=5
inherit cmake-utils toolchain-funcs
@@ -19,6 +19,7 @@ RDEPEND="sys-libs/pam
x11-libs/libxcb[xkb(-)]
dev-qt/qtdeclarative:4
dev-qt/qtdbus:4
+ consolekit? ( sys-auth/consolekit )
systemd? ( sys-apps/systemd:= )
upower? ( sys-power/upower:= )"
DEPEND="${RDEPEND}
@@ -46,3 +47,12 @@ src_configure() {
)
cmake-utils_src_configure
}
+
+pkg_postinst() {
+ if use consolekit; then
+ ewarn "This display manager doesn't have native built-in ConsoleKit support."
+ ewarn "In order to use ConsoleKit pam module with this display manager,"
+ ewarn "you should remove the \"nox11\" parameter from pm_ck_connector.so"
+ ewarn "line in /etc/pam.d/system-login"
+ fi
+}
diff --git a/x11-misc/sddm/sddm-0.1.0.ebuild b/x11-misc/sddm/sddm-0.1.0.ebuild
deleted file mode 100644
index 5c9eec27df6a..000000000000
--- a/x11-misc/sddm/sddm-0.1.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sddm/sddm-0.1.0.ebuild,v 1.2 2014/05/25 10:53:42 jauhien Exp $
-
-EAPI=5
-inherit cmake-utils toolchain-funcs
-
-DESCRIPTION="Simple Desktop Display Manager"
-HOMEPAGE="https://github.com/sddm/sddm"
-SRC_URI="http://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-
-LICENSE="GPL-2+ MIT CC-BY-3.0 public-domain"
-SLOT="0"
-IUSE="systemd +upower"
-REQUIRED_USE="?? ( upower systemd )"
-
-RDEPEND="sys-libs/pam
- x11-libs/libxcb[xkb(-)]
- dev-qt/qtdeclarative:4
- dev-qt/qtdbus:4
- systemd? ( sys-apps/systemd:= )
- upower? ( sys-power/upower:= )"
-DEPEND="${RDEPEND}
- >=sys-devel/gcc-4.7.0
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${P}-cmake.patch"
- "${FILESDIR}/${P}-clang.patch"
-)
-
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != binary ]]; then
- [[ $(gcc-version) < 4.7 ]] && \
- die 'The active compiler needs to be gcc 4.7 (or newer)'
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_use systemd)
- $(cmake-utils_use_use upower)
- )
- cmake-utils_src_configure
-}