summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-08-21 21:22:45 +0000
committerMichał Górny <mgorny@gentoo.org>2011-08-21 21:22:45 +0000
commitf0ac9a9fbce0313e3c35788474ae758e01db4f9e (patch)
tree4aeac39ac2d0287fdaf3b82d5da2f4b1b6926399 /x11-misc/sw-notify-send
parentAdd undocumented variable such that in case of test failures the test log is (diff)
downloadgentoo-2-f0ac9a9fbce0313e3c35788474ae758e01db4f9e.tar.gz
gentoo-2-f0ac9a9fbce0313e3c35788474ae758e01db4f9e.tar.bz2
gentoo-2-f0ac9a9fbce0313e3c35788474ae758e01db4f9e.zip
Version bump to 0.2, which is actually a tinynotify-send variant.
(Portage version: 2.2.0_alpha51_p4/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/sw-notify-send')
-rw-r--r--x11-misc/sw-notify-send/ChangeLog7
-rw-r--r--x11-misc/sw-notify-send/sw-notify-send-0.2.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/x11-misc/sw-notify-send/ChangeLog b/x11-misc/sw-notify-send/ChangeLog
index fb6f870c4fdf..05e027639d5e 100644
--- a/x11-misc/sw-notify-send/ChangeLog
+++ b/x11-misc/sw-notify-send/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/sw-notify-send
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/sw-notify-send/ChangeLog,v 1.1 2011/01/14 13:36:28 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sw-notify-send/ChangeLog,v 1.2 2011/08/21 21:22:45 mgorny Exp $
+
+*sw-notify-send-0.2 (21 Aug 2011)
+
+ 21 Aug 2011; Michał Górny <mgorny@gentoo.org> +sw-notify-send-0.2.ebuild:
+ Version bump to 0.2, which is actually a tinynotify-send variant.
*sw-notify-send-0.1.1 (14 Jan 2011)
diff --git a/x11-misc/sw-notify-send/sw-notify-send-0.2.ebuild b/x11-misc/sw-notify-send/sw-notify-send-0.2.ebuild
new file mode 100644
index 000000000000..6fd8f43f9ef4
--- /dev/null
+++ b/x11-misc/sw-notify-send/sw-notify-send-0.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/sw-notify-send/sw-notify-send-0.2.ebuild,v 1.1 2011/08/21 21:22:45 mgorny Exp $
+
+EAPI=4
+inherit autotools-utils
+
+MY_PN=tinynotify-send
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A system-wide variant of tinynotify-send"
+HOMEPAGE="https://github.com/mgorny/tinynotify-send/"
+SRC_URI="http://cloud.github.com/downloads/mgorny/${MY_PN}/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libtinynotify
+ x11-libs/libtinynotify-cli
+ x11-libs/libtinynotify-systemwide"
+DEPEND="${RDEPEND}"
+
+DOCS=( README )
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ myeconfargs=(
+ --disable-regular
+ --enable-system-wide
+ )
+
+ autotools-utils_src_configure
+}