summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-05-06 13:56:14 +0000
committerKevin McCarthy <signals@gentoo.org>2011-05-06 13:56:14 +0000
commit6b02a9338197cebde629dcd0b90e8b407f2a10cc (patch)
tree1ff51c6f8bb69c4787ee6b15647b67503c23e14c /x11-misc/wbar
parentAdd prelink to use.mask since its p.masked (diff)
downloadgentoo-2-6b02a9338197cebde629dcd0b90e8b407f2a10cc.tar.gz
gentoo-2-6b02a9338197cebde629dcd0b90e8b407f2a10cc.tar.bz2
gentoo-2-6b02a9338197cebde629dcd0b90e8b407f2a10cc.zip
Version bump.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/wbar')
-rw-r--r--x11-misc/wbar/ChangeLog8
-rw-r--r--x11-misc/wbar/files/wbar-2.1.3-as-needed.patch36
-rw-r--r--x11-misc/wbar/wbar-2.1.3.ebuild47
3 files changed, 90 insertions, 1 deletions
diff --git a/x11-misc/wbar/ChangeLog b/x11-misc/wbar/ChangeLog
index 0b24b554a80a..9eb863d46246 100644
--- a/x11-misc/wbar/ChangeLog
+++ b/x11-misc/wbar/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/wbar
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.9 2011/04/15 20:11:55 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.10 2011/05/06 13:56:14 signals Exp $
+
+*wbar-2.1.3 (06 May 2011)
+
+ 06 May 2011; Kevin McCarthy <signals@gentoo.org> +wbar-2.1.3.ebuild,
+ +files/wbar-2.1.3-as-needed.patch:
+ Version bump.
15 Apr 2011; Kevin McCarthy <signals@gentoo.org> wbar-2.1.1.ebuild:
Removed -Werror from CFLAGS.
diff --git a/x11-misc/wbar/files/wbar-2.1.3-as-needed.patch b/x11-misc/wbar/files/wbar-2.1.3-as-needed.patch
new file mode 100644
index 000000000000..3e917a670e0b
--- /dev/null
+++ b/x11-misc/wbar/files/wbar-2.1.3-as-needed.patch
@@ -0,0 +1,36 @@
+Fix automake issues with having two Main.cc
+Fix building with --as-needed
+
+https://bugs.gentoo.org/358557
+
+Patch provided by xarthisius@gentoo.org for 2.1.1
+Patch adapted to 2.1.3 by Kevin McCarthy <signals@gentoo.org>
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -27,7 +27,7 @@
+ $(top_srcdir)/src/config/Run.cc \
+ $(top_srcdir)/src/config/Functions.cc \
+ $(top_srcdir)/src/config/Functions.h \
+-$(top_srcdir)/src/config/Main.cc \
++$(top_srcdir)/src/config/Main-config.cc \
+ $(UTILS)
+ endif
+
+@@ -42,11 +42,12 @@
+ $(top_srcdir)/src/utils/OptParser.h \
+ $(top_srcdir)/src/utils/i18n.h
+
+-wbar_CPPFLAGS = @modules_CFLAGS@ -I$(top_srcdir)/src/utils
+-wbar_LDFLAGS = @modules_LIBS@
++AM_CPPFLAGS = -I$(top_srcdir)/src/utils
++wbar_CXXFLAGS = @modules_CFLAGS@
++wbar_LDADD = @modules_LIBS@
+
+ if WBAR_CONFIG
+-wbar_config_CPPFLAGS = @gui_modules_CFLAGS@ -I$(top_srcdir)/src/utils
+-wbar_config_LDFLAGS = @gui_modules_LIBS@
++wbar_config_CXXFLAGS = @gui_modules_CFLAGS@
++wbar_config_LDADD = @gui_modules_LIBS@
+ endif
+
diff --git a/x11-misc/wbar/wbar-2.1.3.ebuild b/x11-misc/wbar/wbar-2.1.3.ebuild
new file mode 100644
index 000000000000..efe1282a965a
--- /dev/null
+++ b/x11-misc/wbar/wbar-2.1.3.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/wbar-2.1.3.ebuild,v 1.1 2011/05/06 13:56:14 signals Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="A fast, lightweight quick launch bar."
+HOMEPAGE="http://code.google.com/p/wbar/"
+SRC_URI="http://wbar.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk"
+
+RDEPEND="media-libs/imlib2
+ x11-libs/libX11
+ gtk? ( dev-libs/atk
+ dev-libs/glib:2
+ dev-libs/libxml2
+ gnome-base/libglade
+ media-libs/fontconfig
+ media-libs/freetype
+ media-libs/libpng
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ if ! use gtk; then
+ # Remove wbar-config from default cfg.
+ sed -i -e '5,8d' \
+ etc/wbar.cfg.in || die "Removing wbar-config from cfg"
+ fi
+ sed -i configure.ac -e "/^CPPFLAGS/d" || die #respect flags
+ eautoreconf
+ # Fix build issue reported by xarthisius (See as-needed.patch)
+ mv "${S}"/src/config/Main.cc "${S}"/src/config/Main-config.cc || die
+}
+
+src_configure() {
+ econf --bindir=/usr/bin $(use_enable gtk wbar-config)
+}