summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKevin McCarthy <signals@gentoo.org>2011-03-13 15:12:35 +0000
committerKevin McCarthy <signals@gentoo.org>2011-03-13 15:12:35 +0000
commitf64a6d5997e56d3ffea9e642c879fea6fb93d99a (patch)
tree11d26e524bfc80afe3bec37dd7a4ee0e00c79d46 /x11-misc/wbar
parentMarked ~ppc-macos (diff)
downloadgentoo-2-f64a6d5997e56d3ffea9e642c879fea6fb93d99a.tar.gz
gentoo-2-f64a6d5997e56d3ffea9e642c879fea6fb93d99a.tar.bz2
gentoo-2-f64a6d5997e56d3ffea9e642c879fea6fb93d99a.zip
Use LDADD for libraries. Fixes bug #358557
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/wbar')
-rw-r--r--x11-misc/wbar/ChangeLog6
-rw-r--r--x11-misc/wbar/files/wbar-2.1.1-as-needed.patch17
-rw-r--r--x11-misc/wbar/wbar-2.1.1.ebuild5
3 files changed, 25 insertions, 3 deletions
diff --git a/x11-misc/wbar/ChangeLog b/x11-misc/wbar/ChangeLog
index d702adb2716b..31d104a6314c 100644
--- a/x11-misc/wbar/ChangeLog
+++ b/x11-misc/wbar/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/wbar
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.6 2011/02/24 17:52:50 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/ChangeLog,v 1.7 2011/03/13 15:12:35 signals Exp $
+
+ 13 Mar 2011; Kevin McCarthy <signals@gentoo.org> wbar-2.1.1.ebuild,
+ +files/wbar-2.1.1-as-needed.patch:
+ Use LDADD for libraries. Fixes bug #358557
*wbar-2.1.1 (24 Feb 2011)
diff --git a/x11-misc/wbar/files/wbar-2.1.1-as-needed.patch b/x11-misc/wbar/files/wbar-2.1.1-as-needed.patch
new file mode 100644
index 000000000000..b0d1fba7f2bf
--- /dev/null
+++ b/x11-misc/wbar/files/wbar-2.1.1-as-needed.patch
@@ -0,0 +1,17 @@
+Put LIBS in LDADD instead of LDFLAGS so --as-needed works.
+
+Patch by Kevin McCarthy <signals@gentoo.org>
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -41,8 +41,8 @@
+ $(top_srcdir)/src/utils/i18n.h
+
+ wbar_CPPFLAGS = @modules_CFLAGS@ -I$(top_srcdir)/src/utils
+-wbar_LDFLAGS = @modules_LIBS@
++wbar_LDADD = @modules_LIBS@
+
+ wbar_config_CPPFLAGS = @gui_modules_CFLAGS@ -I$(top_srcdir)/src/utils
+-wbar_config_LDFLAGS = @gui_modules_LIBS@
++wbar_config_LDADD = @gui_modules_LIBS@
+
diff --git a/x11-misc/wbar/wbar-2.1.1.ebuild b/x11-misc/wbar/wbar-2.1.1.ebuild
index a801ed2291b0..16d87efc6e24 100644
--- a/x11-misc/wbar/wbar-2.1.1.ebuild
+++ b/x11-misc/wbar/wbar-2.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/wbar-2.1.1.ebuild,v 1.1 2011/02/24 17:52:50 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/wbar/wbar-2.1.1.ebuild,v 1.2 2011/03/13 15:12:35 signals Exp $
EAPI=4
inherit autotools eutils
@@ -31,7 +31,8 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-fix-warnings.patch\
- "${FILESDIR}"/${P}-opt-config.patch
+ "${FILESDIR}"/${P}-opt-config.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
sed -i \
-e 's^truetype/dustin/PenguinAttack^corefonts/arial^' \
-e 's^openoffice.png^ooffice.png^' \