summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2007-04-25 03:50:04 +0000
committerMart Raudsepp <leio@gentoo.org>2007-04-25 03:50:04 +0000
commit4065292519c3c096043a8124425fe71225076c3f (patch)
treef6351cffcb5582c2519bcd741496d5a1e80f6a6a /x11-misc/xchm
parentapp-text/gnopaster: added ~amd64 keyword, changed dev-perl/ConfigReader depen... (diff)
downloadgentoo-2-4065292519c3c096043a8124425fe71225076c3f.tar.gz
gentoo-2-4065292519c3c096043a8124425fe71225076c3f.tar.bz2
gentoo-2-4065292519c3c096043a8124425fe71225076c3f.zip
Version bump. Also fixes many MIME related issues - make launching of chm files (with xCHM) work automatically from file managers; make the chm MIME icon provided by this package work properly; update icon and desktop mime database as necessary
(Portage version: 2.1.2.4)
Diffstat (limited to 'x11-misc/xchm')
-rw-r--r--x11-misc/xchm/ChangeLog11
-rw-r--r--x11-misc/xchm/files/digest-xchm-1.133
-rw-r--r--x11-misc/xchm/files/xchm-1.13.desktop11
-rw-r--r--x11-misc/xchm/xchm-1.13.ebuild84
4 files changed, 108 insertions, 1 deletions
diff --git a/x11-misc/xchm/ChangeLog b/x11-misc/xchm/ChangeLog
index ca46d41150c4..a08a6d3b2799 100644
--- a/x11-misc/xchm/ChangeLog
+++ b/x11-misc/xchm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-misc/xchm
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/ChangeLog,v 1.48 2007/03/24 01:34:04 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/ChangeLog,v 1.49 2007/04/25 03:50:04 leio Exp $
+
+*xchm-1.13 (25 Apr 2007)
+
+ 25 Apr 2007; <leio@gentoo.org> +files/xchm-1.13.desktop,
+ +xchm-1.13.ebuild:
+ Version bump. Also fixes many MIME related issues - make launching of chm
+ files (with xCHM) work automatically from file managers; make the chm MIME
+ icon provided by this package work properly; update icon and desktop mime
+ database as necessary
*xchm-1.11 (24 Mar 2007)
diff --git a/x11-misc/xchm/files/digest-xchm-1.13 b/x11-misc/xchm/files/digest-xchm-1.13
new file mode 100644
index 000000000000..bc6d7489732d
--- /dev/null
+++ b/x11-misc/xchm/files/digest-xchm-1.13
@@ -0,0 +1,3 @@
+MD5 b444e36d6f1c7b3d772d1986ea9929dc xchm-1.13.tar.gz 390882
+RMD160 07ac2962ee5da8a4aceda58fecd4578507a71ed9 xchm-1.13.tar.gz 390882
+SHA256 2419ed4bd3228f5e2b2dc6df341230b90fb334dacd0967dff1e4fd88d23d3a64 xchm-1.13.tar.gz 390882
diff --git a/x11-misc/xchm/files/xchm-1.13.desktop b/x11-misc/xchm/files/xchm-1.13.desktop
new file mode 100644
index 000000000000..58542d3fcf41
--- /dev/null
+++ b/x11-misc/xchm/files/xchm-1.13.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Version=0.9.2
+Name=xCHM
+Comment=Utility for viewing Microsoft .chm files
+Exec=xchm %f
+Icon=xchm
+StartupNotify=true
+Type=Application
+Categories=Office;Viewer;
+MimeType=application/x-chm;
diff --git a/x11-misc/xchm/xchm-1.13.ebuild b/x11-misc/xchm/xchm-1.13.ebuild
new file mode 100644
index 000000000000..fa3b655772b6
--- /dev/null
+++ b/x11-misc/xchm/xchm-1.13.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/xchm-1.13.ebuild,v 1.1 2007/04/25 03:50:04 leio Exp $
+
+inherit wxwidgets flag-o-matic fdo-mime gnome2-utils
+
+DESCRIPTION="Utility for viewing Microsoft .chm files."
+HOMEPAGE="http://xchm.sf.net"
+SRC_URI="mirror://sourceforge/xchm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="nls unicode"
+DEPEND=">=app-doc/chmlib-0.31
+ >=x11-libs/wxGTK-2.6.0"
+# Tested to work against a local install of 2.8.3
+
+src_compile() {
+ local myconf
+ export WX_GTK_VER="2.6"
+
+ if use unicode; then
+ need-wxwidgets unicode
+ else
+ need-wxwidgets gtk2
+ fi
+
+ append-flags -fno-strict-aliasing
+
+ myconf="${myconf} --with-wx-config=${WX_CONFIG}"
+
+ econf ${myconf} \
+ $(use_enable nls) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS README ChangeLog
+
+ # fixes desktop and icon problems
+ rm ${D}/usr/share/pixmaps/xchm-*.xpm ${D}/usr/share/pixmaps/xchmdoc-*.xpm
+
+ dodir /usr/share/icons/hicolor/16x16/apps/
+ install -m 644 ${S}/art/xchm-16.xpm \
+ ${D}/usr/share/icons/hicolor/16x16/apps/xchm.xpm
+ dodir /usr/share/icons/hicolor/32x32/apps/
+ install -m 644 ${S}/art/xchm-32.xpm \
+ ${D}/usr/share/icons/hicolor/32x32/apps/xchm.xpm
+ dodir /usr/share/icons/hicolor/48x48/apps/
+ install -m 644 ${S}/art/xchm-48.xpm \
+ ${D}/usr/share/icons/hicolor/48x48/apps/xchm.xpm
+ dodir /usr/share/icons/hicolor/128x128/apps/
+ install -m 644 ${S}/art/xchm-128.xpm \
+ ${D}/usr/share/icons/hicolor/128x128/apps/xchm.xpm
+ dodir /usr/share/icons/hicolor/16x16/mimetypes/
+ install -m 644 ${S}/art/xchmdoc-16.xpm \
+ ${D}/usr/share/icons/hicolor/16x16/mimetypes/application-x-chm.xpm
+ dodir /usr/share/icons/hicolor/32x32/mimetypes/
+ install -m 644 ${S}/art/xchmdoc-32.xpm \
+ ${D}/usr/share/icons/hicolor/32x32/mimetypes/application-x-chm.xpm
+ dodir /usr/share/icons/hicolor/48x48/mimetypes/
+ install -m 644 ${S}/art/xchmdoc-48.xpm \
+ ${D}/usr/share/icons/hicolor/48x48/mimetypes/application-x-chm.xpm
+ dodir /usr/share/icons/hicolor/128x128/mimetypes/
+ install -m 644 ${S}/art/xchmdoc-128.xpm \
+ ${D}/usr/share/icons/hicolor/128x128/mimetypes/application-x-chm.xpm
+ insinto /usr/share/applications
+ newins ${FILESDIR}/${P}.desktop ${PN}.desktop
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ gnome2_icon_cache_update
+}