summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-02-11 13:44:15 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-02-11 13:44:15 +0000
commitf605e0a3657ab2d7289dfcca14579759e3535a4b (patch)
tree510d45ed61cf34ca6c63ae21ac3ecba8142acb04 /x11-misc/xchm
parentFix segfault on amd64, see bug #112567. (diff)
downloadgentoo-2-f605e0a3657ab2d7289dfcca14579759e3535a4b.tar.gz
gentoo-2-f605e0a3657ab2d7289dfcca14579759e3535a4b.tar.bz2
gentoo-2-f605e0a3657ab2d7289dfcca14579759e3535a4b.zip
Fix bug #117798 - compilation with gcc 4.1.
(Portage version: 2.1_pre4-r1)
Diffstat (limited to 'x11-misc/xchm')
-rw-r--r--x11-misc/xchm/ChangeLog9
-rw-r--r--x11-misc/xchm/files/xchm-gcc41.patch12
-rw-r--r--x11-misc/xchm/xchm-1.2.ebuild13
3 files changed, 30 insertions, 4 deletions
diff --git a/x11-misc/xchm/ChangeLog b/x11-misc/xchm/ChangeLog
index 49dbc441b08c..1668aca24e6b 100644
--- a/x11-misc/xchm/ChangeLog
+++ b/x11-misc/xchm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xchm
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/ChangeLog,v 1.31 2005/11/01 13:08:39 nelchael Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/ChangeLog,v 1.32 2006/02/11 13:44:15 nelchael Exp $
+
+ 11 Feb 2006; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/xchm-gcc41.patch, xchm-1.2.ebuild:
+ Fix bug #117798 - compilation with gcc 4.1, patch by Ryan Hill
+ <dirtyepic.sk@gmail.com>.
01 Nov 2005; Krzysiek Pawlik <nelchael@gentoo.org> xchm-0.9.6.ebuild,
xchm-1.1.ebuild:
diff --git a/x11-misc/xchm/files/xchm-gcc41.patch b/x11-misc/xchm/files/xchm-gcc41.patch
new file mode 100644
index 000000000000..59a046ebbb39
--- /dev/null
+++ b/x11-misc/xchm/files/xchm-gcc41.patch
@@ -0,0 +1,12 @@
+diff -Naur xchm-1.2-orig/src/chmframe.h xchm-1.2/src/chmframe.h
+--- xchm-1.2-orig/src/chmframe.h 2006-01-04 17:40:19.702114632 -0600
++++ xchm-1.2/src/chmframe.h 2006-01-04 17:41:29.929438456 -0600
+@@ -166,7 +166,7 @@
+ void OnPrint(wxCommandEvent& event);
+
+ //! Called when the user selects a file from the file history.
+- void CHMFrame::OnHistFile(wxCommandEvent& event);
++ void OnHistFile(wxCommandEvent& event);
+
+ //! Called when the user types Ctrl-F.
+ void OnFind(wxCommandEvent& event);
diff --git a/x11-misc/xchm/xchm-1.2.ebuild b/x11-misc/xchm/xchm-1.2.ebuild
index 60def95b491e..8bf3b23c1443 100644
--- a/x11-misc/xchm/xchm-1.2.ebuild
+++ b/x11-misc/xchm/xchm-1.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/xchm-1.2.ebuild,v 1.1 2005/10/31 22:14:20 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xchm/xchm-1.2.ebuild,v 1.2 2006/02/11 13:44:15 nelchael Exp $
inherit eutils wxwidgets
@@ -17,6 +17,15 @@ IUSE="doc unicode"
DEPEND=">=app-doc/chmlib-0.31
>=x11-libs/wxGTK-2.6.0"
+src_unpack() {
+
+ unpack "${A}"
+
+ # Fixes bug #117798:
+ epatch "${FILESDIR}/${PN}-gcc41.patch"
+
+}
+
src_compile() {
local myconf
export WX_GTK_VER="2.6"