summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-02-17 15:27:06 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-02-17 15:27:06 +0000
commit290d65ce9ea6ec568c08ee8962be26df7ce9c1b5 (patch)
tree3b1703fc667051dde7b0eb9672aabf7eff5c8ecd /x11-misc/xfe
parentVersion bump (diff)
downloadgentoo-2-290d65ce9ea6ec568c08ee8962be26df7ce9c1b5.tar.gz
gentoo-2-290d65ce9ea6ec568c08ee8962be26df7ce9c1b5.tar.bz2
gentoo-2-290d65ce9ea6ec568c08ee8962be26df7ce9c1b5.zip
Fix building wrt #305093 by Tom Gillespie.
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xfe')
-rw-r--r--x11-misc/xfe/ChangeLog6
-rw-r--r--x11-misc/xfe/files/xfe-1.32.1-inline.patch22
-rw-r--r--x11-misc/xfe/xfe-1.32.1.ebuild7
3 files changed, 33 insertions, 2 deletions
diff --git a/x11-misc/xfe/ChangeLog b/x11-misc/xfe/ChangeLog
index b4a905082543..ba4e1a1aa49d 100644
--- a/x11-misc/xfe/ChangeLog
+++ b/x11-misc/xfe/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/xfe
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.55 2010/02/08 11:49:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/ChangeLog,v 1.56 2010/02/17 15:27:03 ssuominen Exp $
+
+ 17 Feb 2010; Samuli Suominen <ssuominen@gentoo.org> xfe-1.32.1.ebuild,
+ +files/xfe-1.32.1-inline.patch:
+ Fix building wrt #305093 by Tom Gillespie.
*xfe-1.32.1 (08 Feb 2010)
diff --git a/x11-misc/xfe/files/xfe-1.32.1-inline.patch b/x11-misc/xfe/files/xfe-1.32.1-inline.patch
new file mode 100644
index 000000000000..e72b3ef0f593
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-1.32.1-inline.patch
@@ -0,0 +1,22 @@
+http://bugs.gentoo.org/show_bug.cgi?id=305093
+
+--- src/xfeutils.cpp
++++ src/xfeutils.cpp
+@@ -512,7 +512,7 @@
+
+
+ // Replacement of the stat function
+-inline FXint statrep(const FXchar* filename, struct stat* buf)
++FXint statrep(const FXchar* filename, struct stat* buf)
+ {
+ #if defined(linux)
+
+@@ -546,7 +546,7 @@
+
+
+ // Replacement of the lstat function
+-inline FXint lstatrep(const FXchar* filename, struct stat* buf)
++FXint lstatrep(const FXchar* filename, struct stat* buf)
+ {
+ #if defined(linux)
+
diff --git a/x11-misc/xfe/xfe-1.32.1.ebuild b/x11-misc/xfe/xfe-1.32.1.ebuild
index d681518f9347..2fe1ee97f554 100644
--- a/x11-misc/xfe/xfe-1.32.1.ebuild
+++ b/x11-misc/xfe/xfe-1.32.1.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.32.1.ebuild,v 1.1 2010/02/08 11:49:04 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xfe/xfe-1.32.1.ebuild,v 1.2 2010/02/17 15:27:03 ssuominen Exp $
EAPI=2
+inherit eutils
DESCRIPTION="MS-Explorer-like minimalist file manager for X"
HOMEPAGE="http://roland65.free.fr/xfe"
@@ -20,6 +21,10 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-inline.patch
+}
+
src_configure() {
econf \
--disable-dependency-tracking \