summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-10-02 01:05:44 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-10-02 01:05:44 +0000
commit039e6406d4c71a2c94ef4631189fdfee983f87ef (patch)
tree69a13071f5aaec5035a9dd8bb47265360dc6f4bc /x11-misc/xkeyboard-config
parentFix dmx documentation dependency. (diff)
downloadgentoo-2-039e6406d4c71a2c94ef4631189fdfee983f87ef.tar.gz
gentoo-2-039e6406d4c71a2c94ef4631189fdfee983f87ef.tar.bz2
gentoo-2-039e6406d4c71a2c94ef4631189fdfee983f87ef.zip
Version bump.
(Portage version: 2.2.0_alpha53/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/ChangeLog8
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.4.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/xkeyboard-config/ChangeLog b/x11-misc/xkeyboard-config/ChangeLog
index fca9cc6bcad2..98dccfe99853 100644
--- a/x11-misc/xkeyboard-config/ChangeLog
+++ b/x11-misc/xkeyboard-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-misc/xkeyboard-config
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.139 2011/09/21 00:39:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.140 2011/10/02 01:05:44 chithanh Exp $
+
+*xkeyboard-config-2.4 (02 Oct 2011)
+
+ 02 Oct 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xkeyboard-config-2.4.ebuild:
+ Version bump.
21 Sep 2011; Jeroen Roovers <jer@gentoo.org> xkeyboard-config-2.3.ebuild:
Stable for HPPA (bug #380421).
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.4.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.4.ebuild
new file mode 100644
index 000000000000..e9bff3e31370
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-2.4.ebuild,v 1.1 2011/10/02 01:05:44 chithanh Exp $
+
+EAPI=4
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=">=x11-apps/xkbcomp-1.2.1
+ >=x11-libs/libX11-1.4.2"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ >=dev-util/intltool-0.30
+ dev-perl/XML-Parser"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}
+
+src_compile() {
+ # cleanup to make sure .dir files are regenerated
+ # bug #328455 c#26
+ xorg-2_src_compile clean
+ xorg-2_src_compile
+}