summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-04-14 18:27:10 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-04-14 18:27:10 +0000
commitfdc9b3e7961be487634d1d783007f6c9bed7ed9c (patch)
tree546b98d22084b7e1c6daaa81edc8633eff400f5a /x11-misc/xosview/xosview-1.8.3.ebuild
parentVersion bump, see bug #129186. (diff)
downloadgentoo-2-fdc9b3e7961be487634d1d783007f6c9bed7ed9c.tar.gz
gentoo-2-fdc9b3e7961be487634d1d783007f6c9bed7ed9c.tar.bz2
gentoo-2-fdc9b3e7961be487634d1d783007f6c9bed7ed9c.zip
Version bump, see bug #128241.
(Portage version: 2.1_pre7-r5)
Diffstat (limited to 'x11-misc/xosview/xosview-1.8.3.ebuild')
-rw-r--r--x11-misc/xosview/xosview-1.8.3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/xosview/xosview-1.8.3.ebuild b/x11-misc/xosview/xosview-1.8.3.ebuild
new file mode 100644
index 000000000000..38587113a9df
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.8.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xosview/xosview-1.8.3.ebuild,v 1.1 2006/04/14 18:27:10 nelchael Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="X11 operating system viewer"
+SRC_URI="mirror://sourceforge/xosview/${P}.tar.gz"
+HOMEPAGE="http://xosview.sourceforge.net"
+
+SLOT="0"
+LICENSE="GPL-2 BSD"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="|| ( (
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt )
+ virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-proto/xproto virtual/x11 )"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/xosview-emptyxpaths.patch"
+ epatch "${FILESDIR}/xosview-resdir.patch"
+ gnuconfig_update # for ppc64, but no reason to restrict it
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe xosview
+ insinto /etc/X11/app-defaults
+ newins Xdefaults XOsview
+ doman *.1
+ dodoc CHANGES README README.linux TODO
+}