summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-02-08 16:30:51 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-02-08 16:30:51 +0000
commit20a993e9899e92f030551b95f6c6b3305838b7f4 (patch)
treec6423260fc58f39fbba7d0f2a0fd609446e29902 /x11-misc
parentMove clang fbsd profile data to arch/amd64-fbsd. Bug #491654 by Yuta SATOH. (diff)
downloadgentoo-2-20a993e9899e92f030551b95f6c6b3305838b7f4.tar.gz
gentoo-2-20a993e9899e92f030551b95f6c6b3305838b7f4.tar.bz2
gentoo-2-20a993e9899e92f030551b95f6c6b3305838b7f4.zip
version bump requested by ssuominen
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/shared-mime-info/ChangeLog9
-rw-r--r--x11-misc/shared-mime-info/shared-mime-info-1.4.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/x11-misc/shared-mime-info/ChangeLog b/x11-misc/shared-mime-info/ChangeLog
index f56a381551b1..d7c1fd06b36b 100644
--- a/x11-misc/shared-mime-info/ChangeLog
+++ b/x11-misc/shared-mime-info/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/shared-mime-info
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/shared-mime-info/ChangeLog,v 1.213 2014/05/30 14:08:41 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shared-mime-info/ChangeLog,v 1.214 2015/02/08 16:30:51 williamh Exp $
+
+*shared-mime-info-1.4 (08 Feb 2015)
+
+ 08 Feb 2015; William Hubbs <williamh@gentoo.org> +shared-mime-info-1.4.ebuild:
+ version bump requested by ssuominen
30 May 2014; Samuli Suominen <ssuominen@gentoo.org>
-shared-mime-info-1.0.ebuild, -shared-mime-info-1.1.ebuild:
diff --git a/x11-misc/shared-mime-info/shared-mime-info-1.4.ebuild b/x11-misc/shared-mime-info/shared-mime-info-1.4.ebuild
new file mode 100644
index 000000000000..2f3c3e9896ea
--- /dev/null
+++ b/x11-misc/shared-mime-info/shared-mime-info-1.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shared-mime-info/shared-mime-info-1.4.ebuild,v 1.1 2015/02/08 16:30:51 williamh Exp $
+
+EAPI=5
+inherit eutils fdo-mime
+
+DESCRIPTION="The Shared MIME-info Database specification"
+HOMEPAGE="http://freedesktop.org/wiki/Software/shared-mime-info"
+SRC_URI="http://people.freedesktop.org/~hadess/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-libs/glib-2
+ dev-libs/libxml2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( ChangeLog HACKING NEWS README )
+
+src_configure() {
+ export ac_cv_func_fdatasync=no #487504
+
+ econf \
+ $(use_enable test default-make-check) \
+ --disable-update-mimedb
+}
+
+src_compile() {
+ # FIXME: 0.91 fails with -j9 every second time like:
+ # update_mime_database-update-mime-database.o: file not recognized: File truncated
+ # collect2: ld returned 1 exit status
+ emake -j1
+}
+
+src_install() {
+ default
+
+ # in prefix, install an env.d entry such that prefix patch is used/added
+ if use prefix; then
+ echo "XDG_DATA_DIRS=\"${EPREFIX}/usr/share\"" > "${T}"/50mimeinfo
+ doenvd "${T}"/50mimeinfo
+ fi
+}
+
+pkg_postinst() {
+ use prefix && export XDG_DATA_DIRS="${EPREFIX}"/usr/share
+ fdo-mime_mime_database_update
+}